charset=iso-8859-7

Ερωτήσεις και απαντήσεις σχετικές με την HTML, XHTML και την κατασκευή σελίδων για το Web.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Matrox
Δημοσιεύσεις: 287
Εγγραφή: 26 Ιούλ 2004 04:28

charset=iso-8859-7

Δημοσίευση από Matrox » 03 Μαρ 2005 14:27

Γιατί όταν υπάρχει κάποια λέξη που αρχίζει από Α μου τη εμφανίζει σαν:
’ π.χ. ’γαμοι.
Αυτό συμβαίνη στις .html και .php σελίδες και η κωδικοποίηση είναι με charset=iso-8859-7

Άβαταρ μέλους
Paralias
Δημοσιεύσεις: 82
Εγγραφή: 29 Ιαν 2005 20:00

charset=iso-8859-7

Δημοσίευση από Paralias » 03 Μαρ 2005 14:33

Όταν έχεις αυτή την κωδικοποίηση δεν αναγνωρίζει ελληνικά.Αντί για iso-8859-7 γράψε: charset=windows-1253" και θα δουλέψει κανονικά.

zipgr
Δημοσιεύσεις: 109
Εγγραφή: 31 Μαρ 2002 01:00
Τοποθεσία: Θεσσαλονίκη
Επικοινωνία:

charset=iso-8859-7

Δημοσίευση από zipgr » 03 Μαρ 2005 14:36

Απ' ότι φαίνεται charset=iso-8859-7 δεν αναγνωρίζει τον τόνο στα κεφαλαία ελληνικά...

Matrox
Δημοσιεύσεις: 287
Εγγραφή: 26 Ιούλ 2004 04:28

charset=iso-8859-7

Δημοσίευση από Matrox » 03 Μαρ 2005 15:03

Ποιά είναι η διαφορά της
charset=iso-8859-7
και της
charset=windows-1253
κωδικωποίησης

Γιατί εγώ έχω σε όλες τις σελίδες μου και μέχρι τώρα δεν είχα πρόβλημα.
Αν βάλω charset=windows-1253 αντί για charset=iso-8859-, θα υπάρχει πρόβλημα με τα άλλα ελληνικά?

Άβαταρ μέλους
EneMe
Super Moderator
Δημοσιεύσεις: 13307
Εγγραφή: 09 Ιούλ 2002 13:29
Τοποθεσία: Στο κέντρο της Ελλάδας!
Επικοινωνία:

charset=iso-8859-7

Δημοσίευση από EneMe » 03 Μαρ 2005 15:05

Ά <<<Το εμφανίζει σωστά; Περίεργο, γιατί το frestuff έχει iso-8859-7

:hammer:

H iso-8859-7 είναι πιο "γενική", ενώ η άλλη είναι -προφανώς- των windows! :P

Matrox
Δημοσιεύσεις: 287
Εγγραφή: 26 Ιούλ 2004 04:28

charset=iso-8859-7

Δημοσίευση από Matrox » 03 Μαρ 2005 15:11

Μόλις το δοκίμασα χωρίς τόνο και εμφανίζετε εντάξει.
Σε μερικές σελίδες μου δεν έχω πρόβλημα ενώ σε άλλες έχω, και αυτό είναι κάτι που δεν καταλαβαίνω, και να τονίσω ότι όλες έχουν κωδικοποίηση iso-8859-7.
Καμιά ιδέα?

Άβαταρ μέλους
EneMe
Super Moderator
Δημοσιεύσεις: 13307
Εγγραφή: 09 Ιούλ 2002 13:29
Τοποθεσία: Στο κέντρο της Ελλάδας!
Επικοινωνία:

charset=iso-8859-7

Δημοσίευση από EneMe » 03 Μαρ 2005 15:12

Aυτό που έγραψα παραπάνω το βλέπεις κανονικά; Είναι Α με τόνο...

Matrox
Δημοσιεύσεις: 287
Εγγραφή: 26 Ιούλ 2004 04:28

charset=iso-8859-7

Δημοσίευση από Matrox » 03 Μαρ 2005 15:23

Ευχαριστώ για τις απαντήσεις σας.
Μόλις το βρήκα το πρόβλημα.
Κωδικοποίηση iso-8859-7 είχε μόνο η σελίδα που έβλεπε ο επισκέπτης και εμφανιζότανε το πρόβλημα, αλλά στον πίνακα ελέγχου που πρόσθετα το άρθρο στο text area, δεν υπήρχε κωδικοποίηση iso-8859-7 στο head και αυτό ήτανε που δημιουργούσε το πρόβλημα.


Άβαταρ μέλους
skeftomilos
Script Master
Δημοσιεύσεις: 2888
Εγγραφή: 07 Ιαν 2005 07:22
Τοποθεσία: Αθήνα

charset=iso-8859-7

Δημοσίευση από skeftomilos » 04 Μαρ 2005 07:47

Μία μπακάλικη λύση στο πρόβλημα του τονισμένου κεφαλαίου άλφα είναι το 'Α, δηλαδή μονό εισαγωγικό πριν από άτονο κεφαλαίο άλφα.

Matrox τελικά ποιά είναι η λύση του προβλήματος? Δεν κατάλαβα.
Η παρακάτω εντολή πρέπει να βρίσκεται στο head ή δεν πρέπει?

Κώδικας: Επιλογή όλων

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-7">
:question:
Τελευταία επεξεργασία από το μέλος skeftomilos την 04 Μαρ 2005 14:42, έχει επεξεργασθεί 1 φορά συνολικά.
The pure and simple truth is rarely pure and never simple. Ο μη νους δε σκέπτεται μη σκέψεις για το τίποτα.

Άβαταρ μέλους
Tanaka
Δημοσιεύσεις: 174
Εγγραφή: 27 Απρ 2004 21:40
Τοποθεσία: Κορωπί

charset=iso-8859-7

Δημοσίευση από Tanaka » 04 Μαρ 2005 11:00

Το charset windows-1253 λειτουργεί κανονικά και σε μη windows περιβάλλοντα ή είναι καθαρά θέμα browser?

Άβαταρ μέλους
geraki
Honorary Member
Δημοσιεύσεις: 1404
Εγγραφή: 26 Ιαν 2004 20:10
Τοποθεσία: Θεσσαλονίκη
Επικοινωνία:

charset=iso-8859-7

Δημοσίευση από geraki » 04 Μαρ 2005 11:42

Μπορεί κανείς να μας πει γιατί δημιουργεί τόσα προβλήματα ο χαρακτήρας Ά;
Ξέρω php script που κολλάει όταν έχει να επεξεργαστεί ένα string που περιέχει αυτό το χαρακτήρα.
Εικόνα &#8592; Αυτό το έκλεψα απ'τον Eneme.

Matrox
Δημοσιεύσεις: 287
Εγγραφή: 26 Ιούλ 2004 04:28

charset=iso-8859-7

Δημοσίευση από Matrox » 04 Μαρ 2005 14:13

Όπως είπα και πιό πάνω το πρόβλημα ήτανε η κωδικοποίηση στη σελίδα του πίνακα ελέγχου όπου γινότανε η εισαγωγή του κειμένου. Η κωδικοποίηση της σελίδας του πίνακα ελέγχου ήτανε charset=iso-8859-1 και αυτός ήτανε ο λόγος που είχε πρόβλημα το Ά με τόνο, και μόλις άλλαξα το iso-8859-1 σε iso-8859-7 το πρόβλημα λύθηκε.
Να σας πώ πως η σελίδα που εμφάνιζε το κείμενο είχε ήδη κωδικοποίηση iso-8859-7 αλλά είχε πρόβλημα με το Ά.

Άβαταρ μέλους
Paralias
Δημοσιεύσεις: 82
Εγγραφή: 29 Ιαν 2005 20:00

charset=iso-8859-7

Δημοσίευση από Paralias » 04 Μαρ 2005 18:33

Tanaka έγραψε:Το charset windows-1253 λειτουργεί κανονικά και σε μη windows περιβάλλοντα ή είναι καθαρά θέμα browser?
Όταν βάζεις charset=... απλά ορίζεις στον browser αυτού που θα δει τη σελίδα την κωδικοποίηση έτσι ώστε να φαίνονται όλα κανονικά και ειδικά τα ελληνικά.That's all!
Πιστεύω πως πολύ καλύτερα είναι να βάζεις windows-1253.Δε θα έχεις ποτέ πρόβλημα.Απλό!

Άβαταρ μέλους
softius
Script Master
Δημοσιεύσεις: 241
Εγγραφή: 11 Ιαν 2004 19:07
Επικοινωνία:

charset=iso-8859-7

Δημοσίευση από softius » 04 Μαρ 2005 19:15

και το unicode ( utf-8 ) μια χαρά είναι ;)

Απάντηση

Επιστροφή στο “HTML και XHTML”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες