[solved]Πρόβλημα με Alpha

Λύσεις προβλημάτων για το δημοφιλές πρόγραμμα κατασκευής παρουσιάσεων στο διαδίκτυο.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Άβαταρ μέλους
Dazed_and_confused
Δημοσιεύσεις: 743
Εγγραφή: 29 Νοέμ 2003 19:38
Τοποθεσία: Χίος, Θεσσαλονίκη
Επικοινωνία:

[solved]Πρόβλημα με Alpha

Δημοσίευση από Dazed_and_confused » 08 Ιουν 2005 18:01

Λίγη help plzz! :cry:

Προσπαθώ να κάνω ένα κείμενο να ξεθωριάζει βάζοντας σε 2 keyframes 100% kai 0 % Alpha και μετα create motion tween.

Αλλά δεν , μόλις βάζω το create motion tween σε όλο το διάστημα το δείχνει 100%.

Στο Color mixer μου βγάζει αλλάνταλλών

Είμαι με flash mx 2004
Τελευταία επεξεργασία από το μέλος Dazed_and_confused την 30 Ιουν 2005 01:08, έχει επεξεργασθεί 1 φορά συνολικά.

Άβαταρ μέλους
weblink
Δημοσιεύσεις: 133
Εγγραφή: 20 Μάιος 2005 14:25
Τοποθεσία: πάνω από το ποτάμι

[solved]Πρόβλημα με Alpha

Δημοσίευση από weblink » 08 Ιουν 2005 18:10

Κάνεις λάθος στο εξής :
Πρέπει να δημιουργήσεις το Motion tween και μετά να του δώσεις τις τιμές
Επίσης χρειάζεται να έχουν ένα διάστημα κάποιων frames για να δεις την εικόνα να ξεθωριάζει...

Παράδειγμα:
1. έχεις στο 1o frame μια εικόνα κάνε -motion tween- και δώσε alpha = 100%
2. πήγαινε στο frame 10 (για παράδειγμα) και κάνε Insert keyframe
στο frame 10 δώσε τιμή alpha 0%.
Aυτό ήταν.

Ελπίζω να βοήθησα... :wink:

Άβαταρ μέλους
Dazed_and_confused
Δημοσιεύσεις: 743
Εγγραφή: 29 Νοέμ 2003 19:38
Τοποθεσία: Χίος, Θεσσαλονίκη
Επικοινωνία:

[solved]Πρόβλημα με Alpha

Δημοσίευση από Dazed_and_confused » 08 Ιουν 2005 18:28

thanx για την γρήγορα απάντηση!

Τώρα δέχεται τα alpha, δηλάδη στο πρώτο έχει 100%, στο τελευταίο 0%. αλλά στα ενδιάμεσα έχει πάλι 100%.

σαν να μην γίνεται το motion tween

πφ θα σκάσω!

spookyb52
Δημοσιεύσεις: 1891
Εγγραφή: 23 Ιαν 2002 01:00
Τοποθεσία: Lost in the mansion
Επικοινωνία:

[solved]Πρόβλημα με Alpha

Δημοσίευση από spookyb52 » 08 Ιουν 2005 19:11

Συνημμένα
motion.rar
(14.94 KiB) Μεταφορτώθηκε 452 φορές

Άβαταρ μέλους
Dazed_and_confused
Δημοσιεύσεις: 743
Εγγραφή: 29 Νοέμ 2003 19:38
Τοποθεσία: Χίος, Θεσσαλονίκη
Επικοινωνία:

[solved]Πρόβλημα με Alpha

Δημοσίευση από Dazed_and_confused » 08 Ιουν 2005 19:28

Ωραία το κάνες βρε spooky αλλά εμένα συνεχίζει το πρόβλημα :)

έχω δοκιμάσει και σχεδόν όλους τους συνδιασμούς (πρώτα το tween, μετά, κλπ) αλλά δεν.

μήπως είναι προβληματική η version?

spookyb52
Δημοσιεύσεις: 1891
Εγγραφή: 23 Ιαν 2002 01:00
Τοποθεσία: Lost in the mansion
Επικοινωνία:

[solved]Πρόβλημα με Alpha

Δημοσίευση από spookyb52 » 08 Ιουν 2005 19:47

Φτιάξε πρώτα το tween. Στη συνέχεια επέλεξε το movie που γίνεται tween στο keyframe που θές και από τα properties επέλεξε alpha.
Life is like a fast car on an icy road. Brakes don't work, yes I know it, but I step on the gas
Garage punk | Rockabilly | Rock 'n' Roll | Stoner

Άβαταρ μέλους
Rapid-eraser
WebDev Moderator
Δημοσιεύσεις: 6851
Εγγραφή: 05 Απρ 2003 17:50
Τοποθεσία: Πειραιάς
Επικοινωνία:

[solved]Πρόβλημα με Alpha

Δημοσίευση από Rapid-eraser » 08 Ιουν 2005 19:48

avamesa sta dio key frames exei eva baleaki pou ksekivaei apo to proto kai kataligei sto feftero ?
Cu, Rapid-eraser, Tα αγαθά copies κτώνται.
Love is like oxygen, You get too much you get too high
Not enough and you're gonna die, Love gets you high

spookyb52
Δημοσιεύσεις: 1891
Εγγραφή: 23 Ιαν 2002 01:00
Τοποθεσία: Lost in the mansion
Επικοινωνία:

[solved]Πρόβλημα με Alpha

Δημοσίευση από spookyb52 » 08 Ιουν 2005 20:11

Πρέπει όλα τα frames να είναι σε κατάσταση motion tween μπορεί να έχεις ξεχάσει κάποιο. Ίσως το τελευταίο keyframe. Πάτησε πάνω στο keyframe και δές από τα properties άν είναι motion tween. Όλα τα frames σε ένα Motion animation έχουν μώβ χρώμα. Άν το τελευταίο είναι γκρίζο τότε δέν είναι μέρος του tween. Κατά 99% αυτό έχεις κάνει.

Άβαταρ μέλους
weblink
Δημοσιεύσεις: 133
Εγγραφή: 20 Μάιος 2005 14:25
Τοποθεσία: πάνω από το ποτάμι

[solved]Πρόβλημα με Alpha

Δημοσίευση από weblink » 08 Ιουν 2005 20:14

Λοιπόν βήμα βήμα...

1.Σε ένα άδειο frame (frame 1) βάλε μια φωτογραφία...
2.Δεξι κλικ πάνω στο frame και επιλέγεις create motion tween...
3.Πηγαίνεις στο timeline στο frame 10 (δεν υπάρχει - τώρα θα το δημιουργήσεις) και επιλέγεις insert keyframe.
4.Στο πρώτο frame επιλέγεις alpha=100% και στο δέκατο alpha=0%

Αν κάνεις αυτά και δεν δουλέψει κάπου αλλου υπάρχει πρόβλημα...

Αμα θέλεις στείλε μου το fla να στο φτιάξω (με mail - info@weblink.gr)

(ΥΓ. Καθυστερημένα έγγραψα το μήνυμα - Δεν είχα δει ότι είχατε απαντήσει κιόλας ρε τσακάλια!!! :o :clap: :clap: :victory: )

Άβαταρ μέλους
Dazed_and_confused
Δημοσιεύσεις: 743
Εγγραφή: 29 Νοέμ 2003 19:38
Τοποθεσία: Χίος, Θεσσαλονίκη
Επικοινωνία:

[solved]Πρόβλημα με Alpha

Δημοσίευση από Dazed_and_confused » 09 Ιουν 2005 02:07

Έχουν motion tween όλα τα frames .

Τα υπόλοιπα τα έκανα αλλά δεν.

μήπως φταίει που δεν ειναι αγορασμένο?

Άβαταρ μέλους
xultimatex
Honorary Member
Δημοσιεύσεις: 2505
Εγγραφή: 26 Ιούλ 2003 13:02
Τοποθεσία: Ξάνθη
Επικοινωνία:

[solved]Πρόβλημα με Alpha

Δημοσίευση από xultimatex » 09 Ιουν 2005 11:31

Στο flash έχει μια υποσημείωση που λέει πως τα motion tweens δε θα γίνουν σε layers που έχουν χύμα σχήματα(χωρίς να είναι grouped ή μετετραμένα σε movie clip) ή σε layers που υπάρχουν παραπάνω από ένα movie clip.
:arrow: Αν προσπαθείς πολύ για να πετύχεις κάτι, ίσως το κάνεις με λάθος τρόπο...

Άβαταρ μέλους
Dazed_and_confused
Δημοσιεύσεις: 743
Εγγραφή: 29 Νοέμ 2003 19:38
Τοποθεσία: Χίος, Θεσσαλονίκη
Επικοινωνία:

[solved]Πρόβλημα με Alpha

Δημοσίευση από Dazed_and_confused » 15 Ιουν 2005 02:26

πφ τι πρόβλημα κι αυτό!

έχει κανείς άλλος καμία ιδέα τι φταίει?

Άβαταρ μέλους
Knorcedger
Script Master
Δημοσιεύσεις: 1226
Εγγραφή: 18 Μάιος 2004 04:29
Επικοινωνία:

[solved]Πρόβλημα με Alpha

Δημοσίευση από Knorcedger » 15 Ιουν 2005 02:33

Αν θες ανέβασε ένα αρχείο fla, για να το δουμε και να στο φτιάξουμε.
Εικόνα
myUbuntu.gr[Ελληνικός οδηγός για Ubuntu]

Άβαταρ μέλους
Pixelatorios
Δημοσιεύσεις: 457
Εγγραφή: 05 Δεκ 2004 16:01
Τοποθεσία: Berlin - Thes/niki
Επικοινωνία:

[solved]Πρόβλημα με Alpha

Δημοσίευση από Pixelatorios » 15 Ιουν 2005 02:51

Dazed_and_confused έγραψε:Έχουν motion tween όλα τα frames .
Τα υπόλοιπα τα έκανα αλλά δεν.
μήπως φταίει που δεν ειναι αγορασμένο?
καταρχάς δεν πεζή κανένα ρολο εάν αγορά... η .. παράνο.

Το πρόβλημα σου είναι αλλου.
τα frame/tween σου είναι με το 100% alpha... κοίταξε τα tween ένα ένα..και χαμήλωσε τα ποσοστά.
motion. web. print. designer

Άβαταρ μέλους
Dazed_and_confused
Δημοσιεύσεις: 743
Εγγραφή: 29 Νοέμ 2003 19:38
Τοποθεσία: Χίος, Θεσσαλονίκη
Επικοινωνία:

[solved]Πρόβλημα με Alpha

Δημοσίευση από Dazed_and_confused » 15 Ιουν 2005 02:52

Thanx αλλά δεν είναι αυτό το πρόβλημα :)

Απάντηση

Επιστροφή στο “Flash γενικά”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες