Opera 8.5 link bug

Ερωτήσεις και απαντήσεις σχετικές με την HTML, XHTML και την κατασκευή σελίδων για το Web.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Άβαταρ μέλους
skeftomilos
Script Master
Δημοσιεύσεις: 2888
Εγγραφή: 07 Ιαν 2005 07:22
Τοποθεσία: Αθήνα

Opera 8.5 link bug

Δημοσίευση από skeftomilos » 08 Οκτ 2005 07:55

Απ' όσα γνώριζα μέχρι χθες είναι δυνατό να υπάρχει ένα link της μορφής href="?name=bill" το οποίο φορτώνει την ίδια σελίδα με διαφορετικό QueryString. Δηλαδή αν είμαστε στη σελίδα http://foo.gr/index.htm?id=5 και πατήσουμε αυτό το link, η διεύθυνση θα αλλάξει και θα γίνει http://foo.gr/index.htm?name=bill. Σήμερα όμως δοκίμασα κάποια παλιά demos με Opera 8.5 και αυτό που είδα έκανε να σηκωθούν στον αέρα τα μαλλιά της κεφαλής μου! Το url άλλαξε σε http://foo.gr/index.htm?id=5?name=bill, δηλαδή προστίθεται στο υπάρχον QueryString αντί να αντικαθιστά! :o Επειδή έχω την εντύπωση ότι αυτό δε συνέβαινε με τις παλαιότερες εκδόσεις του Opera, παρακαλώ όσοι έχετε ακόμα κάποια παλιά έκδοση δοκιμάστε το παρακάτω demo για να δείτε αν λειτουργεί σωστά ή όχι:

- Demo

Κώδικας: Επιλογή όλων

<html>
  <head>
    <title>Opera-Link-Bug</title>
  </head>
  <body>
    <h2>Opera-Link-Bug</h2>
    <a href="?name=bill">?name=bill</a><br>
    <a href="?name=mary">?name=mary</a><br>
  </body>
</html>
The pure and simple truth is rarely pure and never simple. Ο μη νους δε σκέπτεται μη σκέψεις για το τίποτα.

Άβαταρ μέλους
xultimatex
Honorary Member
Δημοσιεύσεις: 2505
Εγγραφή: 26 Ιούλ 2003 13:02
Τοποθεσία: Ξάνθη
Επικοινωνία:

Opera 8.5 link bug

Δημοσίευση από xultimatex » 08 Οκτ 2005 11:20

Εγώ που το δοκίμασα με Opera 8.5 σαν τη δικιά σου το queystring αντικαταστάθηκε κανονικότατα. :think:
:arrow: Αν προσπαθείς πολύ για να πετύχεις κάτι, ίσως το κάνεις με λάθος τρόπο...


Άβαταρ μέλους
skeftomilos
Script Master
Δημοσιεύσεις: 2888
Εγγραφή: 07 Ιαν 2005 07:22
Τοποθεσία: Αθήνα

Opera 8.5 link bug

Δημοσίευση από skeftomilos » 08 Οκτ 2005 23:03

Τότε μάλλον είναι ματιασμένος ο Opera μου. :( Δε νομίζω να έκανα κάτι στραβό στο installation. Απλά απεγκατέστησα την προηγούμενη έκδοση (8.0) και έτρεξα το setup της νέας (8.5, 7700).
The pure and simple truth is rarely pure and never simple. Ο μη νους δε σκέπτεται μη σκέψεις για το τίποτα.

Απάντηση

Επιστροφή στο “HTML και XHTML”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες