Ασκήσεις

Γενικά θέματα για τις γλώσσες προγραμματισμού που δεν καλύπτονται από τις άλλες περιοχές της κατηγορίας.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Άβαταρ μέλους
xmavidis
Honorary Member
Δημοσιεύσεις: 1217
Εγγραφή: 02 Δεκ 2003 19:59
Τοποθεσία: Ηράκλειο

Ασκήσεις

Δημοσίευση από xmavidis » 30 Οκτ 2005 23:40

Ορίστε και η λύση του προβλήματος που έθεσα:

Κώδικας: Επιλογή όλων

!!
!! Nα γίνει πρόγραμμα που αφού διαβάσει μια γωνία
!! θα βρίσκει και θα εμφανίζει το ημίτονο και το συνημίτονο
!!  της γωνίας.
!! Στη συνέχεια να εμφανίζει σε πιο τεταρτημόριο βρίσκεται.
!! Τέλος, υπολογίζει τη τιμή της παράστασης:
!!        - |- -  2ημ3χ, αν χΕ[0,90]
!!        - |- -  |ημχ - συνχ|, αν χΕ(90,180]
!!  f(x)  {
!!        - |- -  2 + 3ημχ - συνχ , αν χΕ(180,270] 
!!        - |- -  2συν3χ , αν χΕ(270,360)
!!

ΠΡΟΓΡΑΜΜΑ ΑΣΚΗΣΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:χ,υ,ι,ρ,fx

ΑΡΧΗ
  Γράψε 'Δώσε γωνία'
  Διάβασε χ

  ! Υπολογίζουμε τους τριγωνομετρικούς αριθμούς
  υ <-- ΗΜ&#40;χ&#41;
  ι <-- ΣΥΝ&#40;χ&#41;
  ! ... και τους εμφανίζουμε
  Γράψε 'Ημίτονο ',χ,'&#58; ',υ
  Γράψε 'Συνημίτονο ',χ,'&#58; ',ι

  ! Για να βρούμε το τεταρτημόριο διαιρούμε &#40;DIV&#41; τη γωνία με το 360
  χ <-- χ / 360

  ! Ελέγχουμε...
  Αν χ<=90 τότε
    ρ <-- 1
  αλλιώς_αν χ<=180    τότε
    ρ <-- 2
  αλλιώς_αν χ<=270   τότε
    ρ <-- 3
  αλλιώς
    ρ <-- 4
  τέλος_αν
  Γράψε 'Τεταρτημόριο&#58;',ρ,'ο'

  ! Και η παράσταση...
  Αν ρ=1 τότε
    fx <-- 2* ΗΜ&#40;3*χ&#41;
  αλλιώς_αν ρ=2 τότε
    fx <-- Α_Τ&#40; ΗΜ&#40;χ&#41; - ΣΥΝ&#40;χ&#41; &#41;
  αλλιώς_αν ρ=3 τότε
    fx <-- 2+3* ΗΜ&#40;χ&#41;-ΣΥΝ&#40;χ&#41;
  αλλιώς
    fx <-- 2* ΣΥΝ&#40;3*χ&#41;
  τέλος_αν

  Γράψε 'f&#40;x&#41; = ', fx

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΑΣΚΗΣΗ
I want to know God’s thoughts; the rest are details.
Albert Einstein

Άβαταρ μέλους
dva_dev
Script Master
Δημοσιεύσεις: 3790
Εγγραφή: 16 Σεπ 2005 01:32
Επικοινωνία:

Ασκήσεις

Δημοσίευση από dva_dev » 31 Οκτ 2005 01:22

:think:
Γιατί έχω την εντύπωση ότι αυτή η λύση δίνει σωστά αποτελέσματα μόνο για γωνία 0 μοίρες;
:think:

Άβαταρ μέλους
xmavidis
Honorary Member
Δημοσιεύσεις: 1217
Εγγραφή: 02 Δεκ 2003 19:59
Τοποθεσία: Ηράκλειο

Ασκήσεις

Δημοσίευση από xmavidis » 04 Νοέμ 2005 21:58

Το δοκίμασα στη γλωσσομάθεια και δούλευε άψογα.
I want to know God’s thoughts; the rest are details.
Albert Einstein

Άβαταρ μέλους
dva_dev
Script Master
Δημοσιεύσεις: 3790
Εγγραφή: 16 Σεπ 2005 01:32
Επικοινωνία:

Ασκήσεις

Δημοσίευση από dva_dev » 05 Νοέμ 2005 03:11

...
! Για να βρούμε το τεταρτημόριο διαιρούμε (DIV) τη γωνία με το 360
χ <-- χ / 360

! Ελέγχουμε...
...
Για να βγάζει σωστό αποτέλεσμα το πρόγραμμα αυτό πρέπει:
Αν Κ1 = χ (πριν τη διαίρεση)
και Κ2 = χ (μετά τη διαίρεση)

1) ΗΜ(Κ1) = ΗΜ(Κ2) ΚΑΙ
2) ΣΥΝ(Κ1) = ΣΥΝ(Κ2),
3) ΚΑΙ Κ1,Κ2 να ανήκουν στο ιδιο τεταρτημόριο.

δηλαδή
ΗΜ(χ) = ΗΜ(χ/360) ΚΑΙ
ΣΥΝ(χ) = ΣΥΝ(χ/360) ΚΑΙ
χ, χ/360 να ανήκουν στο ιδιο τεταρτημόριο.

Λίγο δύσκολο μου φαίνεται να ισχύει γενικά.
(Αρκεί να το δοκιμάσεις με τα νούμερα 0,90,180,360)

Αλλά για να αναφέρεις ότι το έχεις δοκιμάσει και δουλεύει σωστά τότε μπορώ να υποθέσω μόνο τα εξής:
α) Δεν έχεις δοκιμάσει το πρόγραμμα παρά μόνο με 1 ή 2 τιμές που έτυχε να βγάζουν σωστά αποτελέσματα.
β) Το πρόγραμμα το έχεις δοκιμάσει και δουλεύει σωστά αλλά δεν είναι αυτό που αναφέρεις στο προηγούμενο post σου.
γ) Αν το πρόγραμμα το έχεις δοκιμάσει, δουλεύει σωστά και είναι αυτό που αναφέρεις στο προηγούμενο post σου, ε, τότε κάτι πάει στραβά με τη ΓΛΩΣΣΑ.

Απάντηση

Επιστροφή στο “γλώσσες προγραμματισμού - γενικά”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης