Κωδικοποίση Unicode

Ερωτήσεις και απαντήσεις σχετικές με την HTML, XHTML και την κατασκευή σελίδων για το Web.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
kostas71gr
Δημοσιεύσεις: 8
Εγγραφή: 15 Ιούλ 2001 03:00

Κωδικοποίση Unicode

Δημοσίευση από kostas71gr » 13 Μαρ 2006 02:06

Χαίρετε...

Εχω ένα πρόβλημα και θέλω βοήθεια...
Το πρόβλημα είναι ότι αν κάποιος επισκεφτεί ένα σαιτ που ετοιμάζω και έχει κωδικοποίηση Unicode δεν εμφανίζετε τίποτα παρά μόνο μια λευκή σελίδα !

Αν διαλέξει άλλη κωδικοποίηση όλα καλά μια χαρά

Στα meta tags έχω Ελληνικά !
<META http-equiv=Content-Type content="text/html; charset=windows-1253">

Είναι από εδώ το πρόβλημα αν το αλλάξω με unicode θα εμφανίζονται όλα σωστά;

Δεν τολμώ να το αλλάξω γιατί φοβάμαι ότι υπάρχει περίπτωση να μην εμφανίζονται σωστά μετά τα Ελληνικά και χρειάζετε να τα ξαναγράψω.

Αν μπορείτε να μου πείτε που είναι το πρόβλημα και να βοηθήσετε...

Ευχαριστώ

Άβαταρ μέλους
alkisg
Δημοσιεύσεις: 265
Εγγραφή: 03 Ιουν 2005 11:53
Τοποθεσία: Ιωάννινα
Επικοινωνία:

Κωδικοποίση Unicode

Δημοσίευση από alkisg » 13 Μαρ 2006 15:02

Κάποιο bug είχε ο IE 6, πρέπει να βάλεις πρώτα το meta content και μετά το TITLE, αλλιώς χαζεύει και δε δείχνει τίποτα.

kostas71gr
Δημοσιεύσεις: 8
Εγγραφή: 15 Ιούλ 2001 03:00

Κωδικοποίση Unicode

Δημοσίευση από kostas71gr » 14 Μαρ 2006 01:28

tipota pali ta idia kanei

Άβαταρ μέλους
skeftomilos
Script Master
Δημοσιεύσεις: 2888
Εγγραφή: 07 Ιαν 2005 07:22
Τοποθεσία: Αθήνα

Κωδικοποίση Unicode

Δημοσίευση από skeftomilos » 14 Μαρ 2006 07:46

Το πρόβλημα υπάρχει μόνο με τον Internet Explorer ή και με άλλους browsers; Π.χ. Firefox.
The pure and simple truth is rarely pure and never simple. Ο μη νους δε σκέπτεται μη σκέψεις για το τίποτα.


Άβαταρ μέλους
milianos
Δημοσιεύσεις: 269
Εγγραφή: 11 Νοέμ 2004 01:39
Τοποθεσία: schwabenland
Επικοινωνία:

Κωδικοποίση Unicode

Δημοσίευση από milianos » 14 Μαρ 2006 09:53

kostas71gr έγραψε: ...Το πρόβλημα είναι ότι αν κάποιος επισκεφτεί ένα σαιτ που ετοιμάζω και έχει κωδικοποίηση Unicode δεν εμφανίζετε τίποτα παρά μόνο μια λευκή σελίδα...
Αυτό ισχύει για όλους, δεν εξαρτάται από εσένα και δεν είναι πρόβλημα. Εσυ φτιάξε το site βάλε την σωστή κωδικοποίηση π.χ <meta http-equiv="content-type" content="text/html; charset=iso-8859-7"> και μη φοβάσαι, νομίζω είναι το τελευταίο πράγμα που θα πρέπει να σε απασχολεί. :lol:

Άβαταρ μέλους
Cue
Δημοσιεύσεις: 19
Εγγραφή: 12 Απρ 2005 17:07
Επικοινωνία:

Κωδικοποίση Unicode

Δημοσίευση από Cue » 14 Μαρ 2006 11:38

Για κάνε paste τι έχεις στο head ακριβώς.
Αν χρησιμοποιείς javascript αντί για το notation
<script ... />
χρησιμοποίησε κανονικό closing tag.
<script></script>
Εικόνα

kostas71gr
Δημοσιεύσεις: 8
Εγγραφή: 15 Ιούλ 2001 03:00

Κωδικοποίση Unicode

Δημοσίευση από kostas71gr » 14 Μαρ 2006 17:24

Το κάνω με το front page παιδιά

Μπορεί να φταίει αυτό;


<HTML><HEAD>
<meta http-equiv="Content-Language" content="el">
<TITLE></TITLE>
<META http-equiv=Content-Type content="text/html; charset=windows-1253">


Εδώ είναι όλα εντάξει;

Άβαταρ μέλους
skeftomilos
Script Master
Δημοσιεύσεις: 2888
Εγγραφή: 07 Ιαν 2005 07:22
Τοποθεσία: Αθήνα

Κωδικοποίση Unicode

Δημοσίευση από skeftomilos » 14 Μαρ 2006 23:59

Άβυσσος η ψυχή του FrontPage. :)
The pure and simple truth is rarely pure and never simple. Ο μη νους δε σκέπτεται μη σκέψεις για το τίποτα.

Άβαταρ μέλους
Cue
Δημοσιεύσεις: 19
Εγγραφή: 12 Απρ 2005 17:07
Επικοινωνία:

Κωδικοποίση Unicode

Δημοσίευση από Cue » 16 Μαρ 2006 14:56

Μισό γιατί προσωπικά μπερδέυτηκα.
Τα περιεχόμενα της σελίδας σε τι encoding είναι?

Βλέπω ότι έχεις δηλώσει το encoding σωστά* ελληνικά (win), τότε για πιο λόγο κάποιος να βάλει Unicode? (ο browser θα αντιληφτεί σωστά το encoding)

*αν και λείπουν τα εισαγωγικά στο http-equiv=Content-Type.
Εικόνα

Απάντηση

Επιστροφή στο “HTML και XHTML”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες