προβλημα με κωδικα swf

Λύσεις προβλημάτων για το δημοφιλές πρόγραμμα κατασκευής παρουσιάσεων στο διαδίκτυο.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Άβαταρ μέλους
wwf
Δημοσιεύσεις: 593
Εγγραφή: 16 Οκτ 2005 15:13
Τοποθεσία: THESS
Επικοινωνία:

προβλημα με κωδικα swf

Δημοσίευση από wwf » 14 Απρ 2006 12:03

Εχω ενα προβλημα και δεν ξερω τι να κανω..


Εχω καποια εξωτερικα sfw που καλω και δεν τα ανεβαζει εχω βαλει κωδικα..

π.χ
on (release)
{
loadMovieNum("info.swf", 1);
}

αλλα το τρελο ειναι οτι με internet explorer παιζει αλλα με firefox οχι ουτε με mac δεν τα διχνει που δωκιμασα..

το site ειναι www.hotel-anastasia.com

Άβαταρ μέλους
wwf
Δημοσιεύσεις: 593
Εγγραφή: 16 Οκτ 2005 15:13
Τοποθεσία: THESS
Επικοινωνία:

προβλημα με κωδικα swf

Δημοσίευση από wwf » 14 Απρ 2006 17:12

kaneis bre paidia

Άβαταρ μέλους
cpulse
Script Master
Δημοσιεύσεις: 1527
Εγγραφή: 21 Μαρ 2006 19:30
Τοποθεσία: Αθήνα village
Επικοινωνία:

προβλημα με κωδικα swf

Δημοσίευση από cpulse » 17 Απρ 2006 01:03

Μήπως το καλείς με την σωστή μέθοδο για IE (<object>) αλλά όχι και με την σωστή μέθοδο για mozilla (<embed>) ;

Για να είναι συμβατό πρέπει να κληθεί και με τους δύο τρόπους .. και μάλιστα να γράψεις τις απαραίτητες πληροφορίες δύο φορές.

Κώδικας: Επιλογή όλων

<object classid="clsid&#58;d27cdb6e-ae6d-11cf-96b8-444553540000"
  codebase="http&#58;//download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0"
  width="VAR_WIDTH" height="VAR_HEIGHT" id="VAR_ID" align="VAR_ALIGN">
  <param name="movie" value="VAR_FILENAME" />
  <embed src="VAR_FILENAME" quality="high" 
    width="VAR_WIDTH" height="VAR_HEIGHT" 
    name="VAR_ID" align="VAR_ALIGN" type="application/x-shockwave-flash"
    pluginspage="http&#58;//www.macromedia.com/go/getflashplayer" />
</object>
(αντικατέστησε όλα τα VAR_* με τις σωστές τιμές)

Απάντηση

Επιστροφή στο “Flash γενικά”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες