Mysql /php πρόβλημα με ???? σε χαρακτήρες, θέμα iconv?

Σε αυτή την περιοχή μπορείτε να βρείτε ή να αναζητήσετε πληροφορίες σχετικές με την PHP

Συντονιστές: WebDev Moderators, Super-Moderators, PHP Moderators

Απάντηση
nastis
Δημοσιεύσεις: 124
Εγγραφή: 16 Φεβ 2005 16:28
Επικοινωνία:

Mysql /php πρόβλημα με ???? σε χαρακτήρες, θέμα iconv?

Δημοσίευση από nastis » 02 Μάιος 2006 13:33

Έχω ένα site σε php/mysql και η βάση είναι (κακώς) σε latin1 και μέσα έχει ελληνικά που παίζουνε μια χαρά με
<meta http-equiv="Content-Type" content="text/html;charset=iso-8859-7" />
στη σελίδα

εγώ θέλω να κάνω την μεταφορά σε μια άλλη βάση που έχει utf8
αμα κάνω ένα απλό dump και την ξαναβάλω θα μου βάζει τους ελληνικούς τονισμένους χαρακτηρες σε "?" ερωτηματικά.
με λίγο ψάξιμο είδα ότι πρέπει να παίξω με την iconv στην php αλλά εάν κατάλαβα καλά πρέπει να μετατρέψω όλα ένα ένα.(?)

Υπάρχει κάποιος τρόπος να το κάνω ευκολότερα?

Σκέφτηκα να αλλάξω και την βάση που έχω ήδη (latin1) να την μετατρέψω σε utf8
αλλάζοντας το my.ini και βάζοντας

default-character-set=utf8
character_set_client =utf8
character_set_connection =utf8
character_set_database = utf8
character_set_results=utf8
character_set_server = utf8
character_set_system = utf8

αλλά αυτό δεν θα άλλαζε/μετέτρεπε τα υπάρχοντα.

Καμιά ιδέα??

Β/
www.oktonia.com - Παγκόσμιο Χωριό Γνώσης Λυμένα Θέματα Εξετάσεων - Ασκήσεις

sofrr
Δημοσιεύσεις: 50
Εγγραφή: 20 Δεκ 2005 21:22
Τοποθεσία: Πειραιάς

Mysql /php πρόβλημα με ???? σε χαρακτήρες, θέμα iconv?

Δημοσίευση από sofrr » 02 Μάιος 2006 14:03

Ρίξε μια ματιά εδώ.

Απάντηση

Επιστροφή στο “PHP Προγραμματισμός”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες