Πρόβλημα με movieclip που αποτελείται από buttons

Λύσεις προβλημάτων για το δημοφιλές πρόγραμμα κατασκευής παρουσιάσεων στο διαδίκτυο.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
eleni m
Δημοσιεύσεις: 13
Εγγραφή: 09 Απρ 2006 20:22
Τοποθεσία: athens

Πρόβλημα με movieclip που αποτελείται από buttons

Δημοσίευση από eleni m » 02 Μάιος 2006 22:22

Καλησπέρα σε όλους! Αντιμετωπίζω ένα μικρό πρόβλημα και θα ήθελα βοήθεια !!!
Φτιάχνω ένα site που περιέχει διάφορες κατηγορίες με φωτογραφίες... Κάθε κατηγορία είναι και ένα movieclip που αποτελείται από 3 μέχρι 40 φωτογραφίες... Κάθε φώτο την έχω κάνει button ώστε πατώντας πάνω της,όταν βρίσκεται το movieclip στο scene, να εμφανίζεται η φώτο πιο μεγάλη... Την εντολή για να το κάνω αυτό, την βρήκα...
π.χ. on (release) {_root.attachMovie ("idname","newname", level);
newname._x=450
newname._y=100
}
ώστε να εμφανίζεται η μεγάλη εικόνα σε συγκεκριμένη θέση

Το πρόβλημά μου είναι άλλο: Τον κώδικα που πρέπει να τον βάλω; Στο scene ή στο edit mode του movieclip? Οταν φέρνω το movieclip στο scene, πρέπει να το κάνω break apart για να μπορέσω να βάλω τον κώδικα ξεχωριστά σε κάθε φώτο-button... Οταν το κάνω αυτό, ναι μεν η εικόνα εμφανίζεται στη θέση που θέλω ΑΛΛΑ το movieclip δεν μετακινείται πλέον δεξιά ή αριστερά με τα βελάκια γιατί δεν το βλέπουν πλέον σαν movieclip... Ξέχασα να πω ότι στο scene έχω βάλει βελάκια για την μετακίνηση των movieclips ώστε ο χρήστης να βλέπει όλες τις φώτο.
Οταν βάζω τον κώδικα στο edit mode του movieclip, ναι μεν λειτουργεί κανονικά, και την εικόνα εμφανίζει και το movieclip μετακινείται κανονικά με τα βελάκια ΑΛΛΑ την εικόνα την εμφανίζει στην πάνω δεξιά γωνία του site... Δηλαδή δεν διαβάζει καθόλου τα "idname._x=450 idname._y=100"...

Εχω πελαγώσει... Πάνω που λύνω το ένα πρόβλημα, εμφανίζεται άλλο...
Μήπως μπορεί κάποιος να διευκολύνει την κατάσταση; Πολύ θα το εκτιμούσα...

Σας ευχαριστώ...

spookyb52
Δημοσιεύσεις: 1891
Εγγραφή: 23 Ιαν 2002 01:00
Τοποθεσία: Lost in the mansion
Επικοινωνία:

Πρόβλημα με movieclip που αποτελείται από buttons

Δημοσίευση από spookyb52 » 03 Μάιος 2006 13:34

Αχά...Εικόνα ...μάλιστα Εικόνα

Ελένη και εγώ έχω πελαγώσει Εικόνα

Αυτό είναι σάν γρίφος! Θα χρειαστόύμε πρώτα μια βοήθεια από εσένα για να κατανοήσουμε καλύτερα τί θές και πώς είναι το flashaki σου. :wink: Εσένα μπορεί να σου φαίνεται κατανοητό αλλά για εμάς που δέν έχουμε ιδέα πώς είναι το flash είναι δύσκολο να ακολουθήσουμε την σκέψη σου.

Εικόνα

Ένα σχεδιάγραμμα ίσως να βοηθούσε :P
Life is like a fast car on an icy road. Brakes don't work, yes I know it, but I step on the gas
Garage punk | Rockabilly | Rock 'n' Roll | Stoner

eleni m
Δημοσιεύσεις: 13
Εγγραφή: 09 Απρ 2006 20:22
Τοποθεσία: athens

Πρόβλημα με movieclip που αποτελείται από buttons

Δημοσίευση από eleni m » 03 Μάιος 2006 23:50

Πάλι μπερδεμένα τα είπα; φτουουουου.... :doh:

Στέλνω μια επισύναψη σε .swf μορφή για να καταλάβεις τι θέλω να κάνω...

Είναι ένα movieclip που περιέχει φωτογραφίες (στην επισύναψη έχω βάλει χρωματιστά παραλληλόγραμμα), τις οποίες έχω μετατρέψει σε buttons (στην επισύναψη το έχω κάνει μόνο στο κουτάκι με το Νο 1)... Οπότε όταν πατάω πάνω στη φωτο-button να εμφανίζεται η ίδια φωτο σε μεγαλύτερο μέγεθος, μπροστά από το movieclip... Τι γίνεται όμως; Εχω βάλει τον κώδικα στη φωτο-button, στο edit mode του movieclip... Ναι μεν λειτουργεί κανονικά, εμφανίζει τη μεγάλη φωτο αλλά την εμφανίζει στην πάνω δεξιά γωνία (όπως θα διαπιστώσεις αν πατήσεις πάνω στο κουτί με το Νο1), ενώ εγώ έχω βάλει στον κώδικα, να την εμφανίζει σε συγκεκριμένη θέση...
Γιατί δεν δέχεται τις ρυθμίσεις που του βάζω;
Συνημμένα

emblems_dokimi.swf [ 1.29 KiB | Προβλήθηκε 1680 φορές ]


spookyb52
Δημοσιεύσεις: 1891
Εγγραφή: 23 Ιαν 2002 01:00
Τοποθεσία: Lost in the mansion
Επικοινωνία:

Πρόβλημα με movieclip που αποτελείται από buttons

Δημοσίευση από spookyb52 » 04 Μάιος 2006 12:42

Το κοίταξα πολύ βιαστικά γιατί πρέπει να φύγω σε λίγο αλλά με μιά ματιά
on (release) {
_root.attachMovie ("idname","newname", level);
_root.newname._x=450
_root.newname._y=100
}

Δέν έχεις δώσει σωστή διαδρομή. Το αντικείμενό σου έχει δημιουργηθεί στο main timeline (_root) αλλά εσύ στη συνέχεια το αναζητείς σε άλλο path μέσα στο clip. Προσθέτεις ένα _root μπροστά από τις επόμενες 2 γραμμές όπως δείχνω με κόκκινο στο πλαίσιo από πάνω. ^
Life is like a fast car on an icy road. Brakes don't work, yes I know it, but I step on the gas
Garage punk | Rockabilly | Rock 'n' Roll | Stoner

eleni m
Δημοσιεύσεις: 13
Εγγραφή: 09 Απρ 2006 20:22
Τοποθεσία: athens

Πρόβλημα με movieclip που αποτελείται από buttons

Δημοσίευση από eleni m » 04 Μάιος 2006 13:42

Για ακόμη μια φορά, σε ευχαριστώ πάαααααααααααααααρα πολύ... :D

Απάντηση

Επιστροφή στο “Flash γενικά”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες