phpMyAdmin setup prob...

Συζητήσεις για την βάση δεδομένων MySQL και το phpMyAdmin

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
jtoros
Δημοσιεύσεις: 7
Εγγραφή: 07 Απρ 2006 04:25

phpMyAdmin setup prob...

Δημοσίευση από jtoros » 15 Ιούλ 2006 21:11

Παιδιά σας καλησπερίζω όλους και σας μεταφέρω τα συγχαρητήριά μου για το forum. Το ξέρω κάνα 6μηνο αλλά δεν χρειάστηκε ποτέ να ποστάρω. Τελικά χρειάστηκε σήμερα :)

Έχω βάλει Apache 2.0.58, php 5.1.4 και mySQL 4.1.18 και θέλω να βάλω phpMyAdmin 2.8.2 για να διαχειρίζομαι τη βάση. Το πρόβλημα είναι πως αφού (νομίζω ότι) έκανα καλές ρυθμίσεις στο phpMyAdmin/scripts/setup.php δεν μου εμφανίζει την σελίδα welcome του phpMyAdmin όπως λέει το παρακάτω tutorial phpMyAdmin installation guide

Δημιούργησα έναν φάκελο "config" στο root directory του phpMyAdmin (που είναι μέσα στο web directory του Apache) και το setup.php δημιούργησε αυτό το αρχείο (config.inc.php).

Βλέπει κανείς κάτι λάθος;

Κώδικας: Επιλογή όλων

<?php
/*
 * Generated configuration file
 * Generated by&#58; phpMyAdmin 2.8.2 setup script by Michal Cihar <michal@cihar.com>
 * Version&#58; $Id&#58; setup.php,v 1.23.2.10 2006/05/15 07&#58;57&#58;30 nijel Exp $
 * Date&#58; Sat, 15 Jul 2006 16&#58;20&#58;38 GMT
 */

/* Servers configuration */
$i = 0;

/* Server localhost &#40;config&#58;root&#41; &#91;1&#93; */
$i++;
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'bookmarktable'&#93; = 'pma_bookmark';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'relation'&#93; = 'pma_relation';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'table_info'&#93; = 'pma_table_info';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'table_coords'&#93; = 'pma_table_coords';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'pdf_pages'&#93; = 'pma_pdf_pages';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'column_info'&#93; = 'pma_column_info';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'history'&#93; = 'pma_history';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'host'&#93; = 'localhost';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'extension'&#93; = 'mysql';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'connect_type'&#93; = 'tcp';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'compress'&#93; = true;
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'controluser'&#93; = 'my_login';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'controlpass'&#93; = 'my_pass';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'auth_type'&#93; = 'config';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'user'&#93; = 'my_login';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'password'&#93; = 'my_pass';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'pmadb'&#93; = 'motogp_site';

/* End of servers configuration */

?>
Όπου my_login και my_pass το login και το password μου.
Any ideas? Επαναλαμβάνω πως δεν μπορώ να δω την αρχική σελίδα του phpmyadmin. Ο IE λέει "The page cannot be displayed", ο δε Firefox "Υπήρξε πρόβλημα σύνδεσης στην προσπάθεια επικοινωνίας με localhost.". Καλώ το http://localhost/phpMyAdmin/index.php
Αυτά :)
Α! Ξέχασα να πω... Είμαι τελείως newbie!
Αν δεν κοιτάς εκεί που θέλεις να πας, θα πας εκεί που κοιτάς.

jtoros
Δημοσιεύσεις: 7
Εγγραφή: 07 Απρ 2006 04:25

phpMyAdmin setup prob...

Δημοσίευση από jtoros » 15 Ιούλ 2006 22:34

Παιδιά έχουμε update!

Καλώντας http://localhost/phpMyAdmin/index.php παίρνω το παρακάτω μήνυμα λάθους: "δεν ήταν δυνατή η φόρτωση της επέκτασης mysql ,<br />παρακαλώ ελέγξτε τις ρυθμίσεις της PHP".

Στο php.ini που βρίσκεται στον φάκελο C:\WINDOWS έχω δώσει extension_dir="c:\php\ext\" και έχω κάνει uncomment τα extension=php_mbstring.dll, extension=php_mysql.dll και extension=php_mysqli.dll.

Τι γίνεται...; :-?
Αν δεν κοιτάς εκεί που θέλεις να πας, θα πας εκεί που κοιτάς.

Άβαταρ μέλους
cordis
Administrator, [F|H]ounder, [C|S]EO
Δημοσιεύσεις: 27621
Εγγραφή: 09 Οκτ 1999 03:00
Τοποθεσία: Greece
Επικοινωνία:

phpMyAdmin setup prob...

Δημοσίευση από cordis » 16 Ιούλ 2006 03:56

δοκίμασε να κάνεις ένα restart
δες αν στο c:\php\ext\ υπάρχει το php_mysql.dll

γιατί δεν κάνεις μία Εγκατάσταση της PHP με αυτόματους Installer να τελειώνεις; ;)
Δεν απαντάω σε προσωπικά μηνύματα με ερωτήσεις που καλύπτονται από τις ενότητες του forum. Για ο,τι άλλο είμαι εδώ για εσάς.
- follow me @twitter

Άβαταρ μέλους
Risk
Δημοσιεύσεις: 319
Εγγραφή: 02 Μάιος 2006 01:16
Τοποθεσία: Κάπου εδώ γύρω...
Επικοινωνία:

phpMyAdmin setup prob...

Δημοσίευση από Risk » 18 Ιούλ 2006 11:25

Αυτό που θα πω τώρα είναι λίγο αντιπρογραμματιστικό και μια πολύ ετοιμή λύση, που άν δεν καταφέρεις να σετάρεις καλά το phpmyAdmin είναι πού καλή επιλογή τελικά! Ανακάλυψα πρόσφατα δύο προγραμματάκια το ένα λέγετε EasyPHP και το άλλο δεν το θυμάμαι αλλά θα το συμπληρώσω κάποια άλλη στιγμή. Λοιπόν αυτά τι κάνουν...τρέχουν κανονικά σαν να βάζεις ένα κανονικό πρόγραμμα και στο τέλος της εγκατάστασης σου έχουν διαμορφώσει όλο το περιβάλλον εργασία που χρειάζεσαι, δηλαδή php,mysql,apache,phpmyAdmin. Βέβαια το θέμα είναι πως ποτέ δεν μαθαίνεις πως όλα αυτά εννώνονται κομμάτι κομμάτι, αλλά για κάποιον που θέλει να αρχίσει να ασχολείτε είναι ότι πρέπει.

Τώρα στην δική σου περίπτωση να ξέρεις πως αν θέλεις να χρησιμοποιήσεις ένα από αυτά τα προγραμματάκια, θα πρέπει πρώτα να απεγκαταστήσης php,mysql,apache που έχεις βάλει μόνο σου, γιατί απ' ότι καταλαβαίνεις αν τρέξεις ένα από αυτά τα προγραμματάκια θα σου βάλει τα νέα πάνω στα ήδη υπάρχοντα και μετά δεν πρόκειται να παίξει τίποτα.
Εικόνα

jtoros
Δημοσιεύσεις: 7
Εγγραφή: 07 Απρ 2006 04:25

phpMyAdmin setup prob...

Δημοσίευση από jtoros » 07 Σεπ 2006 01:47

Παιδιά ξεθάβω το post γιατί το πρόβλημα παραμένει.
Η phpMyAdmin δεν μπορεί να φορτώσει το php_mysqli.dll.

Έχω κάνει uncomment τις αντίστοιχες γραμμές για php_mysql.dll και php_mysqli.dll στο php.ini. Το οποίο ini έχω βάλει και στο C:/WINDOWS... Τα php_mysql.dll και php_mysqli.dll τα έχω βάλει παντού (C:/WINDOWS, C:/WINDOWS/system, C:/WINDOWS/system32, C:/php, C:/php/ext) :o

Η http://localhost:8080/pma/scripts/setup.php την πρώτη φορά που την προσπέλασα έμοιαζε να δουλεύει σωστά. Έκανα configuration και το έσωσα. Το αρχείο (config.inc.php) το έσωσα στον root φάκελο του phpMyAdmin. Αλλά το http://localhost:8080/pma/index.php βγάζει το παραπάνω μήνυμα λάθους (ότι δλδ δεν μπόρεσε να φορτώσει το php_mysqli.dll).

Επίσης κατά το configuration η phpmyadmin έγραψε ότι δεν βρήκε το php_mbstring.dll για την μετατροπή χαρακτήρων (για να βλέπει ελληνικά). Το θέμα είναι ότι και για αυτό το dll έχω κάνει uncomment την αντίστοιχη γραμμή στο php.ini και έχω μεταφέρει το dll στους ίδιους φακέλους που ανέφερα και παραπάνω (C:/WINDOWS, C:/WINDOWS/system, C:/WINDOWS/system32, C:/php, C:/php/ext).

Είμαι ένα βήμα από το να καταφύγω στη λύση του αυτόματου installer, αλλά δεν το θέλω γμτ! Ντροπή...

Any ideas?
Thnx in advance...
Αν δεν κοιτάς εκεί που θέλεις να πας, θα πας εκεί που κοιτάς.

jtoros
Δημοσιεύσεις: 7
Εγγραφή: 07 Απρ 2006 04:25

phpMyAdmin setup prob...

Δημοσίευση από jtoros » 07 Σεπ 2006 18:39

Το πρόβλημα λύθηκε. Πώς; Ιδέα δεν έχω... :kaloe:

Τα ξήλωσα όλα χθες και επιχείρησα να τα εγκαταστήσω όλα με αυτόματο installer. Πέτυχε, αλλά μετά χάθηκα σε φακέλους κ.τ.λ. Οπότε σήμερα το πρωί ξαναέβαλα ξεχωριστά Apache, php, MySQL και phpMyAdmin. Πλέον το πρόβλημα με τη φόρτωση του php_mysql.dll δεν υπήρχε, αλλά έιχα το error υπ' αριθμόν 1045 που έλεγε κάτι για password. Το πρόβλημα ήταν ότι το αρχείο config.inc.php δεν υπήρχε στην διανομή του phpMyAdmin που είχα (2.8.2.4) κι έτσι το έφτιαξα μόνος μου σύμφωνα με τις οδηγίες αυτού του τυπά, οι οποίες απεδείχθησαν ΛΑΘΟΣ για την περίπτωσή μου. Έτσι πήρα το αρχείο από έναν κολλητό μου, του οποίου η εγκατάσταση δουλεύει. Και δούλεψε!!!

Το περιεχόμενο του αρχείου config.inc.php πρέπει να είναι κάπως έτσι:

Κώδικας: Επιλογή όλων

<?php
/*
 * Generated configuration file
 * Generated by&#58; phpMyAdmin 2.8.0.2 setup script by Michal Cihar <michal@cihar.com>
 * Version&#58; $Id&#58; setup.php,v 1.23.2.2.2.1 2006/03/08 19&#58;06&#58;48 nijel Exp $
 * Date&#58; Sat, 25 Mar 2006 14&#58;55&#58;17 GMT
 */

/* Servers configuration */
$i = 0;

/* Server E&#58;/MySql/bin/mysqld-nt.exe &#40;config&#58;localhost&#41; &#91;1&#93; */
$i++;
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'host'&#93; = 'localhost';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'extension'&#93; = 'mysql';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'connect_type'&#93; = 'tcp';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'compress'&#93; = false;
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'auth_type'&#93; = 'config';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'user'&#93; = 'your_username_for_MySQL';
$cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'password'&#93; = 'your_password_for_MySQL';

/* End of servers configuration */

$cfg&#91;'LeftFrameLight'&#93; = true;
$cfg&#91;'LeftFrameDBTree'&#93; = true;
$cfg&#91;'LeftFrameDBSeparator'&#93; = '_';
$cfg&#91;'LeftFrameTableSeparator'&#93; = '__';
$cfg&#91;'LeftFrameTableLevel'&#93; = 1;
$cfg&#91;'LeftDisplayLogo'&#93; = true;
$cfg&#91;'LeftDisplayServers'&#93; = false;
$cfg&#91;'LeftPointerEnable'&#93; = true;
$cfg&#91;'DefaultTabServer'&#93; = 'main.php';
$cfg&#91;'DefaultTabDatabase'&#93; = 'db_details_structure.php';
$cfg&#91;'DefaultTabTable'&#93; = 'tbl_properties_structure.php';
$cfg&#91;'LightTabs'&#93; = false;
$cfg&#91;'ErrorIconic'&#93; = true;
$cfg&#91;'MainPageIconic'&#93; = true;
$cfg&#91;'ReplaceHelpImg'&#93; = true;
$cfg&#91;'NavigationBarIconic'&#93; = 'both';
$cfg&#91;'PropertiesIconic'&#93; = 'both';
?>
Αυτά! Ελπίζω να βοήθησε η απάντησή μου, γιατί εγώ έχασα ένα απόγευμα κι ένα πρωινό για αυτή τη μ@λ@κία :evil: :x
Αν δεν κοιτάς εκεί που θέλεις να πας, θα πας εκεί που κοιτάς.

Άβαταρ μέλους
Cha0s
SysAdmin
Δημοσιεύσεις: 10242
Εγγραφή: 28 Ιούλ 2001 03:00

phpMyAdmin setup prob...

Δημοσίευση από Cha0s » 09 Σεπ 2006 13:41

Φτιάξε ένα αρχείο info.php βάλτο στο root dir που διαβάζει τα htdocs ο apache και γράψε μέσα σε αυτό:

<?phpinfo();?>

Τρέχτο από έναν browser (πχ http://localhost/info.php) και κάνε paste τα results.

Νομίζω πως η PHP είναι precompiled με MySQL support για 4.0.x και όχι 4.1.x όπου είναι διαφορετικός ο τρόπος που λειτουργεί, και δεν μπορεί η mysql lib να κάνει connect στην MySQL και πετάει ένα error για λάθος password or smth.

Απάντηση

Επιστροφή στο “MySQL”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης