Σχεδιαστικό πρόβλημα σε Internet Explorer

Ερωτήσεις και απαντήσεις σχετικές με την HTML, XHTML και την κατασκευή σελίδων για το Web.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Άβαταρ μέλους
dizzy_fingers
Δημοσιεύσεις: 118
Εγγραφή: 24 Ιούλ 2004 18:32
Επικοινωνία:

Σχεδιαστικό πρόβλημα σε Internet Explorer

Δημοσίευση από dizzy_fingers » 25 Ιούλ 2006 04:05

Καλησπέρα.
Έχω ένα πρόβλημα σχετικά με τη σχεδίαση του φόρουμ μου.
Με firefox φαίνεται οκ:
Εικόνα


αλλά όταν το βλέπω από τον internet explorer, το ένα row "τρώει" το άλλο.
Δηλαδή:
Εικόνα


Τί φταίει?

Ευχαριστώ προκαταβολικά.
Συνημμένα
ff.jpg
ff.jpg (9.7 KiB) Προβλήθηκε 1934 φορές
ie.jpg
ie.jpg (8.44 KiB) Προβλήθηκε 1934 φορές

Άβαταρ μέλους
cherouvim
Script Master
Δημοσιεύσεις: 3137
Εγγραφή: 13 Ιούλ 2005 22:56
Τοποθεσία: Athens, Greece
Επικοινωνία:

Σχεδιαστικό πρόβλημα σε Internet Explorer

Δημοσίευση από cherouvim » 25 Ιούλ 2006 10:44

Πιθανώς το broken box model του IE.
Χάρισέ μας λίγο από το HTML/CSS σου.

Άβαταρ μέλους
dizzy_fingers
Δημοσιεύσεις: 118
Εγγραφή: 24 Ιούλ 2004 18:32
Επικοινωνία:

Σχεδιαστικό πρόβλημα σε Internet Explorer

Δημοσίευση από dizzy_fingers » 25 Ιούλ 2006 14:22

HTML:

Κώδικας: Επιλογή όλων

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http&#58;//www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 
<html xml&#58;lang="en" lang="en" xmlns="http&#58;//www.w3.org/1999/xhtml">
<head>
<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
<link rel="shortcut icon" href="favicon.ico" />
<title><% TITLE %></title>
<% GENERATOR %> 
<% CSS %> 
<% JAVASCRIPT %> 
</head> 
<body>
<div id="ipbwrapper">
<table width="100%" align="center" cellpadding="0" cellspacing="0">
<tr>
<td background="style_images/bforum/left.jpg" width="50px" align="left" valign="top"><img src='style_images/bforum/top_left.jpg'></td>
<td rowspan="2">
<% BOARD HEADER %>
<% MEMBER BAR %>
<% NAVIGATION %>
<!--IBF.NEWPMBOX-->
<% BOARD %>
<% BOARD FOOTER %>
<% STATS %> 
<% COPYRIGHT %>
</td>
<td background="style_images/bforum/right.jpg" width="50px" align="right" valign="top"><img src='style_images/bforum/top_right.jpg'></td>
</tr>
<tr>
<td width="15px" background="style_images/bforum/left.jpg">&nbsp;</td>
<td width="15px" background="style_images/bforum/right.jpg">&nbsp;</td>
</tr>
</table>
</div>
</body> 
</html>
CSS:

Κώδικας: Επιλογή όλων

html
&#123;
	overflow-x&#58; auto;
&#125;

body
&#123;
	background-image&#58; url&#40;<#IMG_DIR#>/back.jpg&#41;;
	background-attachment&#58; scroll;
	background-repeat&#58; repeat-x;
	background-position&#58; top;
	background-color&#58; #333333;
	color&#58; #222;
	font-family&#58; Verdana, Tahoma, Arial, Trebuchet MS, Sans-Serif, Georgia, Courier, Times New Roman, Serif;
	font-size&#58; 11px;
	line-height&#58; 135%;
	margin&#58; 0px;
	padding&#58; 0px;
	text-align&#58; center;
&#125;


....



#ipbwrapper
&#123;
	margin&#58; auto auto auto auto;
	text-align&#58; left;
	width&#58; auto;
	background&#58; #efefef;
&#125;

Για να μην κάνω ποστ σεντόνι, έβαλα τα μέρη τα οποία θεωρώ υπεύθυνα.
Ασφαλώς μπορεί να κάνω λάθος, οπότε αν χρειάζεσαι κάτι άλλο να παραθέσω, πες μου.
Ευχαριστώ για τη γρήγορη απάντηση :).

Άβαταρ μέλους
cordis
Administrator, [F|H]ounder, [C|S]EO
Δημοσιεύσεις: 27616
Εγγραφή: 09 Οκτ 1999 03:00
Τοποθεσία: Greece
Επικοινωνία:

Σχεδιαστικό πρόβλημα σε Internet Explorer

Δημοσίευση από cordis » 25 Ιούλ 2006 16:41

κάνε copy από το view source της σελίδας και όχι το template...
Δεν απαντάω σε προσωπικά μηνύματα με ερωτήσεις που καλύπτονται από τις ενότητες του forum. Για ο,τι άλλο είμαι εδώ για εσάς.
- follow me @twitter

Άβαταρ μέλους
dizzy_fingers
Δημοσιεύσεις: 118
Εγγραφή: 24 Ιούλ 2004 18:32
Επικοινωνία:

Σχεδιαστικό πρόβλημα σε Internet Explorer

Δημοσίευση από dizzy_fingers » 25 Ιούλ 2006 18:22

Είναι πολύ μεγάλος για να τον ποστάρω (το δοκίμασα και δε χωράει σε ένα ποστ).

Να σας δώσω το link για να τον δείτε από μόνοι σας?

Άβαταρ μέλους
dizzy_fingers
Δημοσιεύσεις: 118
Εγγραφή: 24 Ιούλ 2004 18:32
Επικοινωνία:

Σχεδιαστικό πρόβλημα σε Internet Explorer

Δημοσίευση από dizzy_fingers » 25 Ιούλ 2006 20:46

Fixed.

To πρόβλημα ήταν αλλού βασικά.
Στο .newslink (το οποίο είναι η μπάρα με τα "Welcome back; your last visit was: Today, 04:10 PM" και το πεδίο search) το width ήταν 100%.
Μπορεί να ήταν πιο "μέσα" από τα άλλα tables αλλά αυτό ήταν που έκανε τη ζημιά.
Το μείωσα στο 85% και έχει φτιάξει (το πρόβλημα υπάρχει ακόμα για 2 pixels αλλά πλέον είναι δυσδιάκριτο και υπάρχει μόνο στην αρχική σελίδα).

Δεν έχω ιδέα πως αυτό επηρρέαζε όλο το φόρουμ (αφού, επειδή ήταν μεγάλο, θα έπρεπε να ξεχελίζει κι όχι να μπαίνει προς τα μέσα), αλλά τώρα που το έφτιαξα ουδώλως με ενδιαφέρει. :D

Απάντηση

Επιστροφή στο “HTML και XHTML”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες