apache niewbie ερωτησεις

Τεχνικές και μόνο Συζητήσεις για WEB hosting servers, Mail servers, DNS servers. Όχι αναζήτηση υπηρεσιών εδώ!

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
kaliende
Δημοσιεύσεις: 5
Εγγραφή: 27 Νοέμ 2006 14:36

apache niewbie ερωτησεις

Δημοσίευση από kaliende » 29 Δεκ 2006 14:03

Γεια σας παιδες,χρονια πολλα
εδω και λιγο καιρο προσπαθω να στησω εναν server για τον χωρο που εργαζομαι(ποιο πολυ εμενα θα ωφελησει στην δουλεια μου)
ετσι ξεκινοντας στηνω στην αρχη το ubuntu μου (6.06 daper) ολα ωραια και καλα,
μετα κατεβαζω τα php,sql,apache,phpmyadmin με διαφορετικη σειρα , και αρχιζω να τα εγκαθιστω , κανω και σεταρισμα ενα opensource cms και τοπικα(στο pc) μου δουλευουν ολα ρολοι.
επειδη στην δουλεια μου εχουμε δυκτιο με αρκετους χρηστες με dhcp του καρφωνο και μια local ip και τρεχω σαν μικρο παιδακι να δω σε ενα αλλο pc (στο δικτιο εννοητε) να δω και εγω την αρχικη σελιδα του cms(joomla) αλλα το μονο που βλεπω ειναι τα κειμενα χωρις εικονες και τα link δεν δουλευουν σωστα.Λεω και εγω ο niewbies κατι λαθος κανω και δεν φαινετε στο δικτιο,διαβασμα απο εδω διαβασμα απο εκει καταληγω να εχω κανει λογαριασμο στην no-ip.com μονο και μονο για να δω αν φαινετε απο εξω ο server μου.μου τον βλεπει κανονικα,μου εστειλε και τα χαιρετησματα της(η no-ip.com) -πλακα κανω- εκανα και το port forwarding μου και χτυπωντας την διευθυνση που εβαλα στην no-ip μου απαντησε ο server μου,ειδα και το cms μου αλλα παλι το ιδιο,δηλαδη μονο τα κειμενα και τα links.
Επειδη οπως καταλαβατε ειμαι νεος στο κινημα και δεν ξερω και πολλα μπορει να σας εχω μπερδεξει ετσι οποιος θελει μπορω να του δωσω περισσοτερες διευκρινησεις..
Εγω απο οτι καταλαβαινω ισως να ειναι θεμα cache αλλα γιατι;βεβαια μπορει και να ειναι και θεμα php!!(ειπα δεν ξερω πολλα) :D
Η μηπως κανω κατι λαθος κατα την εγκατασταση του joomla;(και να ρωτησω αλλου) :oops:
Η μηπως δεν φταει τιποτα απο ολα αυτα και θα μου πειτε εσεις; :clap:
σας ευχαριστω πολυ για τις απαντησεις σας

id12586
στις καρδιές μας
Δημοσιεύσεις: 8387
Εγγραφή: 23 Ιουν 2003 23:28
Τοποθεσία: Far away
Επικοινωνία:

apache niewbie ερωτησεις

Δημοσίευση από id12586 » 29 Δεκ 2006 15:29

Δεν έχω ασχοληθεί με joomla (απο την εποχή mambo και μετά) αλλά αυτό δεν μου κάνει για προβλημα του Apache.
Μήπως οι εικόνες, βρίσκονται σε διαφορετικό directory που δεν έχει access ο Apache ή/και το Joomla?
Chris at your Services
ΕικόναSacame de Aqui

Άβαταρ μέλους
tix-3-
Δημοσιεύσεις: 827
Εγγραφή: 25 Μαρ 2004 05:12
Τοποθεσία: Θεσσαλονικη-Καβαλα-βεροια(το τριγωνο της καταρας)
Επικοινωνία:

apache niewbie ερωτησεις

Δημοσίευση από tix-3- » 29 Δεκ 2006 15:53

Απο οσο θυμαμαι και εγω στο joomla δηλωνεις domain.
Μηπως εκει εχεις δηλωσει localhost;

kaliende
Δημοσιεύσεις: 5
Εγγραφή: 27 Νοέμ 2006 14:36

apache niewbie ερωτησεις

Δημοσίευση από kaliende » 29 Δεκ 2006 18:24

παιδια σας ευχαριστω για το ενδιαφερον.
σε ευχαριστω tix-3- που με πονηρεψες..τελικα ηθελα απλα αλλαγη το live site μεσα απο το configuration.php του joomla.δηλαδη απο: http://localhost/joomla σε
http://Ονομα_server/joomla ετσι απλα και ολα μου τα προβληματα εξανεμηστικαν(μεχρι τωρα δηλαδη,που να μπω και ποιο βαθεια)
ευχαριστω και παλι παιδες και αν δεν τα ξαναπουμε συντομα σας ευχομαι
καλη χρονια σε ολους

kaliende
Δημοσιεύσεις: 5
Εγγραφή: 27 Νοέμ 2006 14:36

apache niewbie ερωτησεις

Δημοσίευση από kaliende » 29 Δεκ 2006 21:34

Καλησπερα και παλι,
τελικα βιαστικα να θριαμβολογησω..
Ολα ενταξει στο τοπικο μας δικτυο το βλεπουμε μια χαρα το joomla ειτε χτυπωντας την local ip ειτε με το ονομα.no-ip.info ολα ωραια και καλα..αφου το δουλεψα λιγο το joomla(εκοψα,εραψα) εφυγα απο την δουλεια τελευταιος και ηρθα στο σπιτι μια και ο server μου δουλευε κανονικα να συνεχισω απο εδω(το κοψιμο και το ραψιμο του cms)-μηπως να γινομουν ραφτης καλυτερα-
ανοιγω το pc μου(στο σπιτι)βαζω και την no-ip διευθυνση μου φωναζω και τον ξαδερφο να ερθει να με καμαρωσει και τζηφος!!!!!!
Παλι τα ιδια:Λευκη σελιδα μονο με το κειμενο,τα links δεν δουλευανε και τα γραφικα περιπατο,μονο η περιγραφες των εικονων..
Οποιος μπορει να με βοηθησει παιδια γιατι πλεον ειναι και θεμα τιμης..εγινα ρεζιλι στον ξαδερφο(και εχει και μεγαλη παρεα...)
Α να μην το ξεχασω, στην ερωτηση σου id12586 ολα τα αντικειμενα του Joomla (εικονες,scripts,php files) βρισκονται στο var/www/φακελος_Joomla εκει δηλαδη που πρεπει να κοιταξει ο apache συμφωνα με το .conf αρχειο του.
Ευχαριστω και παλι με οποιον θελησει να με βοηθησει

Άβαταρ μέλους
tix-3-
Δημοσιεύσεις: 827
Εγγραφή: 25 Μαρ 2004 05:12
Τοποθεσία: Θεσσαλονικη-Καβαλα-βεροια(το τριγωνο της καταρας)
Επικοινωνία:

apache niewbie ερωτησεις

Δημοσίευση από tix-3- » 29 Δεκ 2006 21:46

Λογικο ειναι αφου το http://ονομα server/joomla το βλεπεις μονο απο το τοπικο σου δικτυο.
αν ξανανοιξεις το configuration.php και βαλεις το no-ip domain σου θα το βλεπεις απο εξω.
απο μεσα ομως δεν ειμαι και τοσο σιγουρος...

kaliende
Δημοσιεύσεις: 5
Εγγραφή: 27 Νοέμ 2006 14:36

apache niewbie ερωτησεις

Δημοσίευση από kaliende » 29 Δεκ 2006 22:02

Ισως να εχεις δικιο tix-3- γιατι οταν εβαλα τo no-ip domain Μου στο configuration.php ειχε ακριβως την ιδια αντιδραση τοπικα(μονο κειμενο).
Δηλαδη δεν υπαρχει τροπος να να το βλεπω και τοπικα και via ιντερνετ?

Άβαταρ μέλους
tix-3-
Δημοσιεύσεις: 827
Εγγραφή: 25 Μαρ 2004 05:12
Τοποθεσία: Θεσσαλονικη-Καβαλα-βεροια(το τριγωνο της καταρας)
Επικοινωνία:

apache niewbie ερωτησεις

Δημοσίευση από tix-3- » 30 Δεκ 2006 01:58

μπορεις να βαλεις στο WINDOWS\system32\drivers\etc\hosts αρχειο μια γραμμη που να λεει


example.no-ip.org την Ip απο τον server

και λογικα θα δουλεψει

kaliende
Δημοσιεύσεις: 5
Εγγραφή: 27 Νοέμ 2006 14:36

apache niewbie ερωτησεις

Δημοσίευση από kaliende » 30 Δεκ 2006 10:58

Καλημερα,
ευχαριστω tix για το ενδιαφερον τελικα το ελυσα κανοντας το εξης(το γραφω σε περιπτωση που καποιος αλλος εχει το ιδιο προβλημα): αλλαξα στο configuration.php την διαδρομη απο http://****.no-ip.org σε http://****.no-ip.org/ονομα_σερβερ και τρεχει κανονικα..λογικο τωρα που το σκεφτομαι
ευχαριστω και παλι.

καλη χρονια σε ολους

petpet
Δημοσιεύσεις: 3
Εγγραφή: 23 Ιαν 2007 22:39

apache niewbie ερωτησεις

Δημοσίευση από petpet » 23 Ιαν 2007 23:06

για χαρά freestuff..

με αφορμή αυτό το thread έγινα και εγώ μέλος..(παίζει να είχα και παλιά acount αλλα χάθηκε μέσα στα mails..)

έχω στήσει και εγώ lamp server..(linux apache mysql php)
και έβαλα το joomla και συνάντησα ακριβώς το ίδιο πρόβλημα..
ενώ localhost/joomla με βλέπω κανονικά..δεν μπορώ να με δω από το no-ip.info/joomla

η απορία μου είναι: πως αλλάζω το configuration.php μέσα από το cpanel??
πως ακριβώς αλλάζω το live site??μου βγάζει την επιλογή non active..sto global configuration/server/live site
όταν αλλάζω κάποια άλλο localhost "πακετονομε"...

δοκίμασα να αλλάξω το αρχείο configuration.php μέσα από το text mode(to arxeio ston www/joomla) από localhost σε pet.....no-ip.info
αλλα ούτε εγώ μπορώ να μπω πια με το "localhost/joomla" αλλα ούτε και κανεις άλλος με την no-ip μου..
όταν το ξανακάνω απλά localhost το βλέπω..

2 ερώτηση δεύτερη όταν λέτε το όνομα του server..(για την περίπτωση του lan..)τι θα βάλω apache??

είχα ξαναδοκιμάσει να ανεβάσω στα win και joomla και php-nuke και mambo και smf και yabb και bbforum αλλα δεν είχα συναντήσει κάποιο πρόβλημα..
byronas jamaika einai dio lepta

Απάντηση

Επιστροφή στο “Apache, IIS, DNS Servers”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες