Πρόβλημα με Apache

Τεχνικές και μόνο Συζητήσεις για WEB hosting servers, Mail servers, DNS servers. Όχι αναζήτηση υπηρεσιών εδώ!

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Άβαταρ μέλους
Khronos
Δημοσιεύσεις: 754
Εγγραφή: 11 Δεκ 2006 14:43
Τοποθεσία: Ηράκλειο

Πρόβλημα με Apache

Δημοσίευση από Khronos » 20 Ιαν 2007 00:12

Εχω ένα πρόβλημα με τον Apache..Στο index of δεν μου εμφανίζει όλα τα αρχεία που υπάρχουν στον φάκελο..Επίσης όταν υπάρχει μια εικόνα στον φάκελο την εμφανίζει στην κορυφή της σελίδας..Γιατί γίνεται αυτό?

sibas
Honorary Member
Δημοσιεύσεις: 1853
Εγγραφή: 21 Φεβ 2003 01:21
Τοποθεσία: Μια εδώ.. Μια εκεί.. Σήμερα είμαι εδώ!!!
Επικοινωνία:

Πρόβλημα με Apache

Δημοσίευση από sibas » 20 Ιαν 2007 00:58

Khronos καλά έκανες την ερώτηση, αλλά πες μας και μερικά στοιχεία.
OS, ποίον apache έχεις, κάποιο url.

Τι να σου πούμε έτσι;

Άβαταρ μέλους
Khronos
Δημοσιεύσεις: 754
Εγγραφή: 11 Δεκ 2006 14:43
Τοποθεσία: Ηράκλειο

Πρόβλημα με Apache

Δημοσίευση από Khronos » 20 Ιαν 2007 01:04

Εχω τον apache 2.0.59 σε windows. Ορισμένα html αρχεία τα βλέπει, τα άλλα όχι. Το ίδιο και με τις εικόνες.

sibas
Honorary Member
Δημοσιεύσεις: 1853
Εγγραφή: 21 Φεβ 2003 01:21
Τοποθεσία: Μια εδώ.. Μια εκεί.. Σήμερα είμαι εδώ!!!
Επικοινωνία:

Πρόβλημα με Apache

Δημοσίευση από sibas » 20 Ιαν 2007 01:36

Αυτά τα html αρχεία τα βλέπεις τοπικά ή από το internet?
Τι error page σου βγάζει όταν δεν δείχνει τις σελίδες, έχεις κοιτάξει τα error logs.

Άβαταρ μέλους
Khronos
Δημοσιεύσεις: 754
Εγγραφή: 11 Δεκ 2006 14:43
Τοποθεσία: Ηράκλειο

Πρόβλημα με Apache

Δημοσίευση από Khronos » 20 Ιαν 2007 01:40

Πάντα τοπικά.. Δεν βγάζει κανένα error, απλά δεν υπάρχουν στη list του index of(localhost)

sibas
Honorary Member
Δημοσιεύσεις: 1853
Εγγραφή: 21 Φεβ 2003 01:21
Τοποθεσία: Μια εδώ.. Μια εκεί.. Σήμερα είμαι εδώ!!!
Επικοινωνία:

Πρόβλημα με Apache

Δημοσίευση από sibas » 20 Ιαν 2007 13:17

Λοιπόν κάτσε να δούμε αν το κατάλαβα καλά
Ο apache λειτουργεί και βλέπεις το index του apache σωστά μέχρι εδώ;
Έχεις βάλει μερικές σελίδες και φωτογραφίες και λες ότι δεν τις εμφανίζει στο index;
Για δώσε μας ένα παράδειγμα μιας photo ή ενός αρχείου που δεν εμφανίζει, σε ποιο folder το έχεις βάλει και πως προσπαθείς να το δεις.

Άβαταρ μέλους
MegasmorF
Honorary Member
Δημοσιεύσεις: 1154
Εγγραφή: 07 Απρ 2005 20:05
Τοποθεσία: ./Root
Επικοινωνία:

Πρόβλημα με Apache

Δημοσίευση από MegasmorF » 20 Ιαν 2007 13:37

Εγώ απο ότι κατάλαβα δεν το έχει βάλει σε φάκελο και γιαυτό του τα κάνει αυτά πρέπει να τα έχει βάλει μεσα στο WWW χύμα ο apache δεν τα εμφανίζει έτσι όπως ο Wamp θέλουν όλα direcotry!
Πες μου τη λέξη σ αγαπώ σε σένα να πιστέψω...και γω μια ολοκληρη ζωή μπορώ να καταστρεψω...

sibas
Honorary Member
Δημοσιεύσεις: 1853
Εγγραφή: 21 Φεβ 2003 01:21
Τοποθεσία: Μια εδώ.. Μια εκεί.. Σήμερα είμαι εδώ!!!
Επικοινωνία:

Πρόβλημα με Apache

Δημοσίευση από sibas » 20 Ιαν 2007 15:30

Ναι και εγώ αυτό πιστεύω για αυτό ρώτησα που έχει βάλει τα αρχεία και τις φωτογραφίες

Άβαταρ μέλους
Khronos
Δημοσιεύσεις: 754
Εγγραφή: 11 Δεκ 2006 14:43
Τοποθεσία: Ηράκλειο

Πρόβλημα με Apache

Δημοσίευση από Khronos » 20 Ιαν 2007 15:36

Οχι παιδιά τα αρχεία είναι σε φάκελο κανονικά και μάλιστα μερικά αρχεία που είναι στον ίδιο φάκελο τα βλεπει κανονικά ενώ τα υπόλοιπα όχι.. Αλλά και ορισμένα αρχεία που έβαλα χύμα στο www τα βλέπει κανονικά. Δεν μπορώ να καταλάβω τι συμβαίνει..

sibas
Honorary Member
Δημοσιεύσεις: 1853
Εγγραφή: 21 Φεβ 2003 01:21
Τοποθεσία: Μια εδώ.. Μια εκεί.. Σήμερα είμαι εδώ!!!
Επικοινωνία:

Πρόβλημα με Apache

Δημοσίευση από sibas » 20 Ιαν 2007 15:45

Αν θέλεις να σε βοηθήσουμε δώσε μας στοιχεία
Όλη την διαδρομή των αρχείων που λειτουργούν και όλη την διαδρομή των αρχείων που δεν λειτουργούν.
Γιατί απλά δεν γίνετε να βλέπεις μια φωτογραφία και στο ίδιο folder να μην βλέπεις μια άλλη.

Άβαταρ μέλους
Khronos
Δημοσιεύσεις: 754
Εγγραφή: 11 Δεκ 2006 14:43
Τοποθεσία: Ηράκλειο

Πρόβλημα με Apache

Δημοσίευση από Khronos » 20 Ιαν 2007 16:01

Λοιπόν στο localhost υπάρχουν 2 φάκελοι και 2 php αρχεία. Τα περιεχόμενα του ενός φακέλου και τα 2 php αρχεία τα βλέπει κανονικά. Το πρόβλημα αποτι φαίνεται βρίσκεται στον άλλο φάκελο, ο οποίος περιέχει 1 html και ένα css αρχείο τα οποία βλέπει κανονικά και άλλο ένα html αρχείο και 2 gif τα οποία δεν τα βλέπει καθόλου αλλα εμφανίζει το περιεχόμενο τους εκει που έπρεπε να γράφει index of.. Ελπίζω να καταλάβατε.

sibas
Honorary Member
Δημοσιεύσεις: 1853
Εγγραφή: 21 Φεβ 2003 01:21
Τοποθεσία: Μια εδώ.. Μια εκεί.. Σήμερα είμαι εδώ!!!
Επικοινωνία:

Πρόβλημα με Apache

Δημοσίευση από sibas » 20 Ιαν 2007 21:10

Όχι δεν καταλάβαμε.. για να καταλάβουμε θέλουμε να μας πεις τα εξής.
Στον δικό μου apache βάζω τις σελίδες στο
C:\Program Files\Apache Software Foundation\Apache2.2\htdocs
Και τοπικά τις βλέπω στο http://127.0.0.1:8080
και αυτό που βλέπω είναι το index του apache.
Τώρα αν βάλω άλλο folder πχ pictures τότε για να δω το folder πάω στο
http://127.0.0.1:8080/pictures/

Εσύ που έχεις βάλει τις σελίδες.
Σε ρώτησα και παραπάνω, δώσε όλη την διαδρομή των αρχείων που σου δουλεύουν και αυτών που δεν δουλεύουν.
Δεν ασκούμε μαντική εδώ.

Άβαταρ μέλους
Khronos
Δημοσιεύσεις: 754
Εγγραφή: 11 Δεκ 2006 14:43
Τοποθεσία: Ηράκλειο

Πρόβλημα με Apache

Δημοσίευση από Khronos » 20 Ιαν 2007 21:22

Οι σελίδες είναι στο F:\mypages
Tοπικά τις βλέπω στο http://localhost όπου είναι το index του Apache
localhost/dbtest.php το βλέπει
localhost/test.php το βλέπει
localhost/forum/.... τα βλέπει
localhost/test/mail.html το βλέπει
localhost/test/mycss.css το βλέπει

Tα υπόλοιπα αρχεία στο φάκελο test(header.html και 2 gif δεν τα βλέπει αλλά εμφανίζει το αποτέλεσμα του header.html στην κορυφή του index of )

Αυτό ακριβώς συμβαίνει, δεν μπορώ να το πω πιο περιγραφικά

sibas
Honorary Member
Δημοσιεύσεις: 1853
Εγγραφή: 21 Φεβ 2003 01:21
Τοποθεσία: Μια εδώ.. Μια εκεί.. Σήμερα είμαι εδώ!!!
Επικοινωνία:

Πρόβλημα με Apache

Δημοσίευση από sibas » 20 Ιαν 2007 22:08

Τότε Khronos ή έχεις κάνει κάτι μαγικό με την php ή έχεις εγκαταστήσει λάθος τον apache.
Για την php δεν μπορώ να σε βοηθήσω, για το θέμα του apache ξεκίνα το διάβασμα
γιατί το F:\mypages δεν μου κάθεται καλά

http://httpd.apache.org/docs/2.0/platform/windows.html

Άβαταρ μέλους
Khronos
Δημοσιεύσεις: 754
Εγγραφή: 11 Δεκ 2006 14:43
Τοποθεσία: Ηράκλειο

Πρόβλημα με Apache

Δημοσίευση από Khronos » 21 Ιαν 2007 12:38

Το όνομα του html και του gif αρχείου ήταν header.html, header.gif. Αλλαξα τα ονόματα και τα βλέπει κανονικά.. Γιατί όμως να έχει πρόβλημα με αυτό το όνομα?

Απάντηση

Επιστροφή στο “Apache, IIS, DNS Servers”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης