[SOLVED] Apache ignores .htaccess files!!!

Τεχνικές και μόνο Συζητήσεις για WEB hosting servers, Mail servers, DNS servers. Όχι αναζήτηση υπηρεσιών εδώ!

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Άβαταρ μέλους
_Invisible_
Δημοσιεύσεις: 418
Εγγραφή: 16 Νοέμ 2006 16:47
Τοποθεσία: Greece

[SOLVED] Apache ignores .htaccess files!!!

Δημοσίευση από _Invisible_ » 01 Ιουν 2007 02:22

Hello guys!

To kano post epidi me exei trelanei kai den ksero ti allo prepei na kano. Opos katalabate kai apo ton titlo, o apache agnoei telios ta .htaccess arxeia me apotelesma oi efarmoges na min douleuoun swsta. Auto ginetai giati sto "apache2.conf" ginetai include ena allo arxeio me skopo na ginoun include ta configuration files ton virutal hosts.

Κώδικας: Επιλογή όλων

Include /etc/apache2/sites-enabled/
O kodikas pou kanei to include einai o parapano. Mesa sto sites-enabled iparxei ena arxeio me onoma: "000-default". Se auto to arxeio iparxei o akolou8os kodikas:

Κώδικας: Επιλογή όλων

NameVirtualHost *
<VirtualHost *>
	ServerAdmin webmaster@localhost
	ServerName localhost
	
	DocumentRoot /var/www/
	<Directory />
		Options +FollowSymLinks
		Options -Indexes
		AllowOverride None
	</Directory>
	<Directory /var/www/>
		Options +FollowSymLinks
		AllowOverride None
		Order allow,deny
		allow from all
		# This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                #RedirectMatch ^/$ /apache2-default/
	</Directory>

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	<Directory "/usr/lib/cgi-bin">
		AllowOverride None
		Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	</Directory>

	ErrorLog /var/log/apache2/error.log

	# Possible values include&#58; debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access.log combined
	ServerSignature Off

</VirtualHost>
H lisi sto problima mou einai to AllowOverride directive pou einai sto None. Gia na kano ton apache na "diabazei" kai ta .htaccess arxeia, prepei na oriso to AllowOverride se All. To kano, apo8ikeuo to arxeio, kano restart ton apache kai pairno "Internal Server Error". Leei oti mporo na vro pros8etes plirofories sto error log mou, gi' auto eriksa kai ekei mia matia:

Κώδικας: Επιλογή όλων

&#91;Thu May 31 08&#58;35&#58;56 2007&#93; &#91;notice&#93; Apache/2.2.3 &#40;Ubuntu&#41; configured -- resuming normal operations
&#91;Thu May 31 08&#58;36&#58;32 2007&#93; &#91;notice&#93; caught SIGTERM, shutting down
Epsaksa sto Google gia "caught SIGTERM, shutting down" alla den brika kapoia lisi... To mono pou allazo sto "default-000" einai to AllowOverride se All.

Κώδικας: Επιλογή όλων

AllowOverride All
Molis to kano auto o apache petaei Internal Server Error. I periptosi einai poli mistirio...

Eyxaristo poli.
Τελευταία επεξεργασία από το μέλος _Invisible_ την 02 Ιουν 2007 22:07, έχει επεξεργασθεί 1 φορά συνολικά.

sibas
Honorary Member
Δημοσιεύσεις: 1851
Εγγραφή: 21 Φεβ 2003 01:21
Τοποθεσία: Μια εδώ.. Μια εκεί.. Σήμερα είμαι εδώ!!!
Επικοινωνία:

[SOLVED] Apache ignores .htaccess files!!!

Δημοσίευση από sibas » 01 Ιουν 2007 06:06

an bgaleis to

Include /etc/apache2/sites-enabled/

sou deixnei kanena la8os?

Άβαταρ μέλους
_Invisible_
Δημοσιεύσεις: 418
Εγγραφή: 16 Νοέμ 2006 16:47
Τοποθεσία: Greece

[SOLVED] Apache ignores .htaccess files!!!

Δημοσίευση από _Invisible_ » 01 Ιουν 2007 10:58

Eyxaristo gia tin amesi apantisi sou file sibas, alla to eixa dokimasei kai auto. Den douleuei, bgazei:

Κώδικας: Επιλογή όλων

Not Found

The requested URL / was not found on this server.
Auto ginetai giati den iparxei kapoio virtual host orismeno kai den einai orismenes oi ri8miseis pou xreiazontai gia na doulepsei o apache. me liga logia, to "default-000" periexei stoixeia pou einai aparaitita gia tin leitourgeia tou.

Eyxarisro

id12586
στις καρδιές μας
Δημοσιεύσεις: 8387
Εγγραφή: 23 Ιουν 2003 23:28
Τοποθεσία: Far away
Επικοινωνία:

[SOLVED] Apache ignores .htaccess files!!!

Δημοσίευση από id12586 » 01 Ιουν 2007 12:12

-Γενική Παρατήρηση-
Δεν βάζεις το Webmin για να πειράζεις τα configuration files με πιο μεγάλη "άνεση"?:wink:
www.webmin.com
Chris at your Services
ΕικόναSacame de Aqui

Άβαταρ μέλους
_Invisible_
Δημοσιεύσεις: 418
Εγγραφή: 16 Νοέμ 2006 16:47
Τοποθεσία: Greece

[SOLVED] Apache ignores .htaccess files!!!

Δημοσίευση από _Invisible_ » 01 Ιουν 2007 13:04

id poli kalo auto pou mou proteines, mou arese poli. ektimo tin boi8eia sou kai s' euxaristo poli.

Tora omos sxetika me to problima mou, ti 8a kano? :(

Άβαταρ μέλους
netrriper
Δημοσιεύσεις: 189
Εγγραφή: 10 Δεκ 2004 10:50
Επικοινωνία:

[SOLVED] Apache ignores .htaccess files!!!

Δημοσίευση από netrriper » 01 Ιουν 2007 13:41

mipws, lew mipws o server den ypostirizei .htaccess?
borei na ka8orizei permisions me allo tropo. kati antistixo eixe symbei kai se mena kai ta ekane corrupt ta arxeia me apotelesma na trow internal server error.
gia psakse to config tou server , kati pezei ekei.
Εικόνα

Άβαταρ μέλους
_Invisible_
Δημοσιεύσεις: 418
Εγγραφή: 16 Νοέμ 2006 16:47
Τοποθεσία: Greece

[SOLVED] Apache ignores .htaccess files!!!

Δημοσίευση από _Invisible_ » 01 Ιουν 2007 15:23

oxi vre guys... ipostirizei .htaccess... to eida kai sto config tou server. apla einai kati mikro pou mou diafeugei. tespa euxaristo gia tin boi8eia.

cheers.

sibas
Honorary Member
Δημοσιεύσεις: 1851
Εγγραφή: 21 Φεβ 2003 01:21
Τοποθεσία: Μια εδώ.. Μια εκεί.. Σήμερα είμαι εδώ!!!
Επικοινωνία:

[SOLVED] Apache ignores .htaccess files!!!

Δημοσίευση από sibas » 01 Ιουν 2007 18:01

ego den rotisa an paizei h selida alla an xoris to include sou bgazei kanena error o apache,
efoson den sou bgazei kalo einai na baleis to include kai na bazeis ena ena ta directory kai ta .htaccess sou giati einai poly pi8ano na min ftaiei o apache alla ta programata pou trexoun sta directory sou
me poio apla logia dokimase na baleis ena directory kai na kaneis ena htpasswrd na deis an pezei,
an pezei tote exeis brei kata to imisi to problima

zoran
Δημοσιεύσεις: 2
Εγγραφή: 03 Ιουν 2006 02:42
Τοποθεσία: homeless...

[SOLVED] Apache ignores .htaccess files!!!

Δημοσίευση από zoran » 01 Ιουν 2007 18:29

Κώδικας: Επιλογή όλων

ErrorLog /var/log/apache2/error.log 

   # Possible values include&#58; debug, info, notice, warn, error, crit, 
   # alert, emerg. 
   LogLevel warn 
Αντί για LogLevel warn δώσε ένα LogLevel debug

tail -f /path/to/error_log
και σε άλλο terminal επανεκκίνηση apache.

Τι έχεις βάλει στο .htaccess??

Άβαταρ μέλους
_Invisible_
Δημοσιεύσεις: 418
Εγγραφή: 16 Νοέμ 2006 16:47
Τοποθεσία: Greece

[SOLVED] Apache ignores .htaccess files!!!

Δημοσίευση από _Invisible_ » 01 Ιουν 2007 22:16

oriste to .htaccess mias efarmogis:

Κώδικας: Επιλογή όλων

#
# Apache/PHP settings&#58;
#

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# Follow symbolic links in this directory.
Options +FollowSymLinks

# Customized error messages.
ErrorDocument 404 error_docs/not_found.php
ErrorDocument 403 error_docs/forbidden.php

# Set the default handler.
DirectoryIndex index.php

# Override PHP settings. More in sites/default/settings.php
# but the following cannot be changed at runtime.

# PHP 4, Apache 1.
<IfModule mod_php4.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
</IfModule>

# PHP 4, Apache 2.
<IfModule sapi_apache2.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
</IfModule>

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
</IfModule>

# Requires mod_expires to be enabled.
<IfModule mod_expires.c>
  # Enable expirations.
  ExpiresActive On
  # Cache all files for 2 weeks after access &#40;A&#41;.
  ExpiresDefault A1209600
  # Do not cache dynamically generated pages.
  ExpiresByType text/html A1
</IfModule>

php_flag session.use_trans_sid off

# Various rewrite rules.
<IfModule mod_rewrite.c>
  RewriteEngine on

  # If your site can be accessed both with and without the prefix www. you
  # can use one of the following settings to force user to use only one option&#58;

  #
  # If you want the site to be accessed WITH the www. only, adapt and
  # uncomment the following&#58;

  # RewriteCond %&#123;HTTP_HOST&#125; ^example\.com$ &#91;NC&#93;
  # RewriteRule .* http&#58;//www.example.com/ &#91;L,R=301&#93;

  #
  # If you want the site to be accessed only WITHOUT the www. prefix, adapt
  # and uncomment the following&#58;
  # RewriteCond %&#123;HTTP_HOST&#125; ^www\.example\.com$ &#91;NC&#93;
  # RewriteRule .* http&#58;//example.com/ &#91;L,R=301&#93;

  # Modify the RewriteBase if you are using Drupal in a subdirectory and
  # the rewrite rules are not working properly.
  RewriteBase /drupal

  # Rewrite old-style URLs of the form 'node.php?id=x'.
  #RewriteCond %&#123;REQUEST_FILENAME&#125; !-f
  #RewriteCond %&#123;REQUEST_FILENAME&#125; !-d
  #RewriteCond %&#123;QUERY_STRING&#125; ^id=&#40;&#91;^&&#93;+&#41;$
  #RewriteRule node.php index.php?q=node/view/%1 &#91;L&#93;

  # Rewrite old-style URLs of the form 'module.php?mod=x'.
  #RewriteCond %&#123;REQUEST_FILENAME&#125; !-f

  #RewriteCond %&#123;REQUEST_FILENAME&#125; !-d
  #RewriteCond %&#123;QUERY_STRING&#125; ^mod=&#40;&#91;^&&#93;+&#41;$

  #RewriteRule module.php index.php?q=%1 &#91;L&#93;
  # Rewrite current-style URLs of the form 'index.php?act=x'.

  RewriteCond %&#123;REQUEST_FILENAME&#125; !-f
  RewriteCond %&#123;REQUEST_FILENAME&#125; !-d
  RewriteRule ^&#40;.*&#41;$ ./index.php?act=$1 &#91;L,QSA&#93;
</IfModule>

 # Use this line to disable hotlinking.
 RewriteRule .*\.&#40;gif|jpg|jpeg|bmp|png|tiff&#41;$ %&#123;HTTP_POST&#125;/go-portal/images?im=hotlinking_disabled &#91;R,NC&#93;
apo to error.log:

Κώδικας: Επιλογή όλων

&#91;Fri Jun 01 08&#58;46&#58;16 2007&#93; &#91;notice&#93; Apache/2.2.3 &#40;Ubuntu&#41; configured -- resuming normal operations
&#91;Fri Jun 01 08&#58;48&#58;07 2007&#93; &#91;notice&#93; caught SIGTERM, shutting down
&#91;Fri Jun 01 08&#58;48&#58;10 2007&#93; &#91;notice&#93; Apache/2.2.3 &#40;Ubuntu&#41; configured -- resuming normal operations
&#91;Fri Jun 01 08&#58;48&#58;11 2007&#93; &#91;notice&#93; caught SIGTERM, shutting down
&#91;Fri Jun 01 08&#58;48&#58;21 2007&#93; &#91;notice&#93; Apache/2.2.3 &#40;Ubuntu&#41; PHP/5.2.1 configured -- resuming normal operations
&#91;Fri Jun 01 08&#58;53&#58;31 2007&#93; &#91;notice&#93; caught SIGTERM, shutting down
&#91;Fri Jun 01 08&#58;53&#58;41 2007&#93; &#91;notice&#93; Apache/2.2.3 &#40;Ubuntu&#41; PHP/5.2.1 configured -- resuming normal operations
&#91;Fri Jun 01 09&#58;01&#58;13 2007&#93; &#91;error&#93; &#91;client 127.0.0.1&#93; File does not exist&#58; /var/www/favicon.ico
&#91;Fri Jun 01 09&#58;09&#58;57 2007&#93; &#91;notice&#93; caught SIGTERM, shutting down
PHP Warning&#58;  PHP Startup&#58; Unable to load dynamic library '/usr/lib/php5/20060613+lfs/msql.so' - /usr/lib/php5/20060613+lfs/msql.so&#58; cannot open shared object file&#58; No such file or directory in Unknown on line 0

To sfalma:

Κώδικας: Επιλογή όλων

PHP Warning&#58;  PHP Startup&#58; Unable to load dynamic library '/usr/lib/php5/20060613+lfs/msql.so' - /usr/lib/php5/20060613+lfs/msql.so&#58; cannot open shared object file&#58; No such file or directory in Unknown on line 0
to dior8osa. eixe na kanei apo to php.ini. anti na fortoso to mysql.so prospa8ousa na fortoso to msql.so (pou den ipirxe)... Tespa, auto omos den einai to mono sfalma, mias kai sto error log blepoume kai alla pragmata...

A ksexasa na anafero to sfalma pou perno sto terminal otan kano restart ton apache:

Κώδικας: Επιλογή όλων

sys-admin@laptop&#58;~$ sudo /etc/init.d/apache2 restart
 * Forcing reload of web server &#40;apache2&#41;...                                                                                                                 apache2&#58; Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
apache2&#58; Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
                                                                                                                                                      &#91; OK &#93;
Auto simbainei giati -simfona me ton apache- den exo orisei to "ServerName" directive. Sas pliroforo oti sto "000-default" iparxei i grammi:

Κώδικας: Επιλογή όλων

ServerName localhost
Ara paizetai trelo paixnidi edo... :)

Eyxaristo gia tis apantiseis sas.
Τελευταία επεξεργασία από το μέλος _Invisible_ την 02 Ιουν 2007 22:09, έχει επεξεργασθεί 1 φορά συνολικά.

Άβαταρ μέλους
_Invisible_
Δημοσιεύσεις: 418
Εγγραφή: 16 Νοέμ 2006 16:47
Τοποθεσία: Greece

[SOLVED] Apache ignores .htaccess files!!!

Δημοσίευση από _Invisible_ » 02 Ιουν 2007 22:07

Πραγματικά ταλαιπωρήθηκα ΠΑΡΑ ΠΟΛΥ για να το κάνω να δουλέψει αλλά τελικά τα κατάφερα!!! Γράφω εδώ τη λύση μήπως βοηθήσω κάποιον στο μέλλον (αυτός είναι και ο σκοπός των forums).

Αυτό που έπρεπε να κάνω ήταν μερικές αλλαγές στο .htaccess μου. Για παράδειγμα η γραμμή:

Κώδικας: Επιλογή όλων

RewriteRule .*\.&#40;gif|jpg|jpeg|bmp|png|tiff&#41;$ %&#123;HTTP_POST&#125;/go-portal/images?im=hotlinking_disabled &#91;R,NC&#93;
Έπρεπε να πάει μέσα στο <IfModule mod_rewrite.c> block. Αφού γίνει αυτό δεν πετάει κάποιο σφάλμα, αλλά η εφαρμογή δεν δουλεύει σωστά. Μετά αφού είδα το block αυτό λέω: "Το block αυτό ενεργοποιεί το RewriteEngine μόνο αν υπάρχει το module mod_rewrite. Παρακάτω όμως έχουμε τη γραμμή για την απενεργοποίηση του hotlinking." Οπότε έβαλα την γραμμή του hotlinking μέσα στο if mod_rewrite block, μετά πήγα στον φάκελο: /etc/apache2/mods-enabled. Εκεί μέσα κοίταξα τα άλλα αρχεία και είδα ότι όλα ήταν <module_name>.load. Μετά μέσα στο apache2.conf βρήκα αυτό:

Κώδικας: Επιλογή όλων

# Include module configuration&#58;
Include /etc/apache2/mods-enabled/*.load
Include /etc/apache2/mods-enabled/*.conf
Απ' αυτό κατάλαβα τι τρέχει... :D Έτσι κοίταξα ξανά τον φάκελο για να δω αν υπάρχει ένα αρχείο με όνομα "rewrite.load". Δεν υπήρχε και το δημιούργησα. Δεν ήξερα όμως τι εντολή έπρεπε να γράψω μέσα σ' αυτό το αρχείο για να δουλέψει, και έτσι άνοιξα ένα άλλο και είδα αυτό:

Κώδικας: Επιλογή όλων

LoadModule <module_name>_module /usr/lib/apache2/modules/mod_<module_name>.so
Οπότε έγραψα και εγώ στο rewrite.load:

Κώδικας: Επιλογή όλων

LoadModule rewrite_module /usr/lib/apache2/modules/mod_rewrite.so
Μετά κοίταξα στον φάκελο /usr/lib/apache2/modules/ για να δω αν υπάρχει το "mod_rewrite.so". Υπήρχε, οπότε έκανα επανεκκίνηση στον apache δίνοντας:

Κώδικας: Επιλογή όλων

sudo /etc/init.d/apache2 restart
Έγινε το restart και όλα δούλεψαν ρολόι σε όλες τις εφαρμογές που χρησιμοποιούσαν το RewriteEngine.

Παιδιά σας ευχαριστώ πολύ για τις απαντήσεις σας και τον χρόνο σας.

Φιλικά.

Απάντηση

Επιστροφή στο “Apache, IIS, DNS Servers”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες