Πρόβλημα με frames

Ερωτήσεις και απαντήσεις σχετικές με την HTML, XHTML και την κατασκευή σελίδων για το Web.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
kosmas
Δημοσιεύσεις: 75
Εγγραφή: 16 Ιουν 2007 17:01

Πρόβλημα με frames

Δημοσίευση από kosmas » 19 Αύγ 2007 19:35

Γεια σας,

έχω ie.6 και σε μία πολύ απλή εφαρμογή frames (λάθος στον κώδικα δεν υπάρχει) δεν χωρίζεται η σελίδα μου στα frames που έχω ορίσει. Μήπως η εφάρμογή αυτή δεν υποστηρίζεται από τον browser μου και πρέπει με κάποιο τρόπο να την ενεργοποιήσω ? Αν γνωρίζει κανείς ...

Ευχαριστώ πολύ!

Άβαταρ μέλους
ksarm
Δημοσιεύσεις: 915
Εγγραφή: 22 Μάιος 2007 10:47

Πρόβλημα με frames

Δημοσίευση από ksarm » 19 Αύγ 2007 21:49

υπάρχει λάθος στον κώδικα.

NIkoz

Πρόβλημα με frames

Δημοσίευση από NIkoz » 19 Αύγ 2007 22:12

Κάνε κανένα paste εδώ το Frame Set σου έτσι υποθετικά δεν μπορεί κανείς να σου πεί τίποτα παραπάνω.

kosmas
Δημοσιεύσεις: 75
Εγγραφή: 16 Ιουν 2007 17:01

Πρόβλημα με frames

Δημοσίευση από kosmas » 20 Αύγ 2007 14:48

Κώδικας: Επιλογή όλων

<html>
<head>
</head>
<body>
<frameset cols="*,*">
<frame name="kos1" src="one.htm">
<frame name="kos2" src="two.htm">
</frameset> 
</body>
</html>
[/code]

Άβαταρ μέλους
ksarm
Δημοσιεύσεις: 915
Εγγραφή: 22 Μάιος 2007 10:47

Πρόβλημα με frames

Δημοσίευση από ksarm » 20 Αύγ 2007 15:02

αυτό είναι σωστό.
Τι ακριβώς δεν παίζει?

kosmas
Δημοσιεύσεις: 75
Εγγραφή: 16 Ιουν 2007 17:01

Πρόβλημα με frames

Δημοσίευση από kosmas » 20 Αύγ 2007 15:40

Aπλά δεν μου χωρίζει την οθόνη σε frames (δεν φαίνονται δηλαδή τα frames) και επίσης δεν εμφανίζεται το περιεχόμενο των άλλων html εγγράφων. Τι λέτε να φταίει ?

NIkoz

Πρόβλημα με frames

Δημοσίευση από NIkoz » 20 Αύγ 2007 15:55

Row δεν ψήνεσε να δηλώσεις.. ?

Κώδικας: Επιλογή όλων

<HTML>
<HEAD>
   <FRAMESET COLS="*" ROWS="*,*">
      <FRAME NAME="kos1" SRC="one.html">
      <FRAME NAME="kos2" SRC="two.html">
   </FRAMESET>
</HEAD>
</HTML>

kosmas
Δημοσιεύσεις: 75
Εγγραφή: 16 Ιουν 2007 17:01

Πρόβλημα με frames

Δημοσίευση από kosmas » 20 Αύγ 2007 16:14

Tο πρόβλημα δεν είναι τα rows. Άθελα σου όμως μου έδωσες τη λύση πρέπει οι ετικέτες <frameset> και <frame> να βρίσκονται μέσα στο <head> απ΄ ότι κατάλαβα... Ισχύει αυτό ????? Πάντως μου δούλεψε.

Ευχαριστώ πολύ !!!!

Άβαταρ μέλους
ksarm
Δημοσιεύσεις: 915
Εγγραφή: 22 Μάιος 2007 10:47

Πρόβλημα με frames

Δημοσίευση από ksarm » 20 Αύγ 2007 16:16

δοκίμασες με άλλο browser?

τα rows δεν είναι απαραίτητα.

μήπως δεν καλείς σωστά τα frames??? Για κοίτα λίγο στο path που δίνεις

για δοκίμασε να βάλεις και <noframes> content και πες μας

Κώδικας: Επιλογή όλων

<frameset cols="120,*" frameborder="NO" border="0" framespacing="0"> 
  <frame name="leftFrame" scrolling="NO" noresize src="index/left/left.htm">
  <frame name="mainFrame" src="index/main/main.htm">
</frameset>
<noframes><body bgcolor="#FFFFFF" text="#000000">
Your browser does not support frames. Sorry. Please enable frames
</body></noframes>
το frameset δουλεύει κι έξω από το head

kosmas
Δημοσιεύσεις: 75
Εγγραφή: 16 Ιουν 2007 17:01

Πρόβλημα με frames

Δημοσίευση από kosmas » 20 Αύγ 2007 17:26

Aυτός ο κώδικας μου δουλεύει:

Κώδικας: Επιλογή όλων

<html>
<head>
<frameset cols="*,*">
<frame name="kos1" src="one.htm">
<frame name="kos2" src="two.htm">
</frameset>
</head>
<body>
</body>
</html>
ενώ αυτός όχι:

Κώδικας: Επιλογή όλων

<html>
<head>
</head>
<body>
<frameset cols="*,*">
<frame name="kos1" src="one.htm">
<frame name="kos2" src="two.htm">
</frameset>
</body>
</html>
Τα παραπάνω ισχύουν ανεξάρτητα αν ο browser που χρησιμοποίω είναι ie ή firefox. Επίσης εφόσον δουλεύει ο πρώτος κώδικας δεν τίθεται θέμα μη υποστήριξης των frames από τον browser (αυτό σχετικά με τη <noframes>)

Με βάση τα παραπάνω τι νομίζεται ότι φταίει ????
Μήπως τελικά πρέπει να ορίζω τα frames μέσα στο <head> ????

Άβαταρ μέλους
ksarm
Δημοσιεύσεις: 915
Εγγραφή: 22 Μάιος 2007 10:47

Πρόβλημα με frames

Δημοσίευση από ksarm » 20 Αύγ 2007 18:36

http://www.w3.org/TR/html4/present/frames.html

λογικότατο να μην σου δουλεύει ο κώδικας αφού είναι λάθος :hammer: :p

εάν χρησιμοποιήσεις frameset ΔΕΝ χρησιμοποιείς το body. Δες το link ;)
πρέπει δηλαδή να είναι έτσι:

Κώδικας: Επιλογή όλων

<html> 
<head> 
</head> 
<frameset cols="*,*"> 
<frame name="kos1" src="one.htm"> 
<frame name="kos2" src="two.htm"> 
</frameset> 
</html>

kosmas
Δημοσιεύσεις: 75
Εγγραφή: 16 Ιουν 2007 17:01

Πρόβλημα με frames

Δημοσίευση από kosmas » 20 Αύγ 2007 18:42

Ok το <frameset> ουσιαστικά αντικαθιστά το <body> ...
Όλοι τη πατήσαμε νομίζω.. :D

Ευχαριστώ πολύ πάντως !!!!!!

NIkoz

Πρόβλημα με frames

Δημοσίευση από NIkoz » 21 Αύγ 2007 05:40

Ποοοο κάναμε παλούκι απλά frames!

Anyways έκανες αυτό που ήθελες ? :PpPP

Άβαταρ μέλους
ksarm
Δημοσιεύσεις: 915
Εγγραφή: 22 Μάιος 2007 10:47

Πρόβλημα με frames

Δημοσίευση από ksarm » 21 Αύγ 2007 11:18

ksarm έγραψε:υπάρχει λάθος στον κώδικα.
χεχε! Είχα δίκιο !! :lol: :lol:

Άβαταρ μέλους
MegasmorF
Honorary Member
Δημοσιεύσεις: 1154
Εγγραφή: 07 Απρ 2005 20:05
Τοποθεσία: ./Root
Επικοινωνία:

Πρόβλημα με frames

Δημοσίευση από MegasmorF » 21 Αύγ 2007 12:32

Ρίξε μία ματιά ΕΔΩ
Πες μου τη λέξη σ αγαπώ σε σένα να πιστέψω...και γω μια ολοκληρη ζωή μπορώ να καταστρεψω...

Απάντηση

Επιστροφή στο “HTML και XHTML”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες