Πρόβλημα με php Ελληνικούς Χαρακτήρες

Σε αυτή την περιοχή μπορείτε να βρείτε ή να αναζητήσετε πληροφορίες σχετικές με την PHP

Συντονιστές: WebDev Moderators, Super-Moderators, PHP Moderators

Απάντηση
Άβαταρ μέλους
MegasmorF
Honorary Member
Δημοσιεύσεις: 1154
Εγγραφή: 07 Απρ 2005 20:05
Τοποθεσία: ./Root
Επικοινωνία:

Πρόβλημα με php Ελληνικούς Χαρακτήρες

Δημοσίευση από MegasmorF » 25 Σεπ 2007 15:48

Καλησπέρα σε όλους!!

Φτιάχνω μία σελίδα η οποία όταν ξεκίνησε ήταν HTML τώρα έχω βάλει κομμάτια php π.χ στο box με τίτλο ανακοινώσεις παίρνει τα δεδομένα απο μία βάση δεδομένων το θέμα είναι ότι σωστά έρχονται μόνο τα αγγλικά η τα ελληνικά με λατινικούς χαρακτήρες αν πάω να γράψω στην βάση ελληνικά μου βγάζει μόνο Ερωτηματικά!

Αν κάποιος ξέρει τι μπορεί να παίζει ας μου το πει πάντως έχω δοκιμάσει σχεδόν τα πάντα!!

Ευχαριστω.
Πες μου τη λέξη σ αγαπώ σε σένα να πιστέψω...και γω μια ολοκληρη ζωή μπορώ να καταστρεψω...

Άβαταρ μέλους
p_pan
Δημοσιεύσεις: 1248
Εγγραφή: 11 Φεβ 2007 20:45
Τοποθεσία: Άστεγος!

Πρόβλημα με php Ελληνικούς Χαρακτήρες

Δημοσίευση από p_pan » 25 Σεπ 2007 16:23

auto exei jana suziti8i edo... 8a mporouses na tsekaris liga topic para piso gia poio poles plirofories apo autes pou 8a s doso..

epidi antimetopiza auto to problima... ekana to ejis... eutiaja mia forma tin opoia tin sundesa stin basi.. kai etsi otan h8ela na pros8eso dedomena stin basi m.. apla to ekana meso tis formas kai oxi meso tou control panel tis basies... apo ekei kai pera otan jana trabaga ta dedomena afou ta ebgaze akatalabistika mesa stin basi otan ta zitaga se mia selida php ta ebgaze kanonika ellinika... auto exo na s protino... einai o poio eukolos tropos an den 8es na to cajeis para polu..
Αγράματος...

Άβαταρ μέλους
afroditi590
Δημοσιεύσεις: 123
Εγγραφή: 08 Ιαν 2007 11:52

Πρόβλημα με php Ελληνικούς Χαρακτήρες

Δημοσίευση από afroditi590 » 25 Σεπ 2007 16:27

εγώ έχω βάλει τη βάση μου με κωδικοποίηση greek iso, το ίδιο και τις php σελίδες και δεν έχω πρόβλημα με τα ελληνικά. Δοκιμασέ το
Ελπίζω να βοήθγσα

Άβαταρ μέλους
MegasmorF
Honorary Member
Δημοσιεύσεις: 1154
Εγγραφή: 07 Απρ 2005 20:05
Τοποθεσία: ./Root
Επικοινωνία:

Πρόβλημα με php Ελληνικούς Χαρακτήρες

Δημοσίευση από MegasmorF » 25 Σεπ 2007 17:00

Εγω στο PHPMYADMIN δεν εχω greek iso εχω greeek_general_ci και δεν δουλεύει
Πες μου τη λέξη σ αγαπώ σε σένα να πιστέψω...και γω μια ολοκληρη ζωή μπορώ να καταστρεψω...

Άβαταρ μέλους
eleni_k
Δημοσιεύσεις: 94
Εγγραφή: 07 Φεβ 2006 01:45
Τοποθεσία: Λυκαβηττός
Επικοινωνία:

Πρόβλημα με php Ελληνικούς Χαρακτήρες

Δημοσίευση από eleni_k » 25 Σεπ 2007 17:19

Ας πω και εγώ μια ιδέα:

Στο αρχείο .php που έχεις, για τη σύνδεση με τη βάση, δηλαδή εκεί που έχεις τα

Κώδικας: Επιλογή όλων

<?php

$conn=mysql_connect&#40;"roooot", "root", "pass"&#41;;
if &#40;!$conn&#41;&#123;
	die&#40;mysql_error&#40;&#41;&#41;;
	   &#125;

mysql_select_db&#40;"vasi_name",$conn&#41; or die &#40;'Could not connect!!!'&#41;;
?>
πρόσθεσε τα παρακάτω:

Κώδικας: Επιλογή όλων

@mysql_query&#40;'set character set greek'&#41;;
@mysql_query&#40;"SET NAMES 'greek'"&#41;;
Επίσης η βάση και όλοι σου οι πίνακες να έχουν collation greek_general_ci.

Άβαταρ μέλους
eleni_k
Δημοσιεύσεις: 94
Εγγραφή: 07 Φεβ 2006 01:45
Τοποθεσία: Λυκαβηττός
Επικοινωνία:

Πρόβλημα με php Ελληνικούς Χαρακτήρες

Δημοσίευση από eleni_k » 25 Σεπ 2007 17:34

Προσπάθησε, ακόμα, να βρεις το my.ini και να πρόσθεσεις στο τέλος αυτή τη γραμμή:

Κώδικας: Επιλογή όλων

default-character-set=greek

Άβαταρ μέλους
dik_
Δημοσιεύσεις: 476
Εγγραφή: 07 Ιουν 2007 11:28

Πρόβλημα με php Ελληνικούς Χαρακτήρες

Δημοσίευση από dik_ » 25 Σεπ 2007 20:33

Κατ' αρχάς πες μας τι κωδικοσελίδα χρησιμοποιείς για τις html, σε τι encoding τις σώζεις, και τι encoding έχει η βάση σου :D

Άβαταρ μέλους
MegasmorF
Honorary Member
Δημοσιεύσεις: 1154
Εγγραφή: 07 Απρ 2005 20:05
Τοποθεσία: ./Root
Επικοινωνία:

Πρόβλημα με php Ελληνικούς Χαρακτήρες

Δημοσίευση από MegasmorF » 27 Σεπ 2007 01:03

Τώρα έχω ISO WINDOWS στήν σελίδα και στην βάση greek_general_ci!
Πες μου τη λέξη σ αγαπώ σε σένα να πιστέψω...και γω μια ολοκληρη ζωή μπορώ να καταστρεψω...

Άβαταρ μέλους
dik_
Δημοσιεύσεις: 476
Εγγραφή: 07 Ιουν 2007 11:28

Πρόβλημα με php Ελληνικούς Χαρακτήρες

Δημοσίευση από dik_ » 27 Σεπ 2007 04:31

Αυτό που λέει η Ελένη τότε :)

ISO και Windows δεν πάνε ποτέ μαζί! Στη θέση σου θα προτιμούσα iso-8859-7 (και όχι win-1253) :D

Άβαταρ μέλους
MegasmorF
Honorary Member
Δημοσιεύσεις: 1154
Εγγραφή: 07 Απρ 2005 20:05
Τοποθεσία: ./Root
Επικοινωνία:

Πρόβλημα με php Ελληνικούς Χαρακτήρες

Δημοσίευση από MegasmorF » 27 Σεπ 2007 16:53

Εκανα και αυτο που λές εσυ και αυτό που είπε η Ελένη αλλα δεν έκανε τίποτα και πάλι.
Πες μου τη λέξη σ αγαπώ σε σένα να πιστέψω...και γω μια ολοκληρη ζωή μπορώ να καταστρεψω...

Άβαταρ μέλους
eleni_k
Δημοσιεύσεις: 94
Εγγραφή: 07 Φεβ 2006 01:45
Τοποθεσία: Λυκαβηττός
Επικοινωνία:

Πρόβλημα με php Ελληνικούς Χαρακτήρες

Δημοσίευση από eleni_k » 27 Σεπ 2007 18:42

Περίεργα πράγματα...

Τα Ελληνικά εμφανίζονται λάθος ακόμα και αν εισάγεις νέα δεδομένα στη βάση σου?
Για προσπάθησε αφού κάνεις αυτά που αναφέρθηκαν παραπάνω να εισάγεις καινούργια δεδομένα να δεις αν και αυτά εμφανίζονται λάθος...

Διαφορετικά δοκίμασε να φτιάξεις μία νέα βάση και πίνακα εκ νέου προσέχοντας πολύ τα collations! Σου παραθέτω κάποιες εικόνες γιατί πολλές φορές ξεφεύγει το μάτι και δεν βλέπουμε τα πάντα:

Collation όταν δημιουργούμε τη βάση:
Εικόνα

Collation όταν δημιουργούμε τον πίνακα:
Εικόνα

Και το encoding...
Εικόνα

και φυσικά δεν ξεχνάμε τις προσθήκες κώδικα που αναφέρθηκαν πιο πάνω!

Good luck! :oops:

theodark
Δημοσιεύσεις: 84
Εγγραφή: 15 Οκτ 2006 02:21
Τοποθεσία: Αθήνα

Πρόβλημα με php Ελληνικούς Χαρακτήρες

Δημοσίευση από theodark » 27 Σεπ 2007 20:57

MegasmorF έγραψε:Εκανα και αυτο που λές εσυ και αυτό που είπε η Ελένη αλλα δεν έκανε τίποτα και πάλι.
Exeis tsekarei ola ta fields gia text (VARCHAR, TEXT klp) na deis an exoun kai afta greek_general_ci ???

Prepei na yparxei epilegmeno apo esena pantou. Akoma kai an kaneis enan table (ek ton ysteron) greek_general_ci, apo latin1 ta fields tha paraminoun latin1. h an alakseis to charset mias yparxousas vasis, oi pinakes pou yparxoun idi tha synexisoun na exoun to palio charset.

Opote kane ena KALO BACKUP kai ksanatsekare ta panta ena pros ena... Kai meta prosthese ton kodika pou eipan ta paidia (SET NAMES, SET CHARACTER SET).

Epeisis oi selides sou einai se UTF-8 'h ISO-8859-1 kai h vasi se greek tote pali exeis provlima. Frontise na tis deis me kapio programma se ti charset einai sosmenes.
Gomenes olo kamari, Oloi oi antres proin fantaroi.
Mia zoh thiteia kseftyla kai volema.
(Tzimis Panousis)

Άβαταρ μέλους
Risk
Δημοσιεύσεις: 319
Εγγραφή: 02 Μάιος 2006 01:16
Τοποθεσία: Κάπου εδώ γύρω...
Επικοινωνία:

Πρόβλημα με php Ελληνικούς Χαρακτήρες

Δημοσίευση από Risk » 02 Οκτ 2007 21:30

Να πω και εγώ την δική μου εμπειρία!!!

Είχα πολλά προβλήματα στην αρχή με το enconding, ψάχνωντας εδώ μέσα και μετά από πολλές προσπάθειες κατέληξα στα παρακάτω:

Για τις html σελίδες: iso-8859-7

Στο phpmyadmin: greek_general_ci

Στα sql ερωτήματα:

Κώδικας: Επιλογή όλων

$link=mysql_connect&#40;'localhost','root','alx'&#41;
	or exit&#40;"Cannot connect to database"&#41;;
	
$result=mysql_query&#40;"SET NAMES 'greek'"&#41;;
Από τότε δεν αντιμετώπισα ξανά κάποιο πρόβλημα με το enconding!

Ελπίζω να βοήθησα οποιονδήποτε αντιμετωπίζει ή αντιμετωπίσει κάποια στιγμή κάποιο τέτοιο πρόβλημα!
Εικόνα

Απάντηση

Επιστροφή στο “PHP Προγραμματισμός”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες