Πρόβλημα με Ελληνικούς χαρακτήρες σε ένα ajax script.

Κώδικας, πληροφορίες, ερωτήσεις και απαντήσεις σχετικές με την JavaScript.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
spyros1234
Δημοσιεύσεις: 21
Εγγραφή: 21 Αύγ 2007 13:18

Πρόβλημα με Ελληνικούς χαρακτήρες σε ένα ajax script.

Δημοσίευση από spyros1234 » 21 Ιαν 2008 14:01

Αντιμετωπίζω προβλήματα με τους Ελληνικούς χαραχτήρες σε ένα ajax script.

Κώδικας: Επιλογή όλων


function doHttpRequest2() {  

httpp.open&#40;"GET", "phpdrop.php?select_form="+document.getElementById&#40;'select_form'&#41;.value+"&lang_dbcode=<?php echo $lang_dbcode; ?>", true&#41;;
  httpp.onreadystatechange = getHttpRes2;
  httpp.send&#40;null&#41;;
&#125;


function getHttpRes2&#40;&#41; &#123;
  if &#40;httpp.readyState == 4&#41; &#123; 
    ress = httpp.responseText;  
    document.getElementById&#40;'title'&#41;.innerHTML = ress;	
  &#125;
&#125;

Η phpdrop.php σελίδα παίρνει κάτι από την βάση και το κάνει echo
Και τελικά παίρνω είναι ακατανόητους χαρακτήρες.
Δοκίμασα να κάνω Include to charset και στην phpdrop.php σελίδα αλλά δεν είχε διαφορά.
Το charset που χρισιμοποιώ είναι iso-8859-7

Καμία ιδέα παιδία έχω μπλοκάρει βοήθεια.

Άβαταρ μέλους
fafos
Script Master
Δημοσιεύσεις: 6231
Εγγραφή: 30 Νοέμ 2004 03:09

Πρόβλημα με Ελληνικούς χαρακτήρες σε ένα ajax script.

Δημοσίευση από fafos » 21 Ιαν 2008 15:16

Sto top tou phpdrop.php vale auto:

header('content-type: text/html; charset=iso-8859-7');

spyros1234
Δημοσιεύσεις: 21
Εγγραφή: 21 Αύγ 2007 13:18

Πρόβλημα με Ελληνικούς χαρακτήρες σε ένα ajax script.

Δημοσίευση από spyros1234 » 21 Ιαν 2008 16:18

se efharisto doulepse horis kanena provlima

Απάντηση

Επιστροφή στο “JavaScript και Frameworks”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης