Πρόβλημα με Apache2Triad

Τεχνικές και μόνο Συζητήσεις για WEB hosting servers, Mail servers, DNS servers. Όχι αναζήτηση υπηρεσιών εδώ!

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Άβαταρ μέλους
vassilism
Δημοσιεύσεις: 1950
Εγγραφή: 17 Μαρ 2007 14:47
Επικοινωνία:

Πρόβλημα με Apache2Triad

Δημοσίευση από vassilism » 14 Φεβ 2008 22:24

Παιδιά καλησπέρα σας.
Για εικονικό server δουλεύω τον apache2triad1.5.4 και έχω μείνει πάρα πάρα πολύ ευχαριστημένος. :D
Η εγκατάστασή του είναι γελοία, όλα γίνονται μόνα τους.

Σήμερα αποφάσισα να δοκιμάσω τα windows vista home premium.
Όταν έκανα εγκατάσταση τον Apache2Triad, εγκαταστήθηκε κανονικά.
Το πρόβλημα είναι ότι δεν ανοίγει.
Δηλαδή δεν κάνει start ο Apache. Πολύ απλά αν γράψω http://localhost/ δεν βρίσκει τίποτα.

Μήπως κάτι από τα windows vista τον εμποδίζει να ξεκινήσει? :think:

Άβαταρ μέλους
vassilism
Δημοσιεύσεις: 1950
Εγγραφή: 17 Μαρ 2007 14:47
Επικοινωνία:

Πρόβλημα με Apache2Triad

Δημοσίευση από vassilism » 15 Φεβ 2008 00:31

Τελικά βρήκα την λύση.
Αν αντιμετωπίσει και κάποιος άλλος το ίδιο πρόβλημα:
Author: Ganesh.rao, Works For Real Been an a2t user for long time and upgraded to vista and a2t wouldnt boot up for me but this tut made it work without downloading a whole new server
--------------------------------------------------------------------------------
To all the bird brains that are finding a way to run Apache2Triad on Vista and for all others who gave really, long long and boaring tutorials on how to make it work, this is the exact way to do it.

Wont take you more than 30 seconds

1) Open "Apache Monitor"
2) Click on "Services"
3) Right click on "Apache2Triad Apache2 Service"
4) Click on "Properties"
5) Click on the "Log On" tab
6) HERE IS THE TRICKY PART

Log on as:
"Local System account" <--- [This would have been selected]

NOW CHANGE TO...

- "This Account"
- Enter ".\apache2triad" in the text box field.
- Enter your Apache2Triad password correctly.
- Click "Apply"
- Click "OK"


Start the service now, it will work.

Do the same thing for "Apache2Triad Apache2 Service with SSL" and you are done.

Reason: Apache is trying to run as the local account you are logged in as, where as it must run as the apache2triad user. In WinXP, etc this happens automatically on installation in WinVista it screws up.

To make Apache Monitor Work
Go to "apachemonitor.exe" and then right click... properties... compatibilty... Windows XP... Apply. Done

Απάντηση

Επιστροφή στο “Apache, IIS, DNS Servers”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες