πρόβλημα με ελληνικά στη βάση

Σε αυτή την περιοχή μπορείτε να βρείτε ή να αναζητήσετε πληροφορίες σχετικές με την PHP

Συντονιστές: WebDev Moderators, Super-Moderators, PHP Moderators

Απάντηση
antoo
Δημοσιεύσεις: 8
Εγγραφή: 11 Φεβ 2008 15:17

πρόβλημα με ελληνικά στη βάση

Δημοσίευση από antoo » 20 Ιαν 2009 14:01

Καλησπέρα σας.
Έχω 1 προβληματάκι και θα ήθελα τη βοήθειά σας αν είναι εύκολο.
Δουλεύω μια galerry on-line και θα ήθελα σε ένα link να εμφανίζω τα βιογραφικά των καλλιτεχνών. Στη βάση όμως απ'ότι είδα (phpmyadmin, xampp) δεν μπαίνουν ελληνικά. Ξέρετε πώς μπορεί να λυθεί αυτό το πρόβλημα;( Αυτό που θέλω είναι να "πατάω" στο όνομα του καλλιτέχνη και να εμφανίζεται το βιογραφικό του).
Ευχαριστώ εκ των προτέρων για το χρόνο σας.

free-stuff
Δημοσιεύσεις: 87
Εγγραφή: 28 Νοέμ 2008 13:07

πρόβλημα με ελληνικά στη βάση

Δημοσίευση από free-stuff » 20 Ιαν 2009 17:39

Καλησπέρα.

Νοουμένου ότι η βάση σου είναι unicode encoded (utf-8 ), το μόνο που έχεις να κάνεις είναι να προσθέσεις την παρακάτω γραμμή αμέσως μετά τη σύνδεση σου με τη βάση.

mysql_query("SET NAMES 'utf8';");

Άβαταρ μέλους
cpulse
Script Master
Δημοσιεύσεις: 1527
Εγγραφή: 21 Μαρ 2006 19:30
Τοποθεσία: Αθήνα village
Επικοινωνία:

πρόβλημα με ελληνικά στη βάση

Δημοσίευση από cpulse » 20 Ιαν 2009 18:52

Στην βάση μπορεί να είναι σωστά γραμμένα. Το phpMyAdmin όμως δεν είναι απόλυτα συμβατό. Αν στο phpMyAdmin δεν τα βλέπεις σωστά μη σε απασχολεί. Το θέμα είναι να φαίνονται σωστά στην ιστοσελίδα σου.

antoo
Δημοσιεύσεις: 8
Εγγραφή: 11 Φεβ 2008 15:17

πρόβλημα με ελληνικά στη βάση

Δημοσίευση από antoo » 20 Ιαν 2009 21:17

free-stuff έγραψε:Καλησπέρα.

Νοουμένου ότι η βάση σου είναι unicode encoded (utf-8 ), το μόνο που έχεις να κάνεις είναι να προσθέσεις την παρακάτω γραμμή αμέσως μετά τη σύνδεση σου με τη βάση.

mysql_query("SET NAMES 'utf8';");
Ευχαριστώ πολύ. Με την εντολή σου δούλεψε ακριβώς όπως ήθελα.

Απάντηση

Επιστροφή στο “PHP Προγραμματισμός”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης