Η σελίδα μας αναβαθμίστηκε, γι' αυτό τον λόγο τα μέλη μας θα πρέπει να ζητήσουν νέο κωδικό πρόσβασης από την υπηρεσία "Αποστολή κωδικού πρόσβασης".
Εάν το email με τον νέο κωδικό δεν έρθει στο inbox κοιτάξτε και στο spam folder. Ο server είναι φρέσκος και δεν έχει το reputation που του αξίζει.

Βοήθεια στην ACCESS,σχετικά με Encrypt/Decrypt Κωδικό

Συζητήσεις για την τοπική βάση δεδομένων Access της Microsoft

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
forow
Δημοσιεύσεις: 3
Εγγραφή: 01 Ιουν 2009 05:10

Βοήθεια στην ACCESS,σχετικά με Encrypt/Decrypt Κωδικό

Δημοσίευση από forow » 01 Ιουν 2009 05:22

Καλησπέρα στην παρέα του Forum. Θα ήθελα αν μπορεί κάποιος να μου δώσει μια μικρή βοήθεια,γιατί εδώ και μέρες έχω κολλήσει.Πρώτη φορά δουλεύω Access 2007,είχα δουλέψει λίγο την 2003,αλλά είμαι σχετικά αρχάριος όπως και να`χει.

-Έχω μία βάση στην οποία απο το μενού Tools->Encrypt With Password,έβαλα έναν κωδικό πρόσβασης. Συνέχισα να την δουλεύω κανονικά,και κάποια στιγμή συνηδειτοποίησα ότι για κάποιο λόγο δε με αφήνει να αλλάξω τον κωδικό.
Ανοίγω κανονικά Exclusive την βάση,δίνω τον κωδικό,όλα κομπλέ, και αντί να μου βγάλει στο μενου Tools την επιλογή Decrypt μου βγάζει πάλι Encrypt with password.
Πατάω και μου λέει να βάλω κωδικό για την βάση ξανά από την αρχή,ενώ έχει ήδη,και να τον κάνω Confirm από κάτω. Δοκίμασα να βάλω τον κωδικό που έχω ήδη,δεν τον δέχεται,οτιδήποτε άλλο δεν το δέχεται.

Και μια 2η ερώτηση.Για κάποιον άγνωστο λόγο έχασα όλο τον VBA κώδικα που είχα γράψει,το μόνο που έκανα ήταν μεταφορά και άνοιγμα της βάσης σε άλλο υπολογιστή.(τη βάση την έχω σε εξωτερικό σκληρό δίσκο). Μικρό το κακό,γιατί είχα Backup αλλά έχασα κανα 2 μέρες δουλειά.Τι μπορεί να προκαλέσει απώλεια του κώδικα?(ΜΟΝΟ του κώδικα)

Ευχαριστώ πολύ προκαταβολικά όσους προσφερθούν να με βοηθήσουν.

forow
Δημοσιεύσεις: 3
Εγγραφή: 01 Ιουν 2009 05:10

Βοήθεια στην ACCESS,σχετικά με Encrypt/Decrypt Κωδικό

Δημοσίευση από forow » 14 Ιουν 2009 15:22

Μετά από κάποιες μέρες τελικά βρήκα μόνος μου τη λύση,και κατάλαβα τελικά ότι ήταν τελείως noobiστικη η ερώτησή μου.Έκανα απλά σε μία καινούργια βάση import τα πάντα από τη παλιά και λύθηκε το πρόβλημα :) . Ας κλειδωθεί/διαγραφεί το θέμα ευχαριστώ!

Απάντηση

Επιστροφή στο “MS Access”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες