προβλημα με αποστολη mail

Σε αυτή την περιοχή μπορείτε να βρείτε ή να αναζητήσετε πληροφορίες σχετικές με την PHP

Συντονιστές: WebDev Moderators, Super-Moderators, PHP Moderators

Απάντηση
dimpap
Δημοσιεύσεις: 43
Εγγραφή: 02 Φεβ 2009 15:28

προβλημα με αποστολη mail

Δημοσίευση από dimpap » 18 Οκτ 2009 00:28

mariosal έγραψε:Ποιος είναι ο ISP σου;
Ο Ote είναι αλλά για email χρησιμοποιώ το yahoo και στο script έβαλα να παίρνω τα email στο yahoo.

Άβαταρ μέλους
vassilism
Δημοσιεύσεις: 1952
Εγγραφή: 17 Μαρ 2007 14:47
Επικοινωνία:

προβλημα με αποστολη mail

Δημοσίευση από vassilism » 18 Οκτ 2009 00:30

dimpap έγραψε:Εμένα ο παροχέας μου είναι yahoo
:o :o :hammer: :hammer:
Βρε καλό μου παιδί.

Δεν έχεις μια σύνδεση για να μπαίνεις στο internet?
Τι είναι αυτή η σύνδεση?
Forthnet?
Otenet?
Hol?
Tellas?

Το όνομα της σύνδεσης που έχεις θα βάλεις διπλά στο mailgate.
Δηλαδή έτσι:
SMTP = mailgate.otenet.gr

dimpap
Δημοσιεύσεις: 43
Εγγραφή: 02 Φεβ 2009 15:28

προβλημα με αποστολη mail

Δημοσίευση από dimpap » 18 Οκτ 2009 00:51

vassilism μάλλον δεν το είδες που το έγραωα ποιο πάνω.
O πάροχος που έχω είναι ΟΤΕ(conex).
Στο stmp θα βάλω mailgate.otenet.gr
και ας χρησιμοποιώ στο script το email που έχω στο yahoo?
Αυτού μπερδεύομαι :cry: :cry:

Άβαταρ μέλους
vassilism
Δημοσιεύσεις: 1952
Εγγραφή: 17 Μαρ 2007 14:47
Επικοινωνία:

προβλημα με αποστολη mail

Δημοσίευση από vassilism » 18 Οκτ 2009 00:59

dimpap έγραψε:Στο stmp θα βάλω mailgate.otenet.gr
και ας χρησιμοποιώ στο script το email που έχω στο yahoo?
Α γειά σου με έσκασες :lol:

dimpap
Δημοσιεύσεις: 43
Εγγραφή: 02 Φεβ 2009 15:28

προβλημα με αποστολη mail

Δημοσίευση από dimpap » 18 Οκτ 2009 01:01

vassilism έγραψε:
dimpap έγραψε:Στο stmp θα βάλω mailgate.otenet.gr
και ας χρησιμοποιώ στο script το email που έχω στο yahoo?
Α γειά σου με έσκασες :lol:
Οκ θα το δοκιμάσω και αυτό.
Συγνώμη για το πρήξιμο :oops: :cry:

dimpap
Δημοσιεύσεις: 43
Εγγραφή: 02 Φεβ 2009 15:28

προβλημα με αποστολη mail

Δημοσίευση από dimpap » 18 Οκτ 2009 01:20

Το έβαλα και αυτο αλλά πάλι τα ίδια μου βγάζει

Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\xampplite\htdocs\webfiles\contact.php on line 1021

Να οι ρυθμίσεις που το έκανα όπως μου είπατε
[mail function]
; For Win32 only.
SMTP = mailgate.otenet.gr
smtp_port = 25

; For Win32 only.
;sendmail_from = postmaster@localhost

; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
;sendmail_path = "C:\xampplite\sendmail\sendmail.exe -t"
Αυτο το Mercury πώς στην ευχή τρέχει? πατάω start αλλά τίποτα!!

mariosal
Honorary Member
Δημοσιεύσεις: 1473
Εγγραφή: 09 Νοέμ 2007 23:55

προβλημα με αποστολη mail

Δημοσίευση από mariosal » 18 Οκτ 2009 01:31

Άνοιξες την port 25 στο router; Έχεις Otenet;

dimpap
Δημοσιεύσεις: 43
Εγγραφή: 02 Φεβ 2009 15:28

προβλημα με αποστολη mail

Δημοσίευση από dimpap » 18 Οκτ 2009 01:35

mariosal έγραψε:Άνοιξες την port 25 στο router; Έχεις Otenet;
Ναι η πόρτα στο router είναι κανονικά ανοιχτή.
Οτενετ έχω.

Η έκδοση το xampp είναι η 1.7.0lite

Apostolis_38
Δημοσιεύσεις: 1969
Εγγραφή: 14 Φεβ 2008 16:20
Τοποθεσία: ΠΕΙΡΑΙΑΣ

προβλημα με αποστολη mail

Δημοσίευση από Apostolis_38 » 18 Οκτ 2009 01:58

Κλείσε το xammp και τρέξε την εντολή netstat -an σε command prompt, μήπως το port25 χρησιμοποιείται από άλλο πρόγραμμα.

dimpap
Δημοσιεύσεις: 43
Εγγραφή: 02 Φεβ 2009 15:28

προβλημα με αποστολη mail

Δημοσίευση από dimpap » 18 Οκτ 2009 02:39

Μόλις κατέβασα την καινούργια έκδοση του xampp την 1.7.2
Εικόνα

Παίζουν κανονικά όλα τώρα και όταν πατάω αποστολή μηνύματος μου λέει οτι το μήνυμα στάλθηκε με επιτυχία.

Το μόνο πρόβλημα είναι βάζω όλα τα στοιχεία στην φόρμα πατάω αποστολή και το στέλνει κανονικά.
Έτσι και ξανα στείλω πάλι απο την φόρμα ενώ μου γράφει οτι το μήνυμα στάλθηκε με επυτηχία δεν έρχεται στο email.

Για να μπορώ να ξαναστείλω το μήνυμα πρέπει να κάνω επανακκίνηση το pc και να ξανατρέξω το xampp.

Τι μπορεί να συμβαίνει τώρα ?

dimpap
Δημοσιεύσεις: 43
Εγγραφή: 02 Φεβ 2009 15:28

προβλημα με αποστολη mail

Δημοσίευση από dimpap » 18 Οκτ 2009 16:19

Παιδιά το πρόβλημα λύθηκε ήτανε στο yahoo.
Μόλις άλλαξα email στο script τα έπαιρνα αμέσως.
Ευχαριστώ σε όλους για την βοήθεια.

Apostolis_38
Δημοσιεύσεις: 1969
Εγγραφή: 14 Φεβ 2008 16:20
Τοποθεσία: ΠΕΙΡΑΙΑΣ

προβλημα με αποστολη mail

Δημοσίευση από Apostolis_38 » 18 Οκτ 2009 17:04

Ναι, είναι λίγο μυστήρια αυτά τα mail.
Που να δείς το hotmail "παραξενιές".

Άβαταρ μέλους
dimos_mitel
Δημοσιεύσεις: 279
Εγγραφή: 07 Αύγ 2009 21:06
Επικοινωνία:

προβλημα με αποστολη mail

Δημοσίευση από dimos_mitel » 23 Απρ 2013 19:43

Καλησπέρα παιδιά, αντιμετώπιζα το ίδιο πρόβλημα και λύθηκε.

λοιπόν, εκτός από το php.ini στον φάκελο της php υπάρχει και ένα αντίστοιχο αρχείο στο path

C:\wamp\bin\apache\Apache2.2.17\bin (θα πρέπει να αλλάξετε και αυτό ανάλογα).

υπάρχει και ένα link που με βοήθησε: http://blog.techwheels.net/send-email-f ... -sendmail/

το post το είδα σήμερα πρώτη φορά επειδή ψαχνόμουν για να λύσω το συγκεκριμένο πρόβλημα :)
miteletsis

gvre
Δημοσιεύσεις: 990
Εγγραφή: 14 Οκτ 2010 11:34
Τοποθεσία: Ηράκλειο Κρήτης
Επικοινωνία:

προβλημα με αποστολη mail

Δημοσίευση από gvre » 23 Απρ 2013 21:26

Δε χρειάζεσαι επιπλέον προγράμματα για να στείλεις email μέσω php σε windows. Το μόνο που πρέπει να κάνεις είναι να ρυθμίσεις σωστά το php.ini. Αυτό σημαίνει (παράδειγμα με FORTHnet):

Κώδικας: Επιλογή όλων

sendmail_path =
sendmail_from = youremail@ath.forthnet.gr
SMTP = mailgate.forthnet.gr
smtp_port = 25

Απάντηση

Επιστροφή στο “PHP Προγραμματισμός”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης