Creative Fatal1ty Headset & Ubuntu

Είναι δωρεάν, είναι σταθερό, είναι γρήγορο.. ας το γνωρίσουμε και λίγο καλύτερα..

Συντονιστές: Super-Moderators, Software & Hardware Moderators

Απάντηση
Tasos-21

Creative Fatal1ty Headset & Ubuntu

Δημοσίευση από Tasos-21 » 17 Οκτ 2009 13:33

Καλησπέρα,
έχω ένα πρόβλημα... Εγκατέστησα χθες τα Ubuntu 9.04 και τα πάντα λειτουργούν κανονικά, εκτός από την κάμερα του VAIO και τα ακουστικά! ;) Για την κάμερα, απ' ό,τι έψαξα, δεν υπάρχει σωτηρία... Για τα ακουστικά ωστόσο... Πώς είναι δυνατόν να έχω ήχο, αλλά όταν συνδέω τα ακουστικά στην υποδοχή (δεν είναι USB, σε 2.5mm jack, απλά) να μην ακούγεται απολύτως τίποτα; Έπαιξα λιγάκι και με τις επιλογές από το Sound με τα Mixers (Alsa) κ.τ.λ., αλλά δεν κατάφερα κάτι... Τι μπορεί να φταίει; :-?

Άβαταρ μέλους
Hermeia
Honorary Member
Δημοσιεύσεις: 987
Εγγραφή: 02 Αύγ 2004 00:14
Τοποθεσία: Αθήνα
Επικοινωνία:

Creative Fatal1ty Headset & Ubuntu

Δημοσίευση από Hermeia » 18 Οκτ 2009 17:17

Αυτό που συμβαίνει πολύ συχνά, είναι να μην έχεις ανοίξει καθόλου την ένταση των ακουστικών - δες alsamixer- και υπόψη ότι το καναλι των ακουστικών μπορεί εκεί να εμφανίζεται με άλλο (λάθος, άσχετο) όνομα.
Δηλαδή ανοίγεις 1-1 όλα τα κανάλια που δείχνει το alsamixer για να βεβαιωθείς ότι δεν είναι εδώ το πρόβλημα.
Ανοίγεις = ενεργοποιείς ΚΑΙ ανεβάζεις την ένταση στο alsamixer

Ενα άλλο που συμβαίνει αρκετά συχνά και είναι πρόβλημα ασυμβατότητας υλικού, είναι ότι το σύστημα ήχου του (Linux) δεν αναγνωρίζει τέλεια το σύστημα ήχου του hardware σου, με αποτέλεσμα να λειτουργούν μόνο κάποια κανάλια, πχ. τα ενσωματωμένα ηχεία (αν υποθέσουμε ότι από αυτά "εχεις ήχο").
Οταν βάζεις ένα καρφάκι ακουστικών στην υποδοχή τους (χωρίς απαραίτητα να είναι συνδεδεμένο με τίποτα), τότε σε πολλές συσκευές αυτό "κλείνει" αυτόματα όλες τις άλλες εξόδους ήχου, όπως για παράδειγμα τα εσωτερικά ηχεία (ή ό,τι άλλο έπαιζε πριν)
- για να το λύσεις αυτό (αν εχεις βεβαιωθει πρώτα ότι έχεις ανοίξει την ένταση σε όλα τα καναλια στο alsamixer, και πάλι δεν εχεις ήχο στα ακουστικά), ψάξε στα ubuntu-forums και στο διαδίκτυο γενικότερα, για ανθρώπους με το ίδιο πρόβλημα (ίδιο υπολογιστή ή κάρτα ήχου και ίδιο ή παρόμοιο ubuntu ή linux με τους ίδιους drivers ήχου και την ίδια ;ekdosh alsa..) - για να δεις τί ενημερώσεις χρειάζεσαι στα προγράμματα και τους οδηγούς του ήχου

Υπάρχουν βέβαια και άλλες πιθανότητες, κυρίως το ποιο πρόγραμμα παίζει και ποιο εσωτερικό (Linux) virtual σύστημα ήχου χρησιμοποιεί - αλλά αυτό θα σου έκανε να "παιζουν" ήχο γενικότερα κάποια προγράμματα ενώ άλλα όχι (ανεξάρτητα από τα ακουστικά), και λύνεται αν ρυθμίσεις τα προγράμματα που δεν παίζουν να χρησιμοποιούν το σωστο Linux-συστημα ήχου, πχ. alsa αν ξέρεις ότι αυτό είναι.

καλή επιτυχία
Hermeia the InfoSharer
Η Γνώση είναι Δύναμη
Εικόνα

Tasos-21

Creative Fatal1ty Headset & Ubuntu

Δημοσίευση από Tasos-21 » 18 Οκτ 2009 18:35

Hermeia έγραψε:Αυτό που συμβαίνει πολύ συχνά, είναι να μην έχεις ανοίξει καθόλου την ένταση των ακουστικών - δες alsamixer- και υπόψη ότι το καναλι των ακουστικών μπορεί εκεί να εμφανίζεται με άλλο (λάθος, άσχετο) όνομα.
Δηλαδή ανοίγεις 1-1 όλα τα κανάλια που δείχνει το alsamixer για να βεβαιωθείς ότι δεν είναι εδώ το πρόβλημα.
Ανοίγεις = ενεργοποιείς ΚΑΙ ανεβάζεις την ένταση στο alsamixer

Ενα άλλο που συμβαίνει αρκετά συχνά και είναι πρόβλημα ασυμβατότητας υλικού, είναι ότι το σύστημα ήχου του (Linux) δεν αναγνωρίζει τέλεια το σύστημα ήχου του hardware σου, με αποτέλεσμα να λειτουργούν μόνο κάποια κανάλια, πχ. τα ενσωματωμένα ηχεία (αν υποθέσουμε ότι από αυτά "εχεις ήχο").
Οταν βάζεις ένα καρφάκι ακουστικών στην υποδοχή τους (χωρίς απαραίτητα να είναι συνδεδεμένο με τίποτα), τότε σε πολλές συσκευές αυτό "κλείνει" αυτόματα όλες τις άλλες εξόδους ήχου, όπως για παράδειγμα τα εσωτερικά ηχεία (ή ό,τι άλλο έπαιζε πριν)
- για να το λύσεις αυτό (αν εχεις βεβαιωθει πρώτα ότι έχεις ανοίξει την ένταση σε όλα τα καναλια στο alsamixer, και πάλι δεν εχεις ήχο στα ακουστικά), ψάξε στα ubuntu-forums και στο διαδίκτυο γενικότερα, για ανθρώπους με το ίδιο πρόβλημα (ίδιο υπολογιστή ή κάρτα ήχου και ίδιο ή παρόμοιο ubuntu ή linux με τους ίδιους drivers ήχου και την ίδια ;ekdosh alsa..) - για να δεις τί ενημερώσεις χρειάζεσαι στα προγράμματα και τους οδηγούς του ήχου

Υπάρχουν βέβαια και άλλες πιθανότητες, κυρίως το ποιο πρόγραμμα παίζει και ποιο εσωτερικό (Linux) virtual σύστημα ήχου χρησιμοποιεί - αλλά αυτό θα σου έκανε να "παιζουν" ήχο γενικότερα κάποια προγράμματα ενώ άλλα όχι (ανεξάρτητα από τα ακουστικά), και λύνεται αν ρυθμίσεις τα προγράμματα που δεν παίζουν να χρησιμοποιούν το σωστο Linux-συστημα ήχου, πχ. alsa αν ξέρεις ότι αυτό είναι.

καλή επιτυχία
Ευχαριστώ πολύ για τον κόπο και την απάντηση! :wink:
Όλα είναι ενεργοποιημένα και η ένταση στο "τέρμα", οπότε μάλλον θα ψάξω σε forums, γιατί με τα εσωτερικά ηχεία δεν υπάρχει κανένα απολύτως πρόβλημα.
Ευχαριστώ και πάλι και θα ενημερώσω εάν καταφέρω να το λύσω! Έως τότε αναμένω και άλλες απόψεις, αν και η προηγούμενη ήταν πληρέστατη. :wink:

Apostolis_38
Δημοσιεύσεις: 1969
Εγγραφή: 14 Φεβ 2008 16:20
Τοποθεσία: ΠΕΙΡΑΙΑΣ

Creative Fatal1ty Headset & Ubuntu

Δημοσίευση από Apostolis_38 » 19 Οκτ 2009 21:03

Hermeia έγραψε: Ενα άλλο που συμβαίνει αρκετά συχνά και είναι πρόβλημα ασυμβατότητας υλικού, είναι ότι το σύστημα ήχου του (Linux) δεν αναγνωρίζει τέλεια το σύστημα ήχου του hardware σου, με αποτέλεσμα να λειτουργούν μόνο κάποια κανάλια
Δυστυχώς έχει δίκιο.
Επίσης πολλά προβλήματα δημιουργεί το Pulse Audio, το οποίο είναι το εξ ορισμού πρόγραμμα στο Jaunty.
Πέταξέ το ΤΕΛΕΙΩΣ (πρόσεχε γιατί έχει ένα σκασμό libs) και άσε μόνο το Alsa.
Τουλάχιστον μέχρι να σοβαρευτούν αυτοί που γράφουν το Pulse.
Διάβασε όμως καλά για την απεγκατάσταση γιατί επηρεάζει πολλές συσκευές και προγράμματα.
Αν βρω το link που χρησιμοποίησα κι εγώ θα στο γράψω.

Tasos-21

Creative Fatal1ty Headset & Ubuntu

Δημοσίευση από Tasos-21 » 21 Οκτ 2009 16:41

Ευχαριστώ πολύ, θα περιμένω! ;)
Θα ψάξω κι εγώ. :wink:

Apostolis_38
Δημοσιεύσεις: 1969
Εγγραφή: 14 Φεβ 2008 16:20
Τοποθεσία: ΠΕΙΡΑΙΑΣ

Creative Fatal1ty Headset & Ubuntu

Δημοσίευση από Apostolis_38 » 22 Οκτ 2009 11:34

http://idyllictux.wordpress.com/2009/04 ... io-at-bay/

Είναι λίγο μπέρδεμα γι αυτό πρόσεξε τι κάνεις.
Πάντως εγώ μόλις το έκανα παίξανε τα πάντα. Ασχετο που μετά απο 2 μέρες ξήλωσα όλο το Ubuntu :D

Καλη επιτυχία.

Απάντηση

Επιστροφή στο “Linux Guide”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης