Πρόβλημα με PHP...

Σε αυτή την περιοχή μπορείτε να βρείτε ή να αναζητήσετε πληροφορίες σχετικές με την PHP

Συντονιστές: WebDev Moderators, Super-Moderators, PHP Moderators

Απάντηση
Άβαταρ μέλους
crackman
Δημοσιεύσεις: 339
Εγγραφή: 26 Μαρ 2003 01:19
Τοποθεσία: Ιωάννινα, Αμαρτίας 69 ημιόροφος. Ο τελευταίος να κλείσει την πόρτα! Το κουδούνι είναι χαλασμένο :P

Πρόβλημα με PHP...

Δημοσίευση από crackman » 29 Ιουν 2003 01:06

Καλημέρα σε όσους είναι μέσα αυτή τη στιγμή αλλά και στους
'βρυκόλακες' (που λέει και ο greekbytes) που θα ακολουθήσουν.

Ανέβασα το PHPNuke 6.5 στον server μου, και τελειώνοντας, και αφού έκανα όλες τις απαραίτητες ρυθμίσεις (config.php κτλ), μου βγάζει το εξής error:
Warning: Failed opening 'language/lang-.php' for inclusion (include_path='./:/usr/local/lib/php') in /home/x-site/x-site-www/mainfile.php on line 156

Warning: Failed opening 'themes//theme.php' for inclusion (include_path='./:/usr/local/lib/php') in /home/fx-site/x-site-www/header.php on line 21

Fatal error: Call to undefined function: themeheader() in /home/x-site/x-site-www/header.php on line 38
(όπου x-site=το site μου)

Έχει κανείς ιδέα τι μπορεί να είναι;
Σας αναφέρω πως δοκίμασα να ανεβάσω και την 6.0 έκδοση του ιδίου portal, αλλά πάλι τα ίδια.
Θέλω επίσεις να σας πώ πως έλεγξα την PHP Version του Server και είναι η ίδια με αυτήν που έχω στο προσωπικό μου Η/Υ (PHP Version 4.2.3).

Ευχαριστώ προκαταβολικά για τις όποιες απαντήσεις.

Άβαταρ μέλους
cordis
Administrator, [F|H]ounder, [C|S]EO
Δημοσιεύσεις: 27616
Εγγραφή: 09 Οκτ 1999 03:00
Τοποθεσία: Greece
Επικοινωνία:

Πρόβλημα με PHP...

Δημοσίευση από cordis » 29 Ιουν 2003 01:19

den exei oristei i kirios glossa tis selida kai to kirios thema...
mallon de sou exei kathisei kala i database... koita ean exei kapoio nuke_configuration table -i- kati tetio...
Δεν απαντάω σε προσωπικά μηνύματα με ερωτήσεις που καλύπτονται από τις ενότητες του forum. Για ο,τι άλλο είμαι εδώ για εσάς.
- follow me @twitter

Άβαταρ μέλους
crackman
Δημοσιεύσεις: 339
Εγγραφή: 26 Μαρ 2003 01:19
Τοποθεσία: Ιωάννινα, Αμαρτίας 69 ημιόροφος. Ο τελευταίος να κλείσει την πόρτα! Το κουδούνι είναι χαλασμένο :P

Πρόβλημα με PHP...

Δημοσίευση από crackman » 29 Ιουν 2003 01:20

Μισό λεπτό να το ελέγξω γιατί έχω παράλληλα και την database ανοιχτή και το ftp για όποιες αλλαγές :wink:

Άβαταρ μέλους
crackman
Δημοσιεύσεις: 339
Εγγραφή: 26 Μαρ 2003 01:19
Τοποθεσία: Ιωάννινα, Αμαρτίας 69 ημιόροφος. Ο τελευταίος να κλείσει την πόρτα! Το κουδούνι είναι χαλασμένο :P

Πρόβλημα με PHP...

Δημοσίευση από crackman » 29 Ιουν 2003 01:26

Ωραία υπάρχει ένα table με όνομα nuke_config.
Έκανα περιήγηση μέσα σε αυτό αλλά δεν υπάρχει κάτι που να παραπέμπει στο πρόβλημα.

Μήπως φτέει το ότι τα tables τα ανέβασα από το PC μου?
Πάλι δεν νομίζω ότι είναι αυτό γιατί το έχω ξανακάνει και δούλεψε μια χαρα.
Τί να πω....?

Άβαταρ μέλους
cordis
Administrator, [F|H]ounder, [C|S]EO
Δημοσιεύσεις: 27616
Εγγραφή: 09 Οκτ 1999 03:00
Τοποθεσία: Greece
Επικοινωνία:

Πρόβλημα με PHP...

Δημοσίευση από cordis » 29 Ιουν 2003 01:27

an einai adio ayto to table.. tote ayto einai to problima ;)
Δεν απαντάω σε προσωπικά μηνύματα με ερωτήσεις που καλύπτονται από τις ενότητες του forum. Για ο,τι άλλο είμαι εδώ για εσάς.
- follow me @twitter

Άβαταρ μέλους
crackman
Δημοσιεύσεις: 339
Εγγραφή: 26 Μαρ 2003 01:19
Τοποθεσία: Ιωάννινα, Αμαρτίας 69 ημιόροφος. Ο τελευταίος να κλείσει την πόρτα! Το κουδούνι είναι χαλασμένο :P

Πρόβλημα με PHP...

Δημοσίευση από crackman » 29 Ιουν 2003 01:31

Λές ρε συ?

Οπότε καλό είναι να αδιάσω από την database όλα τα nuke_x tables και να το κάνω install από την αρχή...
:idea: Μάλλον αυτό θα κάνω. Έχω και ένα σχετικό installation system που το κατέβασα από τη σελίδα της PHPNuke.org :wink:

Άβαταρ μέλους
crackman
Δημοσιεύσεις: 339
Εγγραφή: 26 Μαρ 2003 01:19
Τοποθεσία: Ιωάννινα, Αμαρτίας 69 ημιόροφος. Ο τελευταίος να κλείσει την πόρτα! Το κουδούνι είναι χαλασμένο :P

Πρόβλημα με PHP...

Δημοσίευση από crackman » 29 Ιουν 2003 01:54

ΤΖΙΦΟΣ :cry:

Πάλι τα ίδια. Κατά την εγκατάσταση πάνω-πάνω μου λέει αυτό:
Warning: Failed opening 'language/lang-.php' for inclusion (include_path='./:/usr/local/lib/php') in /home/x-site/x-site-www/mainfile.php on line 156
(είπαμε x-site= το site μου)

Κανονικά αν όλα ήταν ΟΚ δεν έπρεπε να το βγάζει αυτό γιατί δεν έχει να κάνει με την database. Μετά από τον έλεγχο που κάνει τα όποια errors δεκτά αλλά πρίν?
Για να γίνω σαφέστερος γιατί δεν ξέρω κατα πόσον τα έχουν χτησιμοποιείσει άλλοι αυτό το system, ΔΕΝ έπρεπε να μου βγάζει πρόβλημα στην αρχική σελίδα της διαδικασίας της εγκατάστασης.

Πάλι δεν ξέρω τι να πώ... :cry:

Άβαταρ μέλους
crackman
Δημοσιεύσεις: 339
Εγγραφή: 26 Μαρ 2003 01:19
Τοποθεσία: Ιωάννινα, Αμαρτίας 69 ημιόροφος. Ο τελευταίος να κλείσει την πόρτα! Το κουδούνι είναι χαλασμένο :P

Πρόβλημα με PHP...

Δημοσίευση από crackman » 29 Ιουν 2003 02:38

Κάτι επιπλέον:

Ξέρει κανείς να μου πεεί πως μπορώ να διαγράψω ταυτόχρονα πάνω από 1 table με 1 εντολή;

έστω ότι έχουμε 90 tables με prefix nuke_ και θέλω να τα διαγράψω με τη μια (drop table). Πώς μπορώ να το κάνω;

Άβαταρ μέλους
Cha0s
SysAdmin
Δημοσιεύσεις: 10242
Εγγραφή: 28 Ιούλ 2001 03:00

Πρόβλημα με PHP...

Δημοσίευση από Cha0s » 29 Ιουν 2003 05:11

Gia na deis tis plirofories tis php grapse ayto se ena arxeio kai anebase to kai desto apo ton browser...

Κώδικας: Επιλογή όλων

<?php phpinfo&#40;&#41;; ?>
Gia ta tables tora...
phpMyAdmin den exeis ?
Mporeis na epilexeis ola ta tables mazi kai na ta kaneis drop...

Episis apo to phpMyAdmin mporeis na kaneis kai restore tin database (nuke.sql) gia na sou doulepsei to nuke... to problima einia ayto pou sou eipe o Giannis.

Den einai sosta setarismeni i basi me apotelesma na min briskei tin ti default glossa kai theme kai na sou bgazei error.


Sigekrimena:
Warning: Failed opening 'language/lang-.php' for inclusion (include_path='./:/usr/local/lib/php') in /home/x-site/x-site-www/mainfile.php on line 156
Stin ousia ginetai to exis.
Ginetai ena query stin basi kai apo to config table pernei to onoma tou default theme pou exeis orisei kai tis glossas kai ta kotsarei sto onoma tou arxeiou pou tha kanei include...

Diladi>
'language/lang-greek.php'
Tora epidi den einai sosta setarismeni i basi den briskei to onoma tis glossas kai tou theme kai apla meta tin payla (lang-) den bgazei tpt kai prospathei na kanei include ena arxeio pou den yparxei stin ousia!

Kati allo... An kai me ta errors pou sou ebgale den exei sxesi nomizo des apo to phpinfo() an o server exei anoixta ta register_globals (register_globals=on) giati to nuke den pezei me register_globals=off .

An einai off zita apo ton admin tou server na ta anoixei....

Ayta. Oti alli aporia exeis pes :)

Άβαταρ μέλους
crackman
Δημοσιεύσεις: 339
Εγγραφή: 26 Μαρ 2003 01:19
Τοποθεσία: Ιωάννινα, Αμαρτίας 69 ημιόροφος. Ο τελευταίος να κλείσει την πόρτα! Το κουδούνι είναι χαλασμένο :P

Πρόβλημα με PHP...

Δημοσίευση από crackman » 29 Ιουν 2003 18:27

Λοιπόν για να πώ την αλήθεια, δεν είχα phpMyAdmin και χρησιμοποιούσα αυτό που είχε το cPanel μου το οποίο είχε περιορισμούς. Ένας απο αυτούς ήταν ότι δεν είχε επιλογή για ταυτόχρονη διαγραφή tables. Τώρα που ανέβασα το δικό μου, είναι ΟΚ.

Στην κεντρική σελίδα του phpMyAdmin όμως μου εμφανίζει αυτό:
You are using PHP 4.2.3, which has a serious bug with multi-byte strings (mbstring). See PHP bug report 19404. This version of PHP is not recommended for use with phpMyAdmin.
Λέτε να έχει καμία σχέση;

Δοκίμασα τα πάντα ρε γμτ.
Άδειασα τη βάση, τίποτα.
Την ξαναγέμισα με τα default του PHPNuke, τίποτα.
Ανέβασα τη βάση από το PC μου και μαντέψτε... πάλι τίποτα.

Τι στο καλό φτέει?????

Άβαταρ μέλους
crackman
Δημοσιεύσεις: 339
Εγγραφή: 26 Μαρ 2003 01:19
Τοποθεσία: Ιωάννινα, Αμαρτίας 69 ημιόροφος. Ο τελευταίος να κλείσει την πόρτα! Το κουδούνι είναι χαλασμένο :P

Πρόβλημα με PHP...

Δημοσίευση από crackman » 29 Ιουν 2003 18:33

Σας παραθέτω και τα πλήρη στοιχεία του server που θέλω να εγκαταστήσω το portal:
Όνομα Server που φιλοξενείστε: xxx-xx.net (xxx.xxx.xx.xxx)

Όνομα Βάσης που φιλοξενείστε: localhost (127.0.0.1)

Server OS (Λειτουργικό Σύστημα): Linux 2.4.19

Tύπος & Έκδοση Βάσης Δεδομένων: MySQL 3.23.54

Ημερομηνία Server: 29/06/2003 11:34:57

Ημερομηνία Βάσης: 29/06/2003 11:34:57
Φόρτος Server: 11:34am up 6 days, 6:40, 1 user, load average: 0.99, 0.57, 0.56

HTTP Server: Apache/1.3.27 (Unix) PHP/4.2.3 FrontPage/5.0.2.2510 Rewrit/1.1a

PHP Έκδοση: 4.2.3 (Zend: 1.2.0)
Βγάλατε καμια άκρη???

Άβαταρ μέλους
Cha0s
SysAdmin
Δημοσιεύσεις: 10242
Εγγραφή: 28 Ιούλ 2001 03:00

Πρόβλημα με PHP...

Δημοσίευση από Cha0s » 29 Ιουν 2003 21:01

Den exei kamia sxesi to notice pou sou bgazei to phpMyAdmin me to na min douleyei to nuke...

basika exei arketa palia ekdosi PHP...

Alla kai se ayti tin ekdosi mou epeze kanonika to nuke emena...
(To notice tou phpMyAdmin ipirxe bebea).

SSH Access exeis ston server ?

An nai mpes me SSH katebase ekei to nuke apo to site tou php-nuke
kai kanto extract pano sto server...

mporei na min anebenoun sosta ta arxeia gia kapio logo kai na sou bgazei ayta ta errors... ti na sou po...

Άβαταρ μέλους
crackman
Δημοσιεύσεις: 339
Εγγραφή: 26 Μαρ 2003 01:19
Τοποθεσία: Ιωάννινα, Αμαρτίας 69 ημιόροφος. Ο τελευταίος να κλείσει την πόρτα! Το κουδούνι είναι χαλασμένο :P

Πρόβλημα με PHP...

Δημοσίευση από crackman » 30 Ιουν 2003 03:01

H έκδοση 4.2.3 αίναι παλιά???
Εγώ νόμιζα πως είναι σχετικά νέα...
Να φανταστείς πριν απο κανα 2 μήνες την κατέβασα, άρα πρέπει να είναι σχετικά νέα.

Όσον αφορά το SSH, δεν ξέρω καν τι είναι, πόσο μάλλον να το δουλέψω κιόλλας :oops:

Όπως είπα όμως έχω την ίδια έκδοση ΡΗΡ στο PC μου με αυτήν του Server
και στο PC μου τρέχει κανονικότατα.
Το InvisinBoard, PHPBB2 και κάποια άλλα που δοκίμασα, τρέχουν κανονικά κι αυτά (στον ίδιο server).

Μάλλον δεν υπάρχει λύση και μου σπάει τα νεύρα.
Όχι γιατί δεν σετάρετε το portal, αλλά γιατί δεν μπορώ να βρώ τι φτέει.
Τουλάχιστον να μάθω τι γίνετε, για να ξέρω για άλλη φορά.

Μέχρι και στο forum της PHPNuke UK πήγα να δώ τι θα που πούν και αυτοί
για το πρόβλημά μου...( :arrow: http://ruleit.co.uk/nuke/forums/viewtopic.php?p=873#873)

Άβαταρ μέλους
Cha0s
SysAdmin
Δημοσιεύσεις: 10242
Εγγραφή: 28 Ιούλ 2001 03:00

Πρόβλημα με PHP...

Δημοσίευση από Cha0s » 30 Ιουν 2003 03:19

Basika tora briskomaste stin 4.3.2 kai einia sta skaria apoti eipe o rapid-eraser i 4.3.3 kai esi exeis 4.2.3 ....

Apo tin 4.2.x stin 4.3.x exoun allaksei arketa pragmatakia...

Anyway ayto den einai to problima gia to nuke.

Isos exei allaksei kati sto nuke pou mou diafeygei tora kai den xero ti mporei na fteei....

Ego proti kai teleytea fora pou xrisimopoiisa nuke itan stin ekdosi 5.5 opote eimai arketa piso :P

Xero oti apo tin 6.0 kai meta metaferthikan pola stixeia tou config.php se tables mesa stin basi... isos pezei kati se ayti tin allagi pou mou diafeygei.

Isos kapios allos na exei kapia idea...

Άβαταρ μέλους
Rapid-eraser
WebDev Moderator
Δημοσιεύσεις: 6851
Εγγραφή: 05 Απρ 2003 17:50
Τοποθεσία: Πειραιάς
Επικοινωνία:

Πρόβλημα με PHP...

Δημοσίευση από Rapid-eraser » 30 Ιουν 2003 11:09

basika twra briskomaste stnv 5.01b :P alla leme twra xaaxaxax
Cu, Rapid-eraser, Tα αγαθά copies κτώνται.
Love is like oxygen, You get too much you get too high
Not enough and you're gonna die, Love gets you high

Απάντηση

Επιστροφή στο “PHP Προγραμματισμός”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες