Πρόβλημα με jar αρχείο και Vector<Vector <String>>

Συζητήσεις για την Java

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
thanos45
Δημοσιεύσεις: 8
Εγγραφή: 16 Σεπ 2008 13:22
Τοποθεσία: ΑΘΗΝΑ

Πρόβλημα με jar αρχείο και Vector<Vector <String>>

Δημοσίευση από thanos45 » 03 Φεβ 2010 19:44

Έχω δημιουργήσει μία εφαρμογή σε Java που χρησιμοποιεί μία βάση δεδομένων Access
για να καταχωρεί και να επιστρέφει απ αυτή δεδομένα.
Σε μία φόρμα JFrame() έχω εισάγει ένα JTable στο οποίο φορτώνω δεδομένα μέσα απ την κλήση της Init() στο δημιουργό της κλάσης αφού διαβαστούν απ τη βάση δεδομένων.
Χρησιμοποιώ ένα Vector που έχει στοιχεία (γραμμές) άλλους Vector τύπου string
, για να φορτώσω τα δεδομένα που διαβάζω απ τη βάση και στη συνέχεια ένα JTable στο JFrame όπου τα εμφανίζω.
Επίσης για τη δημιουργία της εφαρμογής χρησιμοποιώ το NetBeans 6.8 της Sun.
Εγώ λοιπόν όπως διάβασα για να χρησιμοποιήσω αυτόν τον τύπο δεδομένων(Vector<Vector <String>> χρηάζεται να έχω εγκατεστημένο το JDK-6 ή νεώτερο(JDK-7) .
Επιλέγω λοιπόν στα option του συγκεκριμένου project το JDK-7 και όταν τρέχω την εφαρμογή μέσα απ τον NetBeans επιστρέφει κανονικά τα δεδομένα και φορτώνονται οι γραμμές του πίνακα, και δεν έχω κανένα απολύτως πρόβλημα.
Όταν όμως δημιουργήσω και τρέξω το jar αρχείο τότε πολλές φορές δεν φορτώνονται τα δεδομένα.
Δηλαδή καταλαβαίνω ότι για κάποιο λόγο δεν θα πρέπει να έχουν φορτωθεί οι αντίστοιχες βιβλιοθήκες στο φάκελο με το δημιουργημένο project.
Μήπως γνωρίζει κανείς τι πρέπει να αλλάξω στις ρυθμίσεις του project στο NetBeans 6.8 προκειμένου να τρέχει κανονικά με αυτο τον τύπο δεδομένων?

Σας Ευχαριστώ πολύ!!!!!

Απάντηση

Επιστροφή στο “Java”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες