δεν μου εμφανίζει τα Wavatar (Generated)

Μια περιοχή για το WordPress, αυτή την δημοφιλή δωρεάν πλατφόρμα για blogging

Συντονιστές: WebDev Moderators, Super-Moderators, PHP Moderators

Απάντηση
Άβαταρ μέλους
tempo
Δημοσιεύσεις: 808
Εγγραφή: 25 Μάιος 2002 16:41
Επικοινωνία:

δεν μου εμφανίζει τα Wavatar (Generated)

Δημοσίευση από tempo » 16 Φεβ 2010 21:29

καλησπέρα,

το πρόβλημα είναι στο νέο μου site http://www.ipedia.gr

ενώ έχω ενεργοποιημένα τα Wavatar (Generated) στα σχόλια του site μου δεν εμφανίζονται οι ανάλογες εικόνες.

τι μπορεί να φταίει? μάλλον κάτι απο το θέμα που χρησιμοποιώ άλλα δεν ξέρω τι να πειράξω
http://www.automotonet.com πραγματικές καταναλώσεις αυτοκινήτων και μοτοσυκλετών όπως διαμορφώνονται απο τους οδηγούς
http://www.ipedia.gr online εγκυκλοπαίδεια με ερωτήσεις και απαντήσεις απο τους επισκέπτες

Άβαταρ μέλους
Basilakis
PHP Moderator
Δημοσιεύσεις: 8574
Εγγραφή: 17 Νοέμ 2003 13:03
Τοποθεσία: Womans' Brain
Επικοινωνία:

δεν μου εμφανίζει τα Wavatar (Generated)

Δημοσίευση από Basilakis » 16 Φεβ 2010 23:58

εγώ τα βλέπω μια χαρά;

Άβαταρ μέλους
Alice_Cooper
Δημοσιεύσεις: 1947
Εγγραφή: 11 Μάιος 2007 00:33
Τοποθεσία: Ioannina
Επικοινωνία:

δεν μου εμφανίζει τα Wavatar (Generated)

Δημοσίευση από Alice_Cooper » 17 Φεβ 2010 01:22

kane clear cache???

Άβαταρ μέλους
tempo
Δημοσιεύσεις: 808
Εγγραφή: 25 Μάιος 2002 16:41
Επικοινωνία:

δεν μου εμφανίζει τα Wavatar (Generated)

Δημοσίευση από tempo » 17 Φεβ 2010 13:38

εμένα γιατί μου δείχνει μόνο το σύμβολο του gravatar?
μιλάω για όλους τους χρήστες που δεν έχουν gravatar, στου άλλους δείχνει κανονικά την εικόνα τους.
http://www.automotonet.com πραγματικές καταναλώσεις αυτοκινήτων και μοτοσυκλετών όπως διαμορφώνονται απο τους οδηγούς
http://www.ipedia.gr online εγκυκλοπαίδεια με ερωτήσεις και απαντήσεις απο τους επισκέπτες

Άβαταρ μέλους
Basilakis
PHP Moderator
Δημοσιεύσεις: 8574
Εγγραφή: 17 Νοέμ 2003 13:03
Τοποθεσία: Womans' Brain
Επικοινωνία:

δεν μου εμφανίζει τα Wavatar (Generated)

Δημοσίευση από Basilakis » 17 Φεβ 2010 13:55

Έχεις επιλέξει απο το admin panel τα σωστά;

Άβαταρ μέλους
tempo
Δημοσιεύσεις: 808
Εγγραφή: 25 Μάιος 2002 16:41
Επικοινωνία:

δεν μου εμφανίζει τα Wavatar (Generated)

Δημοσίευση από tempo » 17 Φεβ 2010 13:57

ναι, η πλάκα είναι ότι όταν τα δείχνει μέσα στο dashboard τα δείχνει κανονικά (δηλ. με generated icons) ενώ στην σελίδα όχι...
http://www.automotonet.com πραγματικές καταναλώσεις αυτοκινήτων και μοτοσυκλετών όπως διαμορφώνονται απο τους οδηγούς
http://www.ipedia.gr online εγκυκλοπαίδεια με ερωτήσεις και απαντήσεις απο τους επισκέπτες

Άβαταρ μέλους
Basilakis
PHP Moderator
Δημοσιεύσεις: 8574
Εγγραφή: 17 Νοέμ 2003 13:03
Τοποθεσία: Womans' Brain
Επικοινωνία:

δεν μου εμφανίζει τα Wavatar (Generated)

Δημοσίευση από Basilakis » 17 Φεβ 2010 14:09

για δείξε μου τον κώδικα που χρησιμοποιείς μέσα στην σελίδα!

Άβαταρ μέλους
tempo
Δημοσιεύσεις: 808
Εγγραφή: 25 Μάιος 2002 16:41
Επικοινωνία:

δεν μου εμφανίζει τα Wavatar (Generated)

Δημοσίευση από tempo » 17 Φεβ 2010 14:14

για το comments.php

Κώδικας: Επιλογή όλων

<?php
// Do not delete these lines
	if &#40;!empty&#40;$_SERVER&#91;'SCRIPT_FILENAME'&#93;&#41; && 'comments.php' == basename&#40;$_SERVER&#91;'SCRIPT_FILENAME'&#93;&#41;&#41;
		die &#40;'Please do not load this page directly. Thanks!'&#41;;

	if &#40; post_password_required&#40;&#41; &#41; &#123; ?>
		<p class="nocomments">This post is password protected. Enter the password to view comments.</p>
	<?php
		return;
	&#125;
?>

<!-- You can start editing here. -->

<?php if &#40; have_comments&#40;&#41; &#41; &#58; ?>
	<h4 id="comments"><?php comments_number&#40;'No Comments', 'One Comment', '% Comments' &#41;;?> <em>&#40;<a href="#respond">+add yours?</a>&#41;</em></h4>

	<div class="comment-nav">
		<span class="previous"><?php previous_comments_link&#40;'Older'&#41; ?></span>
		<span class="next"><?php next_comments_link&#40;'Newer'&#41; ?></span>
	</div>

	<ol class="commentlist">
	<?php wp_list_comments&#40;'type=comment&callback=mytheme_comment'&#41;; ?>
	</ol>

 <?php else &#58; // this is displayed if there are no comments so far ?>

	<?php if &#40; comments_open&#40;&#41; &#41; &#58; ?>
		<!-- If comments are open, but there are no comments. -->

	 <?php else &#58; // comments are closed ?>
		<!-- If comments are closed. -->
		<p class="nocomments">Comments are closed.</p>

	<?php endif; ?>
<?php endif; ?>


<?php if &#40; comments_open&#40;&#41; &#41; &#58; ?>

<div id="respond">

<h4><?php comment_form_title&#40; 'Leave a Reply', 'Leave a Reply to <em>%s</em>' &#41;; ?></h4>

<p class="cancel-comment-reply">
	<?php cancel_comment_reply_link&#40;'Cancel'&#41;; ?>
</p>

<?php if &#40; get_option&#40;'comment_registration'&#41; && !is_user_logged_in&#40;&#41; &#41; &#58; ?>
<p>You must be <a href="<?php echo wp_login_url&#40; get_permalink&#40;&#41; &#41;; ?>">logged in</a> to post a comment.</p>
<?php else &#58; ?>

<form action="<?php echo get_option&#40;'siteurl'&#41;; ?>/wp-comments-post.php" method="post" id="commentform">

<?php if &#40; is_user_logged_in&#40;&#41; &#41; &#58; ?>

<p>Logged in as <a href="<?php echo get_option&#40;'siteurl'&#41;; ?>/wp-admin/profile.php"><?php echo $user_identity; ?></a>. <a href="<?php echo wp_logout_url&#40;get_permalink&#40;&#41;&#41;; ?>" title="Log out of this account">Log out &raquo;</a></p>

<?php else &#58; ?>

<p><input type="text" name="author" id="author" value="<?php echo esc_attr&#40;$comment_author&#41;; ?>" size="22" tabindex="1" <?php if &#40;$req&#41; echo "aria-required='true'"; ?> />
<label for="author">Name <small><?php if &#40;$req&#41; echo "&#40;required&#41;"; ?></small></label></p>

<p><input type="text" name="email" id="email" value="<?php echo esc_attr&#40;$comment_author_email&#41;; ?>" size="22" tabindex="2" <?php if &#40;$req&#41; echo "aria-required='true'"; ?> />
<label for="email">Mail <small><?php if &#40;$req&#41; echo "&#40;required&#41;"; ?></small></label></p>

<p><input type="text" name="url" id="url" value="<?php echo esc_attr&#40;$comment_author_url&#41;; ?>" size="22" tabindex="3" />
<label for="url">Website</label></p>

<?php endif; ?>

<!--<p><small><strong>XHTML&#58;</strong> You can use these tags&#58; <code><?php echo allowed_tags&#40;&#41;; ?></code></small></p>-->

<p><textarea name="comment" id="comment" cols="58" rows="10" tabindex="4"></textarea></p>

<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />
<?php comment_id_fields&#40;&#41;; ?>
</p>
<?php do_action&#40;'comment_form', $post->ID&#41;; ?>

</form>

<?php endif; // If registration required and not logged in ?>
</div>

<?php endif; // if you delete this the sky will fall on your head ?>
http://www.automotonet.com πραγματικές καταναλώσεις αυτοκινήτων και μοτοσυκλετών όπως διαμορφώνονται απο τους οδηγούς
http://www.ipedia.gr online εγκυκλοπαίδεια με ερωτήσεις και απαντήσεις απο τους επισκέπτες

Άβαταρ μέλους
Basilakis
PHP Moderator
Δημοσιεύσεις: 8574
Εγγραφή: 17 Νοέμ 2003 13:03
Τοποθεσία: Womans' Brain
Επικοινωνία:

δεν μου εμφανίζει τα Wavatar (Generated)

Δημοσίευση από Basilakis » 17 Φεβ 2010 14:27

-_-

Όλο το comment? :P Το gravatar ήθελα μόνο :P

Κώδικας: Επιλογή όλων

<?php
function my_own_gravatar&#40; $avatar_defaults &#41; &#123;
    $myavatar = get_bloginfo&#40;'template_directory'&#41; . '/images/gravatar.png';
    $avatar_defaults&#91;$myavatar&#93; = 'GRAVATAR NAME DISPLAYED IN WORDPRESS';
    return $avatar_defaults;
&#125;
add_filter&#40; 'avatar_defaults', 'my_own_gravatar' &#41;;
?>
Δοκίμασε να βάλεις αυτό μέσα στο functions.php και κάνε το

Κώδικας: Επιλογή όλων

   <?php wp_list_comments&#40;'type=comment&callback=mytheme_comment'&#41;; ?>
σε

Κώδικας: Επιλογή όλων

   <?php wp_list_comments&#40;'avatar_size'=>70,type=comment&callback=mytheme_comment'&#41;; ?>


Άβαταρ μέλους
tempo
Δημοσιεύσεις: 808
Εγγραφή: 25 Μάιος 2002 16:41
Επικοινωνία:

δεν μου εμφανίζει τα Wavatar (Generated)

Δημοσίευση από tempo » 17 Φεβ 2010 14:40

οκ θα το δω όταν έχω χρόνο γιατί τώρα φεύγω...θα ενημερώσω....
http://www.automotonet.com πραγματικές καταναλώσεις αυτοκινήτων και μοτοσυκλετών όπως διαμορφώνονται απο τους οδηγούς
http://www.ipedia.gr online εγκυκλοπαίδεια με ερωτήσεις και απαντήσεις απο τους επισκέπτες

Άβαταρ μέλους
tempo
Δημοσιεύσεις: 808
Εγγραφή: 25 Μάιος 2002 16:41
Επικοινωνία:

δεν μου εμφανίζει τα Wavatar (Generated)

Δημοσίευση από tempo » 17 Φεβ 2010 15:14

δυστυχώς το θέμα μου δεν έχει functions.php

λάθος......έχει κανονικά functions.php!!!!

sorry
Τελευταία επεξεργασία από το μέλος tempo την 17 Φεβ 2010 15:23, έχει επεξεργασθεί 1 φορά συνολικά.
http://www.automotonet.com πραγματικές καταναλώσεις αυτοκινήτων και μοτοσυκλετών όπως διαμορφώνονται απο τους οδηγούς
http://www.ipedia.gr online εγκυκλοπαίδεια με ερωτήσεις και απαντήσεις απο τους επισκέπτες


Άβαταρ μέλους
tempo
Δημοσιεύσεις: 808
Εγγραφή: 25 Μάιος 2002 16:41
Επικοινωνία:

δεν μου εμφανίζει τα Wavatar (Generated)

Δημοσίευση από tempo » 17 Φεβ 2010 15:30

νομίζω ότι καλό θα ήταν να σου δώσω το functions.php

Κώδικας: Επιλογή όλων

function mytheme_comment&#40;$comment, $args, $depth&#41; &#123;
   $GLOBALS&#91;'comment'&#93; = $comment; ?>
   <li>
		<p class="comment-author">
 			
<?php echo get_avatar&#40;$comment,$size='42',$default='<path_to_url>' &#41;; ?>
			<?php printf&#40;__&#40;'<cite>%s</cite>'&#41;, get_comment_author_link&#40;&#41;&#41; ?><br />
			<small><?php comment_date&#40;'M d, Y'&#41;; ?> @ <?php comment_time&#40;'H&#58;i&#58;s'&#41;; ?><?php edit_comment_link&#40;'Edit',' &#91;','&#93;'&#41; ?></small>
		</p>
		<div class="commententry" id="commententry-<?php comment_ID&#40;&#41; ?>">
			<?php if &#40;$comment->comment_approved == '0'&#41; &#58; ?>
			<p><em><?php _e&#40;'Your comment is awaiting moderation.'&#41; ?></em></p>
			<?php endif; ?>
		
			<?php comment_text&#40;&#41; ?>
		</div>
		
		<p class="reply">
		<?php comment_reply_link&#40;array_merge&#40; $args, array&#40;'add_below' => 'commententry', 'depth' => $depth, 'max_depth' => $args&#91;'max_depth'&#93;&#41;&#41;&#41; ?>
		</p>

<?php
        &#125;


?>
http://www.automotonet.com πραγματικές καταναλώσεις αυτοκινήτων και μοτοσυκλετών όπως διαμορφώνονται απο τους οδηγούς
http://www.ipedia.gr online εγκυκλοπαίδεια με ερωτήσεις και απαντήσεις απο τους επισκέπτες

Άβαταρ μέλους
tempo
Δημοσιεύσεις: 808
Εγγραφή: 25 Μάιος 2002 16:41
Επικοινωνία:

δεν μου εμφανίζει τα Wavatar (Generated)

Δημοσίευση από tempo » 17 Φεβ 2010 15:46

το βρήκα!!!!!

στην γραμμή

<?php echo get_avatar($comment,$size='42',$default='<path_to_url>' ); ?>

του functions.php

έσβησα το ,$default='<path_to_url>'


basilakis για μια,μια,μια, μια ακόμη φορά ΕΥΧΑΡΙΣΤΩ
http://www.automotonet.com πραγματικές καταναλώσεις αυτοκινήτων και μοτοσυκλετών όπως διαμορφώνονται απο τους οδηγούς
http://www.ipedia.gr online εγκυκλοπαίδεια με ερωτήσεις και απαντήσεις απο τους επισκέπτες

Απάντηση

Επιστροφή στο “WordPress γενικά”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες