Πρόβλημα με Ελληνικούς χαρακτήρες σε osCommerce

Βοήθεια λύσεις και νέα από τον χώρο των open source ή έτοιμων εφαρμογών που έχουν φτιαχτεί με την PHP όπως oscommerce, κ.α.

Συντονιστές: WebDev Moderators, Super-Moderators, PHP Moderators

Απάντηση
Lefteris33
Δημοσιεύσεις: 93
Εγγραφή: 18 Μαρ 2010 15:10
Τοποθεσία: Δαφνη
Επικοινωνία:

Πρόβλημα με Ελληνικούς χαρακτήρες σε osCommerce

Δημοσίευση από Lefteris33 » 29 Μαρ 2010 13:41

Εχω διαβάσει όλα τα βοηθήματα για το πρόβλημα με τους ελληνικούς χαρακτήρες στο osCommerce, εχω υλοποιήσει όλες τις απαραίτητες μετατροπές, αλλα το πρόβλημα εξακολουθεί.
Εχω βάση σε utf8_general_ci collation, εγκαθιστώ το πακέτο Greek utf8, στα langouage του nclude και του admin, εχω μετατρέψει τα databese.php για τον ορισμο του query σε utf8.
Στα αγγλικά είναι όλα σωστά στα ελληνικά δεν βλέπεις καθόλου χαρακτήρες.
Σε έλεγχο του admin ειδα οτι ενώ αλλάζω την ελληνική ονομασία, όταν αποθηκεύω και ξαναμπαίνω να τσεκάρω την αλλαγή το Edit των ελληνικών είναι κενό.
Εχω μπερδευτεί με διάφορες προτάσεις σε iso-8859-7 και utf-8.
Μπορεί να βοηθήσει κάποιος?

Άβαταρ μέλους
fafos
Script Master
Δημοσιεύσεις: 6231
Εγγραφή: 30 Νοέμ 2004 03:09

Πρόβλημα με Ελληνικούς χαρακτήρες σε osCommerce

Δημοσίευση από fafos » 29 Μαρ 2010 16:46

ta arxeia me tis fraseis-lekseis prepei na einai sosmena se utf xoris bom... anoikseta me to notepad++ kai sose ta me authn thn methodo kai meta kane egkatastash tou paketou..

Lefteris33
Δημοσιεύσεις: 93
Εγγραφή: 18 Μαρ 2010 15:10
Τοποθεσία: Δαφνη
Επικοινωνία:

Πρόβλημα με Ελληνικούς χαρακτήρες σε osCommerce

Δημοσίευση από Lefteris33 » 29 Μαρ 2010 19:07

Απο προηγούμενο πρόβλημα πρίν απο πολύ καιρό, γράφω μόνο σε Notepad2 with out Bom.
Μπορείς να δείς τι ακριβώς γίνετε στο http://www.kiteshop.gr

Άβαταρ μέλους
fafos
Script Master
Δημοσιεύσεις: 6231
Εγγραφή: 30 Νοέμ 2004 03:09

Πρόβλημα με Ελληνικούς χαρακτήρες σε osCommerce

Δημοσίευση από fafos » 29 Μαρ 2010 19:51

prepei na vreis pou kanei connect me thn vash (dystyxos den gnorizo apo osc) kai na valeis auta akrivos apo kato:
mysql_query(' set character set utf8 ');
mysql_query("SET NAMES 'utf8' ");

Lefteris33
Δημοσιεύσεις: 93
Εγγραφή: 18 Μαρ 2010 15:10
Τοποθεσία: Δαφνη
Επικοινωνία:

Πρόβλημα με Ελληνικούς χαρακτήρες σε osCommerce

Δημοσίευση από Lefteris33 » 29 Μαρ 2010 20:06

Αυτά ακριβώς εχω βάλει στο αρχείο (catalog/include/functions/database.php) οπου οπως καταλαβάινεις απο την θέση και την ονομασία του αρχείου περιέχει την σύνδεση και τα ερωτήματα.
Αλλα τίποτα.

Άβαταρ μέλους
fafos
Script Master
Δημοσιεύσεις: 6231
Εγγραφή: 30 Νοέμ 2004 03:09

Πρόβλημα με Ελληνικούς χαρακτήρες σε osCommerce

Δημοσίευση από fafos » 29 Μαρ 2010 20:55

Lefteris33 έγραψε:Αυτά ακριβώς εχω βάλει στο αρχείο (catalog/include/functions/database.php) οπου οπως καταλαβάινεις απο την θέση και την ονομασία του αρχείου περιέχει την σύνδεση και τα ερωτήματα.
Αλλα τίποτα.
sthn vash fainontai sosta ta ellhnika?

nbc
Honorary Member
Δημοσιεύσεις: 526
Εγγραφή: 05 Σεπ 2009 20:12
Επικοινωνία:

Πρόβλημα με Ελληνικούς χαρακτήρες σε osCommerce

Δημοσίευση από nbc » 29 Μαρ 2010 22:19

fafos έγραψε: mysql_query(' set character set utf8 ');
mysql_query("SET NAMES 'utf8' ");
Το πρώτο query, ισοδυναμεί με

Κώδικας: Επιλογή όλων

SET character_set_client = x;
SET character_set_results = x;
SET collation_connection = @@collation_database; 

(το collation_connection σετάρει και το character_set_connection)
Το δεύτερο query, ισοδυναμεί με

Κώδικας: Επιλογή όλων

SET character_set_client = x;
SET character_set_results = x;
SET character_set_connection = x;

(το character_set_connection σετάρει και το collation_connection)
Συνεπώς, όχι μόνο το 2ο query υπερκαλύπτει το 1ο (άρα τo 1o δεν έχει αποτέλεσμα), αλλά είναι και το πλέον ενδεδειγμένο από τα 2 καθώς όπως φαίνεται η διαφορά τους είναι ότι οι επιλογές colletion_connection/character_ser_connection σετάρονται explicitly και δεν παίρνουν την όποια (ακόμη και λάθος) ρύθμιση της βάσης.


Πηγή: http://dev.mysql.com/doc/refman/5.1/en/ ... ction.html

Lefteris33
Δημοσιεύσεις: 93
Εγγραφή: 18 Μαρ 2010 15:10
Τοποθεσία: Δαφνη
Επικοινωνία:

Πρόβλημα με Ελληνικούς χαρακτήρες σε osCommerce

Δημοσίευση από Lefteris33 » 30 Μαρ 2010 01:23

Οταν γίνει εγραφή απο PhpMyAdmin φαίνονται σωστά.
Όταν η εγραφή γίνεται άπο το site δέν καταχωρήτε καν.

Απάντηση

Επιστροφή στο “PHP έτοιμες εφαρμογές”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες