iframe kai button και lag

Ερωτήσεις και απαντήσεις σχετικές με την HTML, XHTML και την κατασκευή σελίδων για το Web.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
geosep
Δημοσιεύσεις: 52
Εγγραφή: 15 Μαρ 2009 01:26

iframe kai button και lag

Δημοσίευση από geosep » 15 Απρ 2010 17:06

Έβαλα ένα iframe στην ιστοσελίδα μου και από τότε έχω κάποιο lag μετά από κάποια δευτερόλεπτα με τον mozilla αλλά και από όσο μου είπαν και με άλλους browsers, μόνο ο google chrome δεν έχει πρόβλημα από όσο το δοκίμασα.
Το iframe αυτό είναι κάποια php σελίδα που κάνει κάθε 10 sec auto refresh, δεν ξέρω αν φταίει αυτό.
www.c-sro.eu
Είναι το iframe με την tablet.

Ο κώδικας είναι ο παρακάτω:

Κώδικας: Επιλογή όλων

<iframe src="/statistic/en/en.php" width="100%" height="330" scrolling="no" frameborder="0" allowtransparency="false"></iframe>
Το δεύτερο θέμα μου είναι ότι θέλω να βάζω σε αυτό το iframe ένα ακόμα php αρχείο το οποίο είναι όμοιο με αυτό αλλά στα Kινεζικα, θέλω με ένα button να το αλλάζει όποιος θέλει και να βλέπει την Κινέζικη version.
Διάβασα πολλά θέματα εδώ για το θέμα αυτό αλλά δεν κατάλαβα τίποτα και κανένα δεν με βοηθησε να το κάνω.

Σας ευχαριστώ εκ των προτέρων.

geosep
Δημοσιεύσεις: 52
Εγγραφή: 15 Μαρ 2009 01:26

iframe kai button και lag

Δημοσίευση από geosep » 16 Απρ 2010 14:15

Κανεις τιποτα???

MasterX
Δημοσιεύσεις: 92
Εγγραφή: 13 Οκτ 2009 13:29
Επικοινωνία:

iframe kai button και lag

Δημοσίευση από MasterX » 16 Απρ 2010 14:48

Με ποιό τρόπο δημιουργούνται τα δεδομένα που προβάλλεις? Αν το script /statistic/en/en.php δημιουργεί κάθε φορά τα δεδομένα, τότε το πρόβλημα είναι με τον κώδικα. Μπορείς να έχεις πολλά query. Αν αυτά τα δεδομένα δεν αλλάζουν συχνά, μπορείς να τρέχεις ένα άλλο script οπου θα δημιουργεί αυτά τα δεδομένα, και μετά το /statistic/en/en.php θα τα παρουσιάζει

geosep
Δημοσιεύσεις: 52
Εγγραφή: 15 Μαρ 2009 01:26

iframe kai button και lag

Δημοσίευση από geosep » 16 Απρ 2010 15:25

Τα δεδομενα μεταφερονται με bat σε ftp command στην ιστοσελιδα οπου και το en.php βρισκεται, το php τα παιρνει απο ini καθε 10 sec γιαυτο και το en.php εχει div που κανει καθε 10 sec refresh, εβαλα το en.php με iframe στο index και απο τοτε εχω καποιο lag.
Απο εχθες εχω προβλημα και στο upload τα ini στον webserver κωλαει παντα στην εντολη "put C:/blabla"
Υπαρχει εντολη σε ftp για replace η κατι τετοιο μηπως και κωλαει λογο του οτι ηδη υπαρχουν και δεν μπορει να τα αντικαταστησει.??

MasterX
Δημοσιεύσεις: 92
Εγγραφή: 13 Οκτ 2009 13:29
Επικοινωνία:

iframe kai button και lag

Δημοσίευση από MasterX » 16 Απρ 2010 16:22

geosep έγραψε:Τα δεδομενα μεταφερονται με bat σε ftp command στην ιστοσελιδα οπου και το en.php βρισκεται, το php τα παιρνει απο ini καθε 10 sec γιαυτο και το en.php εχει div που κανει καθε 10 sec refresh, εβαλα το en.php με iframe στο index και απο τοτε εχω καποιο lag.
Απο εχθες εχω προβλημα και στο upload τα ini στον webserver κωλαει παντα στην εντολη "put C:/blabla"
Υπαρχει εντολη σε ftp για replace η κατι τετοιο μηπως και κωλαει λογο του οτι ηδη υπαρχουν και δεν μπορει να τα αντικαταστησει.??
Αυτό που μπορείς να κάνεις είναι να τρέχεις πρώτα μια εντολή που θα σβήσει το υπάρχων ini αρχεία, και στη συνέχεια θα ανεβάσεις το νέο αρχείο. Γιατί επέλεξες να εισάγεις τα δεδομένα με iframe?

geosep
Δημοσιεύσεις: 52
Εγγραφή: 15 Μαρ 2009 01:26

iframe kai button και lag

Δημοσίευση από geosep » 17 Απρ 2010 00:28

Δοκιμασα να κανει del πρωτα τα αρχεια που υπαρχουν αλλα παλι κολαει και δεν εκτελει την put.
Δεν εισαγω δεδομενα με iframe απλα τα προβλαω απο αλλο folder του webserver οπου ειναι ολα τα αρχεια εκει μαζι.
Δοκιμασα και με include αντι για iframe αλλα με το include δεν φαινεται το refresh που κανει το en.php

Για το θεμα
http://www.freestuff.gr/forums/viewtopi ... torder=asc

Απάντηση

Επιστροφή στο “HTML και XHTML”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες