πρόβλημα με subdomain

Από που να ξεκινήσω; Που θα βρω; κ.α. γενικές ερωτήσεις για την δημιουργία μιας ιστοσελίδας.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
stratis79
Δημοσιεύσεις: 118
Εγγραφή: 15 Νοέμ 2009 17:12

πρόβλημα με subdomain

Δημοσίευση από stratis79 » 20 Ιουν 2010 19:59

καλησπέρα παιδιά,

έφτιαξα μια ιστοσελίδα η οποία θα βγει μόνο για 2-3 μήνες και θα αποτελεί μέρος ενός ήδη υπάρχοντος site. επειδή θέλω όμως να έχει μια κάποια εικόνα αυτονομίας έκανα ένα subdomain και εκεί μετά μέσα στο φάκελο ανέβασα φακέλους και αρχεία της ιστοσελίδας.

Υπάρχει όμως ένα πρόβλημα, τα banner δεν εμφανίζονται. Ναι μεν τα links είναι ενεργά αλλά δεν φαίνονται οι εικόνες.

Καμια ιδέα;
Τελευταία επεξεργασία από το μέλος stratis79 την 20 Ιουν 2010 20:06, έχει επεξεργασθεί 1 φορά συνολικά.

Άβαταρ μέλους
burnmind
Script Master
Δημοσιεύσεις: 954
Εγγραφή: 26 Σεπ 2009 02:14
Τοποθεσία: UK
Επικοινωνία:

πρόβλημα με subdomain

Δημοσίευση από burnmind » 20 Ιουν 2010 20:02

Πρόσεξε αν τα paths που έδωσες είναι σωστά. Επίσης, ένα link θα βοηθούσε.

stratis79
Δημοσιεύσεις: 118
Εγγραφή: 15 Νοέμ 2009 17:12

πρόβλημα με subdomain

Δημοσίευση από stratis79 » 20 Ιουν 2010 20:15

τα paths σωστά πρέπει να είναι. Όπως είναι όλα στο pc τα πέρασα και στο folder του subdomain.

Άβαταρ μέλους
burnmind
Script Master
Δημοσιεύσεις: 954
Εγγραφή: 26 Σεπ 2009 02:14
Τοποθεσία: UK
Επικοινωνία:

πρόβλημα με subdomain

Δημοσίευση από burnmind » 20 Ιουν 2010 20:57

stratis79 έγραψε:τα paths σωστά πρέπει να είναι. Όπως είναι όλα στο pc τα πέρασα και στο folder του subdomain.
Δε σε βλέπω και πολύ σίγουρο, οπότε γιατί δεν ελέγχεις αν όντως είναι σωστα;!

Επίσης, δε μπορεί κανείς να μαντέψει τι πρόβλημα υπάρχει χωρίς να μας δείξεις το πρόβλημα, οπότε δώσε κάποιο link ή κώδικα..

GeorgeMak
Δημοσιεύσεις: 23
Εγγραφή: 10 Ιουν 2010 20:26

πρόβλημα με subdomain

Δημοσίευση από GeorgeMak » 20 Ιουν 2010 21:59

Όντως δε βοηθά το ότι δεν έδωσες κάποιο link για να τα δούμε, το καλύτερο που έχεις να κάνεις είναι να checkάρεις firebug/chrome developer tools ή IE debugbar (για τους άλλους browsers δε γνωρίζω, sorry) και να δεις που κάνουν failed requests (http 404 errors). Επίσης θέλω να τονίσω ότι το subdomain παίζει ανεξάρτητα από το parent domain, δηλαδή δεν υπάρχει τρόπος να πάρεις με relative paths τα banners*.

edit: Αυτό σημαίνει ότι για να εμφανίζονται και στο toplevel και στο subdomain τα βάζεις στα httpdocs directories και των δυο.
Ελπίζω να βοήθησα.

stratis79
Δημοσιεύσεις: 118
Εγγραφή: 15 Νοέμ 2009 17:12

πρόβλημα με subdomain

Δημοσίευση από stratis79 » 24 Ιουν 2010 11:31

παιδιά καλημέρα, τελικά δεν προχώρησε αυτή η ιδέα με το subdomain και για λόγους επισκεψιμότητας της μητρικής σελίδας αποφασίσαμε να την εντάξουμε μέσα σε αυτή.

Δεν είχε τύχει ποτέ να ασχοληθώ με subdomain παρά μόνο με κάτι πειράματα που έκανα πριν πολύ καιρό για να ρίξω μια ματιά στο joomla.

Πάντως για να δω αν είμαι σωστός. Όπως είναι οι φάκελοι και τα αρχεία τα βάζεις μέσα στο φάκελο του subdomain σωστά;

Απάντηση

Επιστροφή στο “Γενικές ερωτήσεις κατασκευής ιστοσελίδων”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες