[SOLVED]index.html ή index.php δεν δουλεύουν!

Τεχνικές και μόνο Συζητήσεις για WEB hosting servers, Mail servers, DNS servers. Όχι αναζήτηση υπηρεσιών εδώ!

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
driveland
Δημοσιεύσεις: 59
Εγγραφή: 04 Ιούλ 2010 15:40

[SOLVED]index.html ή index.php δεν δουλεύουν!

Δημοσίευση από driveland » 10 Ιούλ 2010 20:44

οκ δεν πρόκειτε να το ξέρει κανείς αλλά ποτέ δεν ξέρεις.

κάτι έγινε στον server δε ξέρω τι και μετα εμφανίστηκε το εξης πρόβλημα:
οταν πάω π.χ. εδώ www.istoselida.gr/images
ενω μέσα στο φάκελο έχω index.html ή και index.php
δεν το αναγνωριζει και αντι για blank βγάζει λίστα με όλα τα αρχεία!

Αυτό γίνετε σε όλους τους φακέλους και σε όλα τα domains που θα βάλω.

Μια λύση είναι να προσθέσω στο .htaccess
DirectoryIndex index.php index.html
όπου εμφανίζεται το πρόβλημα.

δηλαδή με καθε καινούριο domain που θα βάζω θα πρέπει απο εδώ και πέρα να κάνω αυτό το πράμα? γιατι πρώτα δεν υπήρχε το προβλημα αυτο.

cpanel εχω shared server
Τελευταία επεξεργασία από το μέλος driveland την 11 Ιούλ 2010 14:26, έχει επεξεργασθεί 1 φορά συνολικά.

Άβαταρ μέλους
Giannis78
Δημοσιεύσεις: 1334
Εγγραφή: 11 Οκτ 2005 12:45
Τοποθεσία: Assigned by DHCP
Επικοινωνία:

[SOLVED]index.html ή index.php δεν δουλεύουν!

Δημοσίευση από Giannis78 » 11 Ιούλ 2010 01:02

milises me tin etairia pou se filoksenei? fenete san na einai lathos to config tou apache....
WebHosting Services
http://www.intechs.gr

driveland
Δημοσιεύσεις: 59
Εγγραφή: 04 Ιούλ 2010 15:40

[SOLVED]index.html ή index.php δεν δουλεύουν!

Δημοσίευση από driveland » 11 Ιούλ 2010 02:24

μίλησα ναι... έβαλαν linux administrator na ψάξει τίποτα!
ξανα έβαλαν Super administrator πάλι τίποτα.
lol
και μιλάμε για hostgator τωρα. που πιστεύω είνα άψογη σε θέματα εξυπηρέτησης

Άβαταρ μέλους
CyberCr33p
Honorary Member
Δημοσιεύσεις: 3197
Εγγραφή: 06 Νοέμ 1999 01:00
Τοποθεσία: Αθήνα
Επικοινωνία:

[SOLVED]index.html ή index.php δεν δουλεύουν!

Δημοσίευση από CyberCr33p » 11 Ιούλ 2010 10:32

Φαντάζομαι ότι πείραξαν τη ρύθμιση του apache. Αλλά σίγουρα αυτό είναι το πρώτο που θα έπρεπε να κοιτάξουν και πιθανότατα να κοίταξαν.

driveland
Δημοσιεύσεις: 59
Εγγραφή: 04 Ιούλ 2010 15:40

[SOLVED]index.html ή index.php δεν δουλεύουν!

Δημοσίευση από driveland » 11 Ιούλ 2010 10:54

CyberCr33p έγραψε:Φαντάζομαι ότι πείραξαν τη ρύθμιση του apache.
μ***, μου φένετε κάνουν κλικ οπου να ειναι - σαν και μενα! :hammer:

Άβαταρ μέλους
fiskilis
Honorary Member
Δημοσιεύσεις: 14093
Εγγραφή: 16 Νοέμ 2003 22:44
Τοποθεσία: Athens
Επικοινωνία:

[SOLVED]index.html ή index.php δεν δουλεύουν!

Δημοσίευση από fiskilis » 11 Ιούλ 2010 12:17

λιγο περιεργο παντως!
αν μπορουσες να δωσεις λινκ μεσω prive να εριχνα μια ματια ισως κατι να βρισκαμε

driveland
Δημοσιεύσεις: 59
Εγγραφή: 04 Ιούλ 2010 15:40

[SOLVED]index.html ή index.php δεν δουλεύουν!

Δημοσίευση από driveland » 11 Ιούλ 2010 13:43

fiskilis έγραψε:λιγο περιεργο παντως!
αν μπορουσες να δωσεις λινκ μεσω prive να εριχνα μια ματια ισως κατι να βρισκαμε
είναι περίργο... γιατι εγώ τους έλεγα απο μια αρχή ότι υπάρχει ενδεχόμενο να πειράχτηκε καταλάθος το αρχικό .htaccess απο το primary domain του shared server με αποτέλεσμα να υπάρχει πρόβλημα και στα υπόλοιπα addon domains και φακέλους.

τους είπα να μου στείλουν ξανα το αρχικό .htaccess όταν προτοέστησαν τον server αλλά δεν το εστειλαν...
μεχρι εκεί φτάνουν οι γνώσεις μου δε ξέρω τι αλλο μπορει να φταιει η τι εκαναν αυτη απο πισο απο το whmcm.

αν επιμένεις να χάσεις το χρόνο σου... ναι αμε να στηλω pm

driveland
Δημοσιεύσεις: 59
Εγγραφή: 04 Ιούλ 2010 15:40

[SOLVED]index.html ή index.php δεν δουλεύουν!

Δημοσίευση από driveland » 11 Ιούλ 2010 14:30

[SOLVED] όλα τα δέοντα στον fiskilis! :D

Άβαταρ μέλους
Giannis78
Δημοσιεύσεις: 1334
Εγγραφή: 11 Οκτ 2005 12:45
Τοποθεσία: Assigned by DHCP
Επικοινωνία:

[SOLVED]index.html ή index.php δεν δουλεύουν!

Δημοσίευση από Giannis78 » 12 Ιούλ 2010 01:22

και το πρόβλημα ηταν........????
WebHosting Services
http://www.intechs.gr

Άβαταρ μέλους
CyberCr33p
Honorary Member
Δημοσιεύσεις: 3197
Εγγραφή: 06 Νοέμ 1999 01:00
Τοποθεσία: Αθήνα
Επικοινωνία:

[SOLVED]index.html ή index.php δεν δουλεύουν!

Δημοσίευση από CyberCr33p » 12 Ιούλ 2010 08:41

Μάλλον κάποιο δεύτερο .htaccess που άλλαζε τις ρυθμίσεις σε όλες τις υποσελίδες/υποφακέλους.

Απάντηση

Επιστροφή στο “Apache, IIS, DNS Servers”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες