Το site μου δεν δουλευει

Γενικές ερωτήσεις και απαντήσεις που έχουν σχέση με το Internet και την καθημερινή του χρήση.

Συντονιστής: Super-Moderators

Απάντηση
micahelcom
Δημοσιεύσεις: 14
Εγγραφή: 11 Μαρ 2010 20:00

Το site μου δεν δουλευει

Δημοσίευση από micahelcom » 25 Ιούλ 2010 00:48

Προσπαθώ εδώ και καιρο να φτιάξω ένα σίτε και να το σηκωσω απο δικο μου PC πρώτα απ' ολα έκανα ένα λογαριασμό στο dyndns.com μετά έφτιαξα το domain που θελω το ενεργοποίησα μετά έβαλα το apache (το εβαλα για δοκιμη μετα θα το αλλαζα σε xampp)
και εβαλα επίσης το dyndns updater αφού τα ρυθμισα όλα στο lan και στο PC μου όλα δουλευαν ρολόι τώρα άρχισα να ξεκινάω να προσπαθώ να βγεί στο domain που είχα επιλέξει πρώτα απ' όλα έκανα ανοιξα στην πορτα 80(και στο ρουτερ και απο τον οτε) στην ip του PC μου (οταν έβαζα αυτήν την ip στον firefox μου έλεγε it works αυτό που θέλαμε) μετα (επειδη έχω οτε) πηγα και απενεργοποιησα την ασφαλεια που είχε παρ' όλα αυτα την ώρα που έγραφα το domain που είχα επιλέξει μου έβγαζε το ρουτερ μου γιατι τι εκανα λαθος??????

το router μου ειναι το F@ST™ 1201T069 μαρκας sagem

Άβαταρ μέλους
hitca
Honorary Member
Δημοσιεύσεις: 1919
Εγγραφή: 13 Ιουν 2010 19:41
Τοποθεσία: Brussels
Επικοινωνία:

Το site μου δεν δουλευει

Δημοσίευση από hitca » 25 Ιούλ 2010 01:18

Δεν λειτουργεί (σωστά) το NAT του router που κάνει την ανακατεύθυνση.
Πρέπει στα win να ρυθμιστεί και το firewall (να επιτρέψεις λειτουργία web server)

Μπορεί και να απαιτείται άλλος router (με καλύτερες ρυθμίσεις)
Αναφέρεις ότι άνοιξες την port 80 και στον οτε(??). Δηλαδή τι ??

micahelcom
Δημοσιεύσεις: 14
Εγγραφή: 11 Μαρ 2010 20:00

Το site μου δεν δουλευει

Δημοσίευση από micahelcom » 25 Ιούλ 2010 03:43

ο οτε μου μπλοκααρει για ασφαλεια καμποσες θυρες μαζι και την 80

Άβαταρ μέλους
Connor MacLeod
Honorary Member
Δημοσιεύσεις: 13372
Εγγραφή: 07 Φεβ 2005 13:36
Τοποθεσία: Κοζάνη
Επικοινωνία:

Το site μου δεν δουλευει

Δημοσίευση από Connor MacLeod » 25 Ιούλ 2010 14:04

Ο ΟΤΕ αποκλειετε να σε block-άρει την port 80

Ειναι η λεγομενη "web port"
Meizu MX5(5.5"/8Core/3GB/32GB/Sony IMX220 20.7MP)
PC 27'' (3770@3.4/16GB/560SE/500GB SATA3/650W S12G)
Mac mini (2.5GHz/8GB/6630/90GB GorsairGT)

Άβαταρ μέλους
hitca
Honorary Member
Δημοσιεύσεις: 1919
Εγγραφή: 13 Ιουν 2010 19:41
Τοποθεσία: Brussels
Επικοινωνία:

Το site μου δεν δουλευει

Δημοσίευση από hitca » 25 Ιούλ 2010 18:18

Χρειάζεται να κάνεις ορισμένες συγκεκριμένες ενέργειες για τέτοια θέματα....(απαιτούνται και γνώσεις). Η ίδια διαδικασία γίνεται και όταν θέλουμε άψογη δικτυακή λειτουργία για παιχνίδια (αλλάζουν αναλόγως κάποιες ρυθμίσεις βέβαια ..)

-- Δηλαδή
1. Δηλώνουμε στατική ip στην κάρτα δικτύου του υ/η (υποχρεωτικά, server ρυθμίζουμε)
2. Μπαίνουμε στο μενού του router (με login ώς administrator) και αναζητούμε το μενού NAT ή VIRTUAL SERVER
3. Κάνουμε προσθήκη απο το μενού επιλογών του Virtual Server και επιλέγουμε Web Server (http) για χρήση και δηλώνουμε -προσεκτικά- την ip που αυτός εκπέμπει (πρέπει να είναι απολύτως ίδια με την static ip που ορίσαμε στις επιλογές της κάρτας δικτύου που θα χρησιμοποιούμε).

Τώρα ο router με αυτές τις ρυθμίσεις 'επιτρέπει' στην συγκεκριμένη ip (του υ/η μας) να κάνει broadcast έναν web server με http πρωτόκολλο (στη θύρα 80).

-- Στον υ/η πρέπει να ρυθμιστεί το firewall (δεν έχει σημασία να απενεργοποιηθεί ή όχι) να επιτρέπει την λειτουργία web server (ισχύει και για τον apache αυτό).
Στις ιδιότητες δικτύου > για προχωρημένους θα φανεί αυτό ....κλίκ ενεργοποίηση και αποδοχή των σχετικών ρυθμίσεων. --- δηλαδή άν και κλειστό ή απενεργοποιημένο το firewall έχει ρυθμίσεις που επηρεάζουν την (δικτυακή) λειτουργία του υ/η ---

-- Ενεργοποιείς το dyndns agent.
-- Ενεργοποιείς το site.

Εάν όλα είναι εντάξει, τότε το site εκπέμπει το περιεχόμενό του στο Internet (εξαρτάται και απο την ταχύτητα σύνδεσής σου...) και μέσω της υπηρεσίας dyndns το βλέπεις (ανεξάρτητα απο την -δυναμική- ip που έχεις απο τον πάροχό σου) πληκτρολογώντας το κατάλληλο host name πχ. http://toonomasou.katiallo.katitis. Εάν δεν είχες dydns θα έπρεπε αντίστοιχα κάτι τέτοιο http://123.123.123.123:80 (η public ip του υ/η σου και η θύρα του server)

...αυτά τα ολίγα...

σχετικές φωτο εδώ για όλα αυτά >>>

Εικόνα
Εικόνα
Εικόνα
Εικόνα
Εικόνα
Εικόνα

micahelcom
Δημοσιεύσεις: 14
Εγγραφή: 11 Μαρ 2010 20:00

Το site μου δεν δουλευει

Δημοσίευση από micahelcom » 25 Ιούλ 2010 22:55

Ολα αυτα τα έχω κανει ΑΚΡΙΒΩΣ... Αλλα δεν παιζει

Άβαταρ μέλους
hitca
Honorary Member
Δημοσιεύσεις: 1919
Εγγραφή: 13 Ιουν 2010 19:41
Τοποθεσία: Brussels
Επικοινωνία:

Το site μου δεν δουλευει

Δημοσίευση από hitca » 25 Ιούλ 2010 23:00

Δοκίμασε πλέον με άλλον router, τι να πώ.....

Ίσως κάποιο άλλο μέλος έχει καμμιά ιδέα που μας διαφεύγει...

micahelcom
Δημοσιεύσεις: 14
Εγγραφή: 11 Μαρ 2010 20:00

Το site μου δεν δουλευει

Δημοσίευση από micahelcom » 26 Ιούλ 2010 13:10

Σκεφτομαι να παρω αυτο http://www.plaisio.gr/Peripherals/Netwo ... G834IT.htm τι λες κανει την δουλεια που θελω?

Άβαταρ μέλους
hitca
Honorary Member
Δημοσιεύσεις: 1919
Εγγραφή: 13 Ιουν 2010 19:41
Τοποθεσία: Brussels
Επικοινωνία:

Το site μου δεν δουλευει

Δημοσίευση από hitca » 26 Ιούλ 2010 16:07

Εάν δεν επιβεβαιώσεις ότι αυτό φταίει, μήν πάρεις τίποτα (γιατί απλώς θα επαναληφθεί το πρόβλημα)

-- Το site είναι εντάξει? (κάνε το σε xampp, είναι αξιόπιστο και σίγουρο)
-- Μήπως κάτι ακόμα στον υ/η εμποδίζει το site να είναι online? (δοκίμασε με άλλον υ/η ή και laptop στον ίδιο router)

Δεν θέλω να γίνω μάντης 'κακών', αλλά κάτι δεν λειτουργεί όπως πρέπει...

--- ο router που προτείνεις, μια χαρά φαίνεται ---

nikos89
Δημοσιεύσεις: 43
Εγγραφή: 02 Δεκ 2008 12:10

Το site μου δεν δουλευει

Δημοσίευση από nikos89 » 26 Ιούλ 2010 16:42

Ο ΟΤΕ έχει κλειστές μερικές πόρτες, μαζί με αυτές τις πόρτες είναι και η 80 που χρησιμοποιεί ο web server σου.

Θα πάς εδώ: https://ps.otenet.gr/active/ServiceActi ... csAuth.jsp
Θα κάνεις login με τα στοιχεία σου (κωδικό πελάτη και συνθηματικό θα τα βρεις στα χαρτιά όταν είχες κάνει την σύνδεση), και θα βρεις μια επιλογή που είναι για ασφάλεια, δεν θυμάμαι τώρα ακριβώς πως το γράφει, θα το βρεις και θα επιλέξεις ΟΧΙ. Λογικά μετά θα είσαι οκ.

micahelcom
Δημοσιεύσεις: 14
Εγγραφή: 11 Μαρ 2010 20:00

Το site μου δεν δουλευει

Δημοσίευση από micahelcom » 26 Ιούλ 2010 22:12

nikos89 έγραψε:Ο ΟΤΕ έχει κλειστές μερικές πόρτες, μαζί με αυτές τις πόρτες είναι και η 80 που χρησιμοποιεί ο web server σου.

Θα πάς εδώ: https://ps.otenet.gr/active/ServiceActi ... csAuth.jsp
Θα κάνεις login με τα στοιχεία σου (κωδικό πελάτη και συνθηματικό θα τα βρεις στα χαρτιά όταν είχες κάνει την σύνδεση), και θα βρεις μια επιλογή που είναι για ασφάλεια, δεν θυμάμαι τώρα ακριβώς πως το γράφει, θα το βρεις και θα επιλέξεις ΟΧΙ. Λογικά μετά θα είσαι οκ.
Ειπαμε οτι το εχω κανει αυτο.


---Κοιτα ο η\υ που το τρεχω δουλεβει μια χαρα εγω υποψιαζομαι το router θα ξανακανω ολα ---απο την αρχη και θα σου πω αμα εχω το ιδιο προβλημα.

nikos89
Δημοσιεύσεις: 43
Εγγραφή: 02 Δεκ 2008 12:10

Το site μου δεν δουλευει

Δημοσίευση από nikos89 » 26 Ιούλ 2010 22:14

ok sorry δεν το είδα. :)

Δοκίμασες να απενεργοποιήσεις το firewall του router/windows και να δεις αν είναι εντάξει;

micahelcom
Δημοσιεύσεις: 14
Εγγραφή: 11 Μαρ 2010 20:00

Το site μου δεν δουλευει

Δημοσίευση από micahelcom » 26 Ιούλ 2010 23:35

Ναι εχω κλειστει ολα τα firewall και εχω βαλει και εξερεσεις, δειτε στο localhost ολα πανε οπως πρεπει στην ιπ του η\υ (192.168.1.7) ολα πανε μια χαρα και σε αυτην την ιπ πανε ολα καλα 127.0.0.1 εχω ανοιξει την θυρα 80 απο το ρουτερ την antivirus και το firewall των windows τι στο καλο παει στραβα δεν καταλαβαινω.

Άβαταρ μέλους
hitca
Honorary Member
Δημοσιεύσεις: 1919
Εγγραφή: 13 Ιουν 2010 19:41
Τοποθεσία: Brussels
Επικοινωνία:

Το site μου δεν δουλευει

Δημοσίευση από hitca » 27 Ιούλ 2010 00:01

Αναφέρεις ότι χρησιμοποιείς apache web server.
Σαν τελευταία δοκιμή απεγκατέστησέ το και βάλε το site σε xampp (έχει δικό του apache server). Φύλαξε με backup το site που έχεις έτοιμο και με απλή αντιγραφή το τοποθετείς στον κατάλληλο φάκελλο.

Καλύτερα να ενεργοποιήσεις το firewall των win και αυτό γιατί το πρόγραμμα θα 'εξαναγκάσει' τα win να ξανανοίξουν τίς όποιες port είναι απαραίτητες και το κυριότερο ... θα σε ρωτήσει για επιβεβαίωση.

Το αναφέρω σαν πιθανή λύση γιατί είπες και εσύ ότι αυτό θα βάλεις σαν τελικό πρόγραμμα. Καλύτερα να το κάνεις άμεσα... κατά τα άλλα ισχύουν ότι έχει γραφεί έως τώρα.

micahelcom
Δημοσιεύσεις: 14
Εγγραφή: 11 Μαρ 2010 20:00

Το site μου δεν δουλευει

Δημοσίευση από micahelcom » 27 Ιούλ 2010 01:03

οκ σε λιγη ωρα θα το εχω τελιωσει.

Απάντηση

Επιστροφή στο “Internet Help”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 3 επισκέπτες