Πρόβλημα με κωδικοσελίδα !

Ερωτήσεις και απαντήσεις σχετικές με την HTML, XHTML και την κατασκευή σελίδων για το Web.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
johntrk
Δημοσιεύσεις: 31
Εγγραφή: 22 Αύγ 2010 14:59

Πρόβλημα με κωδικοσελίδα !

Δημοσίευση από johntrk » 29 Αύγ 2010 13:47

Γειά σας. Έχω μια ιστοσελίδα σε UTF8 η οποία στον iexplorer δείχνει μια χαρά ενώ στον chrome ελληνικά πουθενά. Δεν μπορώ να την κάνω ISO-8859-7 γίατί μετά έχω πρόβλημα με την Sql database.

Καμιά ιδέα?

Ευχαριστώ

Άβαταρ μέλους
korgr
Honorary Member
Δημοσιεύσεις: 5067
Εγγραφή: 07 Οκτ 2008 18:30
Τοποθεσία: Corinth
Επικοινωνία:

Πρόβλημα με κωδικοσελίδα !

Δημοσίευση από korgr » 29 Αύγ 2010 15:56

link?


Άβαταρ μέλους
korgr
Honorary Member
Δημοσιεύσεις: 5067
Εγγραφή: 07 Οκτ 2008 18:30
Τοποθεσία: Corinth
Επικοινωνία:

Πρόβλημα με κωδικοσελίδα !

Δημοσίευση από korgr » 29 Αύγ 2010 20:43

Στον ΙΕ σου δειχνει κανονικα γιατι την ερμηνευει ως non-unicode (windows-1253 για την ακριβεια μου δειχνει).
Διορθωσε το charset=UTF8 σε charset=utf-8
Οταν το κανεις αυτο θα δουλευει παντου με το σωστο encoding της βασης σου, αλλα τα ελληνικα που εχεις στα php αρχεια σου (εκτος βασης) θα φαινονται "κινεζικα".
Για να διορθωθει αυτο θα πρεπει να σωθουν αυτα τα php με utf-8 (δεν αρκει να το αναφερεις στην html). Μπορεις να το κανεις αυτο περνώντας τα php files σου απο εναν editor οπως το notepad2 ή το notepad++

johntrk
Δημοσιεύσεις: 31
Εγγραφή: 22 Αύγ 2010 14:59

Πρόβλημα με κωδικοσελίδα !

Δημοσίευση από johntrk » 29 Αύγ 2010 20:54

Δεν καταλαβαίνω τι εννοείς... Αν αλλάξω το UTF8 se UTF-8 τότε ο iexplorer μου τα δείχνει όλα κινέζικα. Ρίξε μια ματιά στην php.
Συνημμένα
index.zip
(2.17 KiB) Μεταφορτώθηκε 159 φορές

Άβαταρ μέλους
korgr
Honorary Member
Δημοσιεύσεις: 5067
Εγγραφή: 07 Οκτ 2008 18:30
Τοποθεσία: Corinth
Επικοινωνία:

Πρόβλημα με κωδικοσελίδα !

Δημοσίευση από korgr » 29 Αύγ 2010 22:44

Εμ αυτο που δεν καταλαβαινεις ειναι το προβλημα δυστυχως
Δοκιμασε αυτο το αρχειο που διορθωσα και πες μου αν σου δουλευει
Συνημμένα
index.zip
(2.31 KiB) Μεταφορτώθηκε 174 φορές

Άβαταρ μέλους
korgr
Honorary Member
Δημοσιεύσεις: 5067
Εγγραφή: 07 Οκτ 2008 18:30
Τοποθεσία: Corinth
Επικοινωνία:

Πρόβλημα με κωδικοσελίδα !

Δημοσίευση από korgr » 29 Αύγ 2010 22:45

και εν πασει περιπτωσει, αυτο το διαβασες?
Οταν το κανεις αυτο θα δουλευει παντου με το σωστο encoding της βασης σου, αλλα τα ελληνικα που εχεις στα php αρχεια σου (εκτος βασης) θα φαινονται "κινεζικα".
Για να διορθωθει αυτο θα πρεπει να σωθουν αυτα τα php με utf-8 (δεν αρκει να το αναφερεις στην html). Μπορεις να το κανεις αυτο περνώντας τα php files σου απο εναν editor οπως το notepad2 ή το notepad++

Άβαταρ μέλους
MegasmorF
Honorary Member
Δημοσιεύσεις: 1154
Εγγραφή: 07 Απρ 2005 20:05
Τοποθεσία: ./Root
Επικοινωνία:

Πρόβλημα με κωδικοσελίδα !

Δημοσίευση από MegasmorF » 29 Αύγ 2010 22:59

korgr έγραψε:και εν πασει περιπτωσει, αυτο το διαβασες?
Οταν το κανεις αυτο θα δουλευει παντου με το σωστο encoding της βασης σου, αλλα τα ελληνικα που εχεις στα php αρχεια σου (εκτος βασης) θα φαινονται "κινεζικα".
Για να διορθωθει αυτο θα πρεπει να σωθουν αυτα τα php με utf-8 (δεν αρκει να το αναφερεις στην html). Μπορεις να το κανεις αυτο περνώντας τα php files σου απο εναν editor οπως το notepad2 ή το notepad++

ΟΕΟΟΟΟ??????????

ΑΧ ρε korgr τόσα χρόνια στο FS ti erotiseis einai aytes pou kaneis... ts ts ts
Πες μου τη λέξη σ αγαπώ σε σένα να πιστέψω...και γω μια ολοκληρη ζωή μπορώ να καταστρεψω...

johntrk
Δημοσιεύσεις: 31
Εγγραφή: 22 Αύγ 2010 14:59

Πρόβλημα με κωδικοσελίδα !

Δημοσίευση από johntrk » 30 Αύγ 2010 03:27

Ναί αυτό δουλεύει όπως είπες και αν κατάλαβα καλά πρέπει να ξαναπεράσω τα δεδομένα στην database απο φόρμα με encoding utf-8. Έχει διαφορά αν γράψω UTF-8 αντί utf-8 στο encoding της φόρμας?

Ρίξε μια ματιά στον τρόπο που προσθέτω πεδία στην βάση.

Ευχαριστώ.
Συνημμένα
newjob.zip
(498 Ψηφιολέξεις) Μεταφορτώθηκε 279 φορές

Άβαταρ μέλους
korgr
Honorary Member
Δημοσιεύσεις: 5067
Εγγραφή: 07 Οκτ 2008 18:30
Τοποθεσία: Corinth
Επικοινωνία:

Πρόβλημα με κωδικοσελίδα !

Δημοσίευση από korgr » 30 Αύγ 2010 08:17

Τα δεδομενα σου μια χαρα τα σωζεις στη βαση σου!
Το προβλημα σου ειναι πως τα php αρχεια σου ειναι σωσμενα ως ANSI encoding και πρεπει να σωθουν (file->save as από κάποιον text editor που να υποστηριζει ορισμο του encoding σε utf-8 ) και να ξαναγινουν upload στον server σου.

Κατεβασε το Notepad2 και ανοιξε σε αυτο ενα απο τα προβληματικα σου php αρχεια (αυτα που δειχνουν κινεζικα οταν οριζεις στην html το encoding σε utf-8 )
Αφου ανοιξεις το αρχειο, κάνε τα ακόλουθα:
  • Αλλαξε το

    Κώδικας: Επιλογή όλων

    <meta http-equiv="content-type" content="text/html; charset=UTF8">
    σε

    Κώδικας: Επιλογή όλων

    <meta http-equiv="content-type" content="text/html; charset=utf-8">
    Πηγαινε στα μενου του notepad2, βρες το File->Encoding->ANSI, και αλλαξε το σε File->Encoding->UTF-8

    Αποθηκευσε ξανα το αρχειο σου.
Θα δεις πως οπως με αυτο που σου εστειλα, θα δουλευει μια χαρα με τα ελληνικα σε ολους τους browsers

johntrk
Δημοσιεύσεις: 31
Εγγραφή: 22 Αύγ 2010 14:59

Πρόβλημα με κωδικοσελίδα !

Δημοσίευση από johntrk » 30 Αύγ 2010 12:00

Ναι αυτό έκανα με όλα τα αρχεία και τα ξανα ανέβασα. Αλλά πάλι με τα ελληνικά στην βάση έχω πρόβλημα. Δες http://server.softgr.com/resume στην λίστα των θέσεων.

Άβαταρ μέλους
korgr
Honorary Member
Δημοσιεύσεις: 5067
Εγγραφή: 07 Οκτ 2008 18:30
Τοποθεσία: Corinth
Επικοινωνία:

Πρόβλημα με κωδικοσελίδα !

Δημοσίευση από korgr » 30 Αύγ 2010 12:53

Εγω τα βλεπω μια χαρα τα ελληνικα.
Που ειναι το προβλημα?

[edit]
sorry τωρα ειδα οτι το προβλημα ειναι στις λιστες
Αυτο σημαινει πως στη βαση σου δεν ειναι καταχωρημενες ως utf-8 οι εγγραφες
Δες και αυτο: http://www.freestuff.gr/forums/viewtopi ... es&t=51575

johntrk
Δημοσιεύσεις: 31
Εγγραφή: 22 Αύγ 2010 14:59

Πρόβλημα με κωδικοσελίδα !

Δημοσίευση από johntrk » 30 Αύγ 2010 14:41

Άλλαξα την βάση σε utf_unicode_ci.

Έκανα τις αλλαγές σύμφωνα με ότι κατάλαβα και ότι βρήκα στο google και το αποτέλεσμα είναι το ίδιο ( σχεδόν ).

Τα ελληνικά στα κείμενα όλα οκ. Η καταχώρηση πεδίων στην βάση πάλι δεν δουλεύει !!!

Αν κάνω import τότε όλα καλα δες "Υπάλληλος Γραφείου" άρα το πρόβλημα είναι στο newjob.php στην καταχώρηση. Πώς επιλέγω το charset που θα καταχωρήσω ?

Ευχαριστώ.
Συνημμένα
ResumeRoot.zip
(1.75 KiB) Μεταφορτώθηκε 284 φορές

Άβαταρ μέλους
korgr
Honorary Member
Δημοσιεύσεις: 5067
Εγγραφή: 07 Οκτ 2008 18:30
Τοποθεσία: Corinth
Επικοινωνία:

Πρόβλημα με κωδικοσελίδα !

Δημοσίευση από korgr » 30 Αύγ 2010 20:53

Στην φορμα που εχεις online, εχεις:

Κώδικας: Επιλογή όλων

<meta http-equiv="content-type" content="text/html; charset=ISO-8859-7">
αντι για

Κώδικας: Επιλογή όλων

<meta http-equiv="content-type" content="text/html; charset=utf-8">
με αποτελεσμα να μην στελνει utf-8 δεδομενα προς την Mysql

Σωσε τα ολα utf-8 και ορισε και στα <meta> utf-8 λεμε (μαλιασε η γλωσσα μου lol)

Apostolis_38
Δημοσιεύσεις: 1969
Εγγραφή: 14 Φεβ 2008 16:20
Τοποθεσία: ΠΕΙΡΑΙΑΣ

Πρόβλημα με κωδικοσελίδα !

Δημοσίευση από Apostolis_38 » 30 Αύγ 2010 22:13

Αρχισε να χρεώνεις
Η θα το πιάνουν όλοι αμέσως ή θα τα κονομήσεις :D

Απάντηση

Επιστροφή στο “HTML και XHTML”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης