Προβλημα με apache server

Τεχνικές και μόνο Συζητήσεις για WEB hosting servers, Mail servers, DNS servers. Όχι αναζήτηση υπηρεσιών εδώ!

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Άβαταρ μέλους
AlexGraphicD
Δημοσιεύσεις: 82
Εγγραφή: 23 Απρ 2010 20:14
Τοποθεσία: Αττική
Επικοινωνία:

Προβλημα με apache server

Δημοσίευση από AlexGraphicD » 20 Σεπ 2010 18:48

Στο error log του xampp εγραφε αυτο.


Can't open nul: No such file or directory
perl_parse: No such file or directory
"Οι άνθρωποι στην ουσία δεν έχουν ανάγκη να αποκτήσουν χρήματα. Αυτό που χρειάζονται πραγματικά είναι η ελεύθερη πρόσβαση σε αγαθά και υπηρεσίες χωρίς τη χρήση κάποιου μέσου ανταλλαγής, χρέους."
http://thepangea.org, http://.thevenusproject.com, http://zeitgeistmovie.com/
Εικόνα

Άβαταρ μέλους
burnmind
Script Master
Δημοσιεύσεις: 954
Εγγραφή: 26 Σεπ 2009 02:14
Τοποθεσία: UK
Επικοινωνία:

Προβλημα με apache server

Δημοσίευση από burnmind » 20 Σεπ 2010 18:54

AlexGraphicD έγραψε:Ετρεξα το setup.bat και στο τελος εβγαλε αυτο.

Και μετα ανοιγω το control panel και ακομα δεν λειουργει ο apache. To error log που ειναι στο

xampp?
Το error log του apache είναι στο:

xampp\apache\logs\error.log

Μετά το setup_xampp.bat (υποθέτω πως αυτό εννοείς με το setup.bat), έτρεξες το xampp_start.exe; Αν ναι, σου έβγαλε κάποιο error; (Τρέξτο από cmd ώστε να προλάβεις να διαβάσεις τι γράφει)

Άβαταρ μέλους
AlexGraphicD
Δημοσιεύσεις: 82
Εγγραφή: 23 Απρ 2010 20:14
Τοποθεσία: Αττική
Επικοινωνία:

Προβλημα με apache server

Δημοσίευση από AlexGraphicD » 20 Σεπ 2010 19:01

Ναι αυτο εννοω. το πατησα και γραφει για λιγο "Starting xampp.."

και μετα χανεται.
Τελευταία επεξεργασία από το μέλος AlexGraphicD την 20 Σεπ 2010 19:06, έχει επεξεργασθεί 1 φορά συνολικά.

nbc
Honorary Member
Δημοσιεύσεις: 526
Εγγραφή: 05 Σεπ 2009 20:12
Επικοινωνία:

Προβλημα με apache server

Δημοσίευση από nbc » 20 Σεπ 2010 19:05

Μπας και έχεις την FLP έκδοση των Windows, ή κόλλησες/καθάρισες κάποιον υιό προσφάτως;

Το μήνυμα "Can't open nul" υποδηλώνει την απουσία του NUL device driver. Αυτός απαιτείται για να τρέξει ο Apache. Αν θυμάμαι καλά, η FLP έκδοση δεν τον περιλαμβάνει.

Άβαταρ μέλους
AlexGraphicD
Δημοσιεύσεις: 82
Εγγραφή: 23 Απρ 2010 20:14
Τοποθεσία: Αττική
Επικοινωνία:

Προβλημα με apache server

Δημοσίευση από AlexGraphicD » 20 Σεπ 2010 19:10

Ειχα κανει ελεγχο πριν κανα μηνα και εβαλα σε κανα 2 ιους σε καραντινα.

To ειδα και το nul αρχειο. Το εχω στα windows εκτος κ αν εχει

κολλησει καναν ιο. Μπορεις να μου το στειλεις εσυ αν εχεις xp? Το xampp shell τι ειναι? πρεπει

να γραψω κατι εκει? Γιατι οταν το ανοιγω γραφει "setting the enviroment for using XAMPP for

windows και περιμενει να γραψω.
Τελευταία επεξεργασία από το μέλος AlexGraphicD την 20 Σεπ 2010 19:15, έχει επεξεργασθεί 1 φορά συνολικά.

nbc
Honorary Member
Δημοσιεύσεις: 526
Εγγραφή: 05 Σεπ 2009 20:12
Επικοινωνία:

Προβλημα με apache server

Δημοσίευση από nbc » 20 Σεπ 2010 19:14

Δώσε σε command prompt

Κώδικας: Επιλογή όλων

type nul
Αν σου πει "The system cannot find the file specified" τότε δεν είναι εγκατεστημένος (null.sys). Αν είναι, τότε δεν πρέπει να συμβεί τίποτα.

Άβαταρ μέλους
AlexGraphicD
Δημοσιεύσεις: 82
Εγγραφή: 23 Απρ 2010 20:14
Τοποθεσία: Αττική
Επικοινωνία:

Προβλημα με apache server

Δημοσίευση από AlexGraphicD » 20 Σεπ 2010 19:17

Δεν το βρισκει. Παραξενο στο system32 δειχνει οτι υπαρχει.

Μπορει να μου το στειλει καποιος?

Στο xampp_shell.bat δεν πρεπει να γραψω τιποτα?

Apostolis_38
Δημοσιεύσεις: 1969
Εγγραφή: 14 Φεβ 2008 16:20
Τοποθεσία: ΠΕΙΡΑΙΑΣ

Προβλημα με apache server

Δημοσίευση από Apostolis_38 » 20 Σεπ 2010 21:22

Αν επιτρέπεις.
screw wamp-xamp-famp

Αν έχεις όρεξη κάνε απεγκατάσταση αυτές τις ιστορίες, κατέβασε apache-mysql-php και εγκατέστησε τα.
Μια μικρή προσοχή θέλει στην εγκατάσταση της mysql, δύο τρεις γραμμές στο httpd.conf και είσαι ok.
Θα μάθεις και πως δουλεύει το όλο σύστημα πολύ καλύτερα.

Άβαταρ μέλους
Cha0s
SysAdmin
Δημοσιεύσεις: 10242
Εγγραφή: 28 Ιούλ 2001 03:00

Προβλημα με apache server

Δημοσίευση από Cha0s » 21 Σεπ 2010 10:21

Apostolis_38 έγραψε:Αν επιτρέπεις.
screw wamp-xamp-famp

Αν έχεις όρεξη κάνε απεγκατάσταση αυτές τις ιστορίες, κατέβασε apache-mysql-php και εγκατέστησε τα.
Μια μικρή προσοχή θέλει στην εγκατάσταση της mysql, δύο τρεις γραμμές στο httpd.conf και είσαι ok.
Θα μάθεις και πως δουλεύει το όλο σύστημα πολύ καλύτερα.
+++

Δεν είναι κακό να μάθεις και πως στήνονται :wink:

Συν ότι αυτά τα έτοιμα xamp lamp gav το καθένα στήνει τον apache/php με τον δικό του τρόπο.

Προσωπικά έχω να τρέξω apache/php/mysql σε windows χρόνια οπότε αυτά τα NUL κλπ δεν έχω ιδέα τι είναι. Τουλάχιστον όταν δούλευα σε windows δεν υπήρχε τέτοιο πράγμα :kaloe:


Αν δεν την παλεύεις με τίποτα να στήσεις μόνος σου apache/mysql/php πέρνα το Appserv.
Απόσα είχα δοκιμάσει επί windows εποχές ήταν το πιο εύκολο στο στήσιμο και παίζανε εγγυημένα όλα out of the box. Δεν ξέρω αν το έχουν χαλάσει μέχρι σήμερα αλλά give it a try ;)

nbc
Honorary Member
Δημοσιεύσεις: 526
Εγγραφή: 05 Σεπ 2009 20:12
Επικοινωνία:

Προβλημα με apache server

Δημοσίευση από nbc » 21 Σεπ 2010 11:29

Και στο Linux υπάρχει null device (/dev/null). To ίδιο και στο Mac. Βασικά, δεν γνωρίζω OS χωρίς null device.

Ότι και να στήσει το παλικάρι, όπου και να το στήσει, αν δεν υπάρχει αυτό το device ο Apache δεν πρόκειται να λειτουργήσει. Και δεν πρόκειται περί ιδιοτροπίας του. Όλες οι console applications, που κάνουν spawn, fork και τα συναφή το χρησιμοποιούν όποτε θέλουν να "καταπιούν" το output και τους ενδιαφέρει μόνο το αποτέλεσμα.

Στην περίπτωσή μας, ο Αpache προσπαθεί να τρέξει ένα child process και κάνει redirect την έξοδο (stdout) στο null device. Από τη στιγμή που δεν υπάρχει, τα Windows επιστρέφουν error #2 (file not found...). Ο Apache μπλοκάρει και σταματά.

Άβαταρ μέλους
Cha0s
SysAdmin
Δημοσιεύσεις: 10242
Εγγραφή: 28 Ιούλ 2001 03:00

Προβλημα με apache server

Δημοσίευση από Cha0s » 21 Σεπ 2010 11:44

Μάλιστα.

Δεν ήξερα ότι το NUL είναι το γνωστό null. (όχι ότι μπήκα στον κόπο να το ψάξω κιόλας...)

Anyway, δεν έχω συναντήσει ποτέ τέτοιο πρόβλημα. Και χαίρομαι που δεν χρειάστηκε να ανακαλύπτω εξαρχής τυπικές ορολογίες με την ηλίθια λογική των windows να ονομάζουν στάνταρ πράγματα όπως τους κατέβει :lol:

nbc
Honorary Member
Δημοσιεύσεις: 526
Εγγραφή: 05 Σεπ 2009 20:12
Επικοινωνία:

Προβλημα με apache server

Δημοσίευση από nbc » 21 Σεπ 2010 11:48

Δεν έχεις άδικο σε αυτό... :)

Η εξήγηση, βέβαια, είαι οι legacy 3 χαρακτήρες στο device name (CON, PRN, LPT, COM, ...)

Απάντηση

Επιστροφή στο “Apache, IIS, DNS Servers”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες