προβλημα με hidden type πεδιο για φορμα εγγραφης

Ερωτήσεις και απαντήσεις σχετικές με την HTML, XHTML και την κατασκευή σελίδων για το Web.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
phpdafni
Δημοσιεύσεις: 12
Εγγραφή: 05 Μάιος 2009 06:55

προβλημα με hidden type πεδιο για φορμα εγγραφης

Δημοσίευση από phpdafni » 05 Οκτ 2010 13:32

Κώδικας: Επιλογή όλων

if ($_POST['form_submitted'] == '1') { echo "επιτυχης εγγραφη";} ;
μεσα σε <?php ?> το έχω

τι πρόβλημα έχει ;

μου εμφανίζει το εξης :

Parse error: syntax error, unexpected T_IF, expecting ',' or ';' in .....page.php on line 513

Άβαταρ μέλους
korgr
Honorary Member
Δημοσιεύσεις: 5067
Εγγραφή: 07 Οκτ 2008 18:30
Τοποθεσία: Corinth
Επικοινωνία:

προβλημα με hidden type πεδιο για φορμα εγγραφης

Δημοσίευση από korgr » 05 Οκτ 2010 14:27

Κώδικας: Επιλογή όλων

if&#40;$_POST&#91;'form_submitted'&#93; == '1'&#41;  echo "επιτυχης εγγραφη";

Άβαταρ μέλους
dva_dev
Script Master
Δημοσιεύσεις: 3790
Εγγραφή: 16 Σεπ 2005 01:32
Επικοινωνία:

προβλημα με hidden type πεδιο για φορμα εγγραφης

Δημοσίευση από dva_dev » 05 Οκτ 2010 21:56

Ετσι παίζει;

Κώδικας: Επιλογή όλων

; if &#40;$_POST&#91;'form_submitted'&#93; == '1'&#41; &#123; echo "επιτυχης εγγραφη";&#125;

Άβαταρ μέλους
Banavas
Script Master
Δημοσιεύσεις: 1367
Εγγραφή: 21 Νοέμ 2004 20:25
Επικοινωνία:

προβλημα με hidden type πεδιο για φορμα εγγραφης

Δημοσίευση από Banavas » 06 Οκτ 2010 09:34

Λογικά λείπει το ; από την προηγούμενη σειρά...

Edit: αυτό που λέει και ο dva_dev. Τώρα παρατήρησα οτι το έβαλες πριν το if
Happy coding....
Μάρκος
http://lasernet.gr

Απάντηση

Επιστροφή στο “HTML και XHTML”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες