Πρόβλημα με VS όταν τρέχω το setup σε άλλα pc

Συζητήσεις για τις γλώσσες του dot Net και για του Visual Studio της Microsoft

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Mercizizou
Δημοσιεύσεις: 2
Εγγραφή: 07 Δεκ 2010 17:27
Τοποθεσία: GR

Πρόβλημα με VS όταν τρέχω το setup σε άλλα pc

Δημοσίευση από Mercizizou » 07 Δεκ 2010 17:44

Καλησπέρα,

Έχω φτιάξει ένα πρόγραμμα σε Visual Studio 2008 στο λειτουργικό μου Wndows Xp SP3. Το πρόγραμμα αυτό περιέχει κάποια images αρχεία σε picturebox. Το πρόβλημα μου είναι όταν κάνω publish το πρόγραμμα και το τρέχω σε άλλα pc με Vista λειτουργικό π.χ. μου γράφει error η συγκεκριμένη εικόνα δε βρέθηκε στην τάδε τοποθεσία(και σε λειτουργικό xp να το τρέξω λογικά το ίδιο θα μου βγάλει αν και δε το έχω δοκιμάσει), το πρόγραμμα συνεχίζει να τρέχει κανονικά αν πατήσω συνέχεια απλά όταν είναι να εμφανίσει κάποια άλλη εικόνα πάλι τα ίδια. Αν πατήσω στις λεπτομέρειες μου λέει κάτι για το JIT και τις εξαιρέσεις.

Ευχαριστώ.
Συνημμένα
error.jpg

Άβαταρ μέλους
_tasos
Δημοσιεύσεις: 116
Εγγραφή: 03 Μάιος 2007 15:06
Επικοινωνία:

Πρόβλημα με VS όταν τρέχω το setup σε άλλα pc

Δημοσίευση από _tasos » 07 Δεκ 2010 20:54

Κοιτώντας τις λεπτομέρειες βλέπω ότι είχες ένα exception System.IO.FileNotFoundException και μετά υπάρχει ένα path. Το path αυτό είναι μία εικόνα που χρησιμοποιεί το πρόγραμμα σου (προφανώς). Στα Vista που έτρεξες το πρόγραμμα σου υπάρχει αυτό το αρχείο στο path που γράφει;

Το ρωτάω γιατί είναι το path που είχες και το project και λογικά δεν υπάρχει στο άλλο μηχάνημα που τρέχεις την εφαρμογή.

athlon
Δημοσιεύσεις: 30
Εγγραφή: 02 Οκτ 2008 01:53
Τοποθεσία: pola kai diafora........

Πρόβλημα με VS όταν τρέχω το setup σε άλλα pc

Δημοσίευση από athlon » 09 Δεκ 2010 11:14

Den exeis prostesi tis ikones ston pc pou to trexis to programa anikse ton fakelo tou rgousou kai kita sto (Resources) an iparxoun h oikones

Mercizizou
Δημοσιεύσεις: 2
Εγγραφή: 07 Δεκ 2010 17:27
Τοποθεσία: GR

Πρόβλημα με VS όταν τρέχω το setup σε άλλα pc

Δημοσίευση από Mercizizou » 10 Δεκ 2010 22:39

Τα είχα δοκιμάσει όλα παιδιά και αναγκάστηκα να το κάνω με άλλο τρόπο. Ευχαριστώ για τις απαντήσεις. Το path και όλα ήταν σωστά τοποθετημένα.

Απάντηση

Επιστροφή στο “dot Net και Visual Studio”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης