Πρόβλημα με bots σε φόρμα με "post" χωρίς captcha

Τεχνικές και μόνο Συζητήσεις για WEB hosting servers, Mail servers, DNS servers. Όχι αναζήτηση υπηρεσιών εδώ!

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Άβαταρ μέλους
fAzer
Δημοσιεύσεις: 361
Εγγραφή: 15 Νοέμ 2009 16:29

Πρόβλημα με bots σε φόρμα με "post" χωρίς captcha

Δημοσίευση από fAzer » 03 Μαρ 2011 15:23

Γεία σας,

ελπίζω να έχω τοποθετίσει το post στη σωστή κατηγορία..
Έχω ένα site με form και post χωρίς captcha. Με έχουν ταράξει με αυτόματα post (δε μπορώ να καταλάβω πως το κάνουν) και ενώ έχω ένα javascript που απάγορεύει τα <a kai /> παρ'ολ'αυτά κάνουν το post κανονικά!
Το site είναι το l5i5k5e5s.gr χωρίς τον αριθμό ανάμεσα και πρίν 1 μήνα είχε ανέβει κατακόρυφα 5.000 - 15.000 επισκέψεις/ μέρα. Όταν άρχισαν να μου το χαλάνε με τα αυτόματα post νευρίασα και το άλλαξα και έβαλα και captcha. Η πτώση ήταν απίστευτη. Για την ακρίβεια πάτωσε!
Οπότε θέλω να το δουλεύω χωρίς captcha και θα ήθελα να μου πείτε μία λύση, αν μπορείτε να με βοηθήσετε..
Το πιό λογικό και γρήγορα ήταν να κάνω στο .htaccess αυτό:

Κώδικας: Επιλογή όλων

order allow,deny
allow from .gr
allow from .cy
καθώς αυτοί που δημιουργούσαν το πρόβλημα δεν παίρνανε ip ούτε από Ελλάδα ούτε απο Κύπρο.
Είναι σωστή μία τέτοια λύση;
Το googlebot μπορεί να διαβάσει το περιεχόμενο;
Μπορώ να βάλω adsense;
Στο access_log βλέπω κάθε 10-30 δευτερόλεπτα:

115.160.178.253 - - [03/Mar/2011:14:02:10 +0200] "POST /index.php HTTP/1.1" 403 463 "http://likes.gr/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)"
stc.29.157.103.87.dsl.krasnet.ru - - [03/Mar/2011:14:02:20 +0200] "POST /index.php HTTP/1.1" 403 463 "http://likes.gr/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)"
62.215.5.69 - - [03/Mar/2011:14:02:24 +0200] "POST /index.php HTTP/1.1" 403 463 "http://likes.gr/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)"
114-47-203-86.dynamic.hinet.net - - [03/Mar/2011:14:02:42 +0200] "POST /index.php HTTP/1.1" 403 467 "http://www.likes.gr/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)"
200.35.177.233 - - [03/Mar/2011:14:02:44 +0200] "POST /index.php HTTP/1.1" 403 467 "http://www.likes.gr/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)"
115.160.178.253 - - [03/Mar/2011:14:02:45 +0200] "POST /index.php HTTP/1.1" 403 467 "http://www.likes.gr/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)"
91.195.183.215 - - [03/Mar/2011:14:02:48 +0200] "POST /index.php HTTP/1.0" 403 467 "http://www.likes.gr/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)"

Αυτά επιβαρύνουν τον server;

Ευχαριστώ
:)

Απάντηση

Επιστροφή στο “Apache, IIS, DNS Servers”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης