javascript debugging σε joomla/virtuemart

Κώδικας, πληροφορίες, ερωτήσεις και απαντήσεις σχετικές με την JavaScript.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Άβαταρ μέλους
Mandingueiro
Δημοσιεύσεις: 270
Εγγραφή: 07 Φεβ 2006 19:26

javascript debugging σε joomla/virtuemart

Δημοσίευση από Mandingueiro » 07 Απρ 2011 21:45

Χαιρετώ άπαντες.

Καθότι είμαι άσχετος με Js είπα να καταφύγω στη βοήθειά σας. Τόσο καιρό ψάχνω και δε μπορώ να βρω τη λύση.

Στο page αυτό για παράδειγμα: http://goo.gl/6lQCV όλα λειτουργούν κανονικά (τουλάχιστον έτσι φαίνεται στον χρήστη) σε όλους τους Broswers εκτός του ΙΕ8!

Μιλάω για την μεγένθυση της κύριας εικόνας. Αν κάνετε κλικ πάνω της θα δείτε ότι δεν γίνεται τίποτα αλλά πετάει error (στον ΙΕ8 μόνο, υπενθυμίζω ότι δουλεύει κανονικά σε Chrome,ff,netscape,IE9):
Message: Object doesn't support this property or method
Line: 8
Char: 186
Code: 0
URI: http://www.e-bath.net/media/system/js/mootools.js


Message: Object doesn't support this property or method
Line: 59
Char: 102
Code: 0
URI: http://www.e-bath.net/media/system/js/mootools.js


Message: Object doesn't support this property or method
Line: 13
Char: 91
Code: 0
URI: http://www.e-bath.net/media/system/js/mootools.js


Message: 'closeButton' is null or not an object
Line: 21
Char: 63
Code: 0
URI: http://www.e-bath.net/media/system/js/mootools.js


Message: 'closeButton' is null or not an object
Line: 21
Char: 63
Code: 0
URI: http://www.e-bath.net/media/system/js/mootools.js
Πολύ πιθανό θα μου πείτε να βγάζει κάποιο error καθώς στο page αυτό φορτώνονται ένα σωρό libraries (mootools,jquery κ.α.) απο το template αρχικά, από το virtuemart αλλά και απο το template του virtuemart το οποίο και έχω αγοράσει.

Από τα παραπάνω errors το τελευταίο είναι αυτό που μ'ενδιαφέρει, γιατί αυτό πετάγεται όταν κάνεις κλικ στην εικόνα για να μεγενθύνει.

Τώρα αν παίξω με τα settings του Joomla, συγκεκριμένα με το RokBox plugin και το vm template τότε μπορεί να λειτουργήσει η μεγένθυση σε IE8 αλλά μετά χαλάνε οι μεγενθύσεις των δευτερεύοντων εικόνων (ανοίγουν ή χωρίς AJAX σε νέο παράθυρο ή πετάει ένα παράθυρο με λάθος link).

Οπότε νομίζω με τις ρυθμίσεις που έχω τώρα πρέπει να το ψάξω το πρόβλημα.

Έχει κανείς κάποια ιδέα απο που ν'αρχίσω ή προς τα πού να κατεθυνθώ;

Απάντηση

Επιστροφή στο “JavaScript και Frameworks”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες