Περίεργα πράγματα με εισαγωγή εικόνας

Ερωτήσεις και απαντήσεις σχετικές με την HTML, XHTML και την κατασκευή σελίδων για το Web.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
txc
Δημοσιεύσεις: 627
Εγγραφή: 02 Δεκ 2003 23:08

Περίεργα πράγματα με εισαγωγή εικόνας

Δημοσίευση από txc » 20 Σεπ 2011 18:57

Καλησπέρα παιδιά,
έχω φτιάξει ενα website στο οποίο η δεξιά στήλη έχει κάποιες στατικές φώτο
Με τον πολύ απλό κώδικα

Κώδικας: Επιλογή όλων

<img border="0" src="banners/1.jpg" alt="Pulpit rock" width="304" height="228" />
περνάω κατα σειρά τις εικόνες.
Το κορυφαίο , όταν κάνω προεπισκόπηση στο Dreamweaver 10 από τις 12 φώτο δεν εμφανίζονται.
Όταν ανοίγω το website σε explorer, mozilla κλπ εμφανίζονται κανονικά.

Κανά δυο πελάτες μου λένε ότι οι ίδιες φώτο δεν εμφανίζονται στο browser τους, άλλοι μου λένε ότι εμφανίζονται κανονικά, καμιά εξήγηση για αυτό το πράγμα?

Υ.Γ. Πρώτη φορά συναντώ κάτι τέτοιο για τόσο απλό κώδικα.

Άβαταρ μέλους
korgr
Honorary Member
Δημοσιεύσεις: 5067
Εγγραφή: 07 Οκτ 2008 18:30
Τοποθεσία: Corinth
Επικοινωνία:

Περίεργα πράγματα με εισαγωγή εικόνας

Δημοσίευση από korgr » 20 Σεπ 2011 19:37

Κάνε τις export ως jpg και από κάποιο άλλο πρόγραμμα. Κάτι στους headers κάποιων εικόνων θα είναι προβληματικό και μερικές φορές σε συγκεκριμένα περιβάλλοντα δημιουργεί πρόβλημα. Μου έχει τύχει και μένα...

txc
Δημοσιεύσεις: 627
Εγγραφή: 02 Δεκ 2003 23:08

Περίεργα πράγματα με εισαγωγή εικόνας

Δημοσίευση από txc » 20 Σεπ 2011 19:59

έκανα save as σε μορφή .png και είναι οκ τώρα
Περίεργα πράγματα, το κακό είναι ότι έχω πάρα πολλές δυναμικές φώτο
είδωμεν

ευχαριστώ

txc
Δημοσιεύσεις: 627
Εγγραφή: 02 Δεκ 2003 23:08

Περίεργα πράγματα με εισαγωγή εικόνας

Δημοσίευση από txc » 21 Σεπ 2011 13:14

λες να υπάρχει καμιά εντολή να "προσπερνάει" τα λάθη της εικόνας και να την εμφανίζει?
γιατί το πρόβλημα εμφανίζεται τώρα μόνο στον Explorer ενώ σε firefox Παίζει οκ

Άβαταρ μέλους
korgr
Honorary Member
Δημοσιεύσεις: 5067
Εγγραφή: 07 Οκτ 2008 18:30
Τοποθεσία: Corinth
Επικοινωνία:

Περίεργα πράγματα με εισαγωγή εικόνας

Δημοσίευση από korgr » 21 Σεπ 2011 13:24

nope 8)

Είναι στην κρίση του Browser και πόσο διατεθιμένος είναι να τα προσπερνάει τα bad image headers

Απάντηση

Επιστροφή στο “HTML και XHTML”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες