προβλημα με ελληνικα σε σιτε

Σε αυτή την περιοχή μπορείτε να βρείτε ή να αναζητήσετε πληροφορίες σχετικές με την PHP

Συντονιστές: WebDev Moderators, Super-Moderators, PHP Moderators

Απάντηση
miltiadisf
Δημοσιεύσεις: 43
Εγγραφή: 28 Ιουν 2010 13:51

προβλημα με ελληνικα σε σιτε

Δημοσίευση από miltiadisf » 08 Νοέμ 2011 13:42

εχω φτιαξει ενα απλο σιτε αλλα δεν μοθ εμφανιζει σωστα τα ελληνικα
σε αλλα σημεια τα εμφανιζει ακαταλαβηστικα και σε αλλα ????????? ετσι.

και δεν μιλαω μονο για αυτα που τραβαω απο την βαση αλλα λαι οτι γραψω απευθειασ στο script .

εχω βαλει την βασει κα τουσ πινακεσ σε utf-8 και εχω γραψει και στο head του script :

<meta http-equiv="content-type" contenet="text/html; charset=utf-8" />
<meta http-equiv="Content-Type" content="text/html; " />

εχω και ενα script σε css πρεπει να βαλω και εκει κατι μηπως???

please help!!!!

Άβαταρ μέλους
Khronos
Δημοσιεύσεις: 754
Εγγραφή: 11 Δεκ 2006 14:43
Τοποθεσία: Ηράκλειο

προβλημα με ελληνικα σε σιτε

Δημοσίευση από Khronos » 08 Νοέμ 2011 13:53

Τσέκαρε οτι και τα αρχεία που χρησιμοποιείς, πχ. index.php είναι σωσμένα σε utf-8.
Επίσης δες και αυτό τον οδηγό.
http://www.freestuff.gr/forums/viewtopic.php?t=52609

Άβαταρ μέλους
stevebat
Script Master
Δημοσιεύσεις: 307
Εγγραφή: 05 Αύγ 2009 15:54
Επικοινωνία:

προβλημα με ελληνικα σε σιτε

Δημοσίευση από stevebat » 08 Νοέμ 2011 14:33

θα μπορούσες να σώσεις τα αρχεία σου πχ το index.php σε urf-8 χωρίς BOM(όπως είπε και ο φίλος Khronos ).
Ένα πρόγραμμα που το κάνει αυτό είναι το notepad++

miltiadisf
Δημοσιεύσεις: 43
Εγγραφή: 28 Ιουν 2010 13:51

προβλημα με ελληνικα σε σιτε

Δημοσίευση από miltiadisf » 08 Νοέμ 2011 17:13

bouzouste έγραψε:θα μπορούσες να σώσεις τα αρχεία σου πχ το index.php σε urf-8 χωρίς BOM(όπως είπε και ο φίλος Khronos ).
Ένα πρόγραμμα που το κάνει αυτό είναι το notepad++
μα το notpad++ χρεισημοποιω και παλι αυτα που τραβαω απο την βαση τα βγαζει οταν εινια ελληνικα τα βγαζει ?????????? γιατι? που να ψαξω για λαθος???

Άβαταρ μέλους
stevebat
Script Master
Δημοσιεύσεις: 307
Εγγραφή: 05 Αύγ 2009 15:54
Επικοινωνία:

προβλημα με ελληνικα σε σιτε

Δημοσίευση από stevebat » 09 Νοέμ 2011 18:05

η βάση σου είναι σε τι characterset είναι;
δώσε και ένα αρχείο να το δούμε λίγο

miltiadisf
Δημοσιεύσεις: 43
Εγγραφή: 28 Ιουν 2010 13:51

προβλημα με ελληνικα σε σιτε

Δημοσίευση από miltiadisf » 13 Νοέμ 2011 18:14

bouzouste έγραψε:η βάση σου είναι σε τι characterset είναι;
δώσε και ένα αρχείο να το δούμε λίγο
επισιναπτο την βαση μου και εδο ειναι το αρχειο συνδεσει με την βαση

<?php

function db_connect() {
$result = new mysqli('localhost', 'root', '', 'my_eshop');
if (!$result) {
throw new Exception('Could not connect to database server');
} else {
return $result;
}
}

function db_result_to_array($result) {
$res_array = array();

for ($count=0; $row = $result->fetch_assoc(); $count++) {
$res_array[$count] = $row;
}

return $res_array;
}

?>
Συνημμένα
127.0.0.1(1).rar
(1.85 KiB) Μεταφορτώθηκε 161 φορές

miltiadisf
Δημοσιεύσεις: 43
Εγγραφή: 28 Ιουν 2010 13:51

προβλημα με ελληνικα σε σιτε

Δημοσίευση από miltiadisf » 13 Νοέμ 2011 18:17

miltiadisf έγραψε:
bouzouste έγραψε:η βάση σου είναι σε τι characterset είναι;
δώσε και ένα αρχείο να το δούμε λίγο
επισιναπτο την βαση μου και εδο ειναι το αρχειο συνδεσει με την βαση

<?php

function db_connect() {
$result = new mysqli('localhost', 'root', '', 'my_eshop');
if (!$result) {
throw new Exception('Could not connect to database server');
} else {
return $result;
}
}

function db_result_to_array($result) {
$res_array = array();

for ($count=0; $row = $result->fetch_assoc(); $count++) {
$res_array[$count] = $row;
}

return $res_array;
}

?>

και επισιναπτο και ενα αρχειο.php
Συνημμένα
main.rar
(1.45 KiB) Μεταφορτώθηκε 62 φορές

Άβαταρ μέλους
stevebat
Script Master
Δημοσιεύσεις: 307
Εγγραφή: 05 Αύγ 2009 15:54
Επικοινωνία:

προβλημα με ελληνικα σε σιτε

Δημοσίευση από stevebat » 13 Νοέμ 2011 18:35

Το αρχείο δεν το έκανες convert se utf8
Για δοκίμασε λίγο πάλι με το αρχείο που σου στέλνω και πες αν δουλεύει .
Συνημμένα
main.rar
(1.53 KiB) Μεταφορτώθηκε 107 φορές

miltiadisf
Δημοσιεύσεις: 43
Εγγραφή: 28 Ιουν 2010 13:51

προβλημα με ελληνικα σε σιτε

Δημοσίευση από miltiadisf » 14 Νοέμ 2011 00:14

bouzouste έγραψε:Το αρχείο δεν το έκανες convert se utf8
Για δοκίμασε λίγο πάλι με το αρχείο που σου στέλνω και πες αν δουλεύει .
αλλαξα ολα τα αρχεια σε utf8 αλλα τιποτα και μου εβγαλε και ενα σφαλμα στο main.php

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at C:\Program Files (x86)\EasyPHP-5.3.8.1\www\miltos15\main.php:178) in C:\Program Files (x86)\EasyPHP-5.3.8.1\www\miltos15\main.php on line 181

Άβαταρ μέλους
stevebat
Script Master
Δημοσιεύσεις: 307
Εγγραφή: 05 Αύγ 2009 15:54
Επικοινωνία:

προβλημα με ελληνικα σε σιτε

Δημοσίευση από stevebat » 14 Νοέμ 2011 15:05

μόνο το main κάνει πρόβλημα ή όλα; Επίσης έκανες μετατροπή ή απλά κωδικοποίηση;

apache έχεις;

miltiadisf
Δημοσιεύσεις: 43
Εγγραφή: 28 Ιουν 2010 13:51

προβλημα με ελληνικα σε σιτε

Δημοσίευση από miltiadisf » 14 Νοέμ 2011 18:03

bouzouste έγραψε:μόνο το main κάνει πρόβλημα ή όλα; Επίσης έκανες μετατροπή ή απλά κωδικοποίηση;

apache έχεις;
ενταξει λειτουργουνε ολα ευχαριστω για την βοηθεια!!!!

Απάντηση

Επιστροφή στο “PHP Προγραμματισμός”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες