Πρόβλημα με getElementById?

Κώδικας, πληροφορίες, ερωτήσεις και απαντήσεις σχετικές με την JavaScript.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Άβαταρ μέλους
ideal
Δημοσιεύσεις: 302
Εγγραφή: 12 Φεβ 2011 16:26

Πρόβλημα με getElementById?

Δημοσίευση από ideal » 04 Φεβ 2012 14:54

Σε μία σελίδα έχω βάλει ένα κουμπί το οποίο κάνει popup ένα νέο παράθυρο.
Μέσα στο παράθυρό αυτό έχω μία φόρμα στην οποία έχω ορίσει σαν target ένα iframe.

Το πρόβλημά μου είναι ότι θέλω να κρύψω τη φόρμα με την εντολή document.getElementById('forma').style.visibility='hidden'; αλλά δεν την κρύβει.

Έβαλα ένα if (document.getElementById('forma')){ alert('exists');} αλλά είναι σαν να μην υπάρχει...

Τι μπορεί να φταίει; Πώς μπορώ να το διορθώσω;

Άβαταρ μέλους
korgr
Honorary Member
Δημοσιεύσεις: 5067
Εγγραφή: 07 Οκτ 2008 18:30
Τοποθεσία: Corinth
Επικοινωνία:

Πρόβλημα με getElementById?

Δημοσίευση από korgr » 04 Φεβ 2012 16:17

Την εντολή πρέπει να την δώσεις από το παράθυρο που έχει την φόρμα. Αν το κάνεις από το αρχείο που έχει το κουμπί, λογικό είναι να μην δουλεύει.

Άβαταρ μέλους
ideal
Δημοσιεύσεις: 302
Εγγραφή: 12 Φεβ 2011 16:26

Πρόβλημα με getElementById?

Δημοσίευση από ideal » 04 Φεβ 2012 16:59

Από το παράθυρο της φόρμας το δίνω.

Άβαταρ μέλους
ideal
Δημοσιεύσεις: 302
Εγγραφή: 12 Φεβ 2011 16:26

Πρόβλημα με getElementById?

Δημοσίευση από ideal » 04 Φεβ 2012 17:37

Γκάφα :hammer:
Ψάχνοντας έπεσα εδώ http://forums.digitalpoint.com/showthread.php?t=244815 και κατάλαβα ότι έτρεχα τη function πριν προλάβει α φορτώσει η φόρμα...
Ευχαριστώ πάντως!

Απάντηση

Επιστροφή στο “JavaScript και Frameworks”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες