Δεν εμφανιζονται ελληνικοι χαρακτηρεσ στο site

Από που να ξεκινήσω; Που θα βρω; κ.α. γενικές ερωτήσεις για την δημιουργία μιας ιστοσελίδας.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
noktoma
Δημοσιεύσεις: 6
Εγγραφή: 24 Ιαν 2013 10:38

Δεν εμφανιζονται ελληνικοι χαρακτηρεσ στο site

Δημοσίευση από noktoma » 24 Ιαν 2013 10:55

Καλημερα σε όλους!
Σχετικά νέα στο χώρο...κ έτσι αντιμετωπίζω το εξής πρόβλημα (σε άλλο site με την αναφορά [παρακάτω] δεν αντιμετώπισα πρόβλημα)

1. εχω κάνει αναλογες αλλαγές που απαιτούνται στο κώδικα δηλαδή μέσα στο
<head>
<title>text</title>
<meta charset="windows-1253">
</head>

δυστυχώς δεν έχω ελληνικούς χαρακτήρες

2. λειτουργικό windows7
3. χρησιμοποιώ html me .css αρχεία
4. κατέβασα template προς πρακτική μου

σε ποια περίπτωση δεν μπορόυμε να δούμε ελληνικούς χαρακτήρες (υπάρχει τέτοια περίπτωση)

Ευχαριστώ εκ των προτέρων

Άβαταρ μέλους
burnmind
Script Master
Δημοσιεύσεις: 954
Εγγραφή: 26 Σεπ 2009 02:14
Τοποθεσία: UK
Επικοινωνία:

Δεν εμφανιζονται ελληνικοι χαρακτηρεσ στο site

Δημοσίευση από burnmind » 24 Ιαν 2013 12:23

Υποθέτω πως μιλάς μόνο για στατικές html σελίδες και δεν έχεις μπλεχτεί ακόμα με βάσεις κλπ.

Βεβαιώσου πως υπάρχει δήλωση για doctype (αν και δε γνωρίζω αν επηρεάζει τη σωστή εμφάνιση των Ελληνικών χαρακτήρων) και δήλωσε UTF-8 charset. Για παράδειγμα:

Κώδικας: Επιλογή όλων

<!DOCTYPE html>
<html>
   <head>
      ...
      <meta charset="utf-8" />
      ...
   </head>
...
</html>
Τέλος, βεβαιώσου πως τα αρχεία είναι σωσμένα με το εξής encoding: UTF-8 without BOM. Μπορείς να το αλλάξεις εύκολα μέσω του notepad++ (Encoding -> Encode in UTF-8 without BOM).

Απάντηση

Επιστροφή στο “Γενικές ερωτήσεις κατασκευής ιστοσελίδων”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 3 επισκέπτες