Πρόβλημα με τον apache

Μια περιοχή για το WordPress, αυτή την δημοφιλή δωρεάν πλατφόρμα για blogging

Συντονιστές: WebDev Moderators, Super-Moderators, PHP Moderators

Απάντηση
Άβαταρ μέλους
jpal
Δημοσιεύσεις: 27
Εγγραφή: 23 Μαρ 2011 22:57

Πρόβλημα με τον apache

Δημοσίευση από jpal » 02 Φεβ 2013 03:37

Σε local ο apache σε Module έχει κίτρινη ένδειξη , log error βγάζοντας τα τελευταία συμβάντα.

Κώδικας: Επιλογή όλων

[Sat Feb 02 03:18:10.977800 2013] [core:notice] [pid 5108:tid 220] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sat Feb 02 03:18:11.061800 2013] [mpm_winnt:notice] [pid 5108:tid 220] AH00418: Parent: Created child process 5204
[Sat Feb 02 03:18:13.216800 2013] [ssl:warn] [pid 5204:tid 232] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sat Feb 02 03:18:13.347800 2013] [mpm_winnt:notice] [pid 5204:tid 232] AH00354: Child: Starting 150 worker threads.
Πριν κρασάρει έβγαζε error :

Κώδικας: Επιλογή όλων

Υπογραφή προβλήματος:
  Όνομα συμβάντος προβλήματος:	APPCRASH
  Όνομα εφαρμογής:	httpd.exe
  Έκδοση εφαρμογής:	2.4.3.0
  Χρονική σήμανση εφαρμογής:	502f70a3
  Όνομα ελαττωματικής λειτουργικής μονάδας:	php5ts.dll
  Έκδοση ελαττωματικής λειτουργικής μονάδας:	5.4.7.0
  Χρονική σήμανση ελαττωματικής λειτουργικής μονάδας:	505114f8
  Κωδικός εξαίρεσης:	c0000005
  Μετατόπιση εξαίρεσης:	00065f59
  Έκδοση λειτουργικού συστήματος:	6.1.7600.2.0.0.256.1
  Αναγνωριστικό τοπικών ρυθμίσεων:	1032
  Πρόσθετες πληροφορίες 1:	0a9e
  Πρόσθετες πληροφορίες 2:	0a9e372d3b4ad19135b953a78882e789
  Πρόσθετες πληροφορίες 3:	0a9e
  Πρόσθετες πληροφορίες 4:	0a9e372d3b4ad19135b953a78882e789
Στοιχεία :
PHP Version 5.4.7
XAMPP 1.8.1

Κάποια ιδεά? κοντεύω να σαλτάρω.

Ευχαριστω και πάλι.

Άβαταρ μέλους
jpal
Δημοσιεύσεις: 27
Εγγραφή: 23 Μαρ 2011 22:57

Πρόβλημα με τον apache

Δημοσίευση από jpal » 03 Φεβ 2013 19:35

Το συγκεκριμένο συμβαίνει όταν θέλω να κάνω edit στο Menu.


Άβαταρ μέλους
jpal
Δημοσιεύσεις: 27
Εγγραφή: 23 Μαρ 2011 22:57

Πρόβλημα με τον apache

Δημοσίευση από jpal » 04 Φεβ 2013 01:03

gvre ευχαριστω για την βοηθεια. Για να δω το server-status πηγαίνω :
Στο http://localhost/server-status στο xampp.conf δεν μπορεί να μπει
New XAMPP security concept:
Access to the requested object is only available from the local network.
This setting can be configured in the file "httpd-xampp.conf".
Μπήκα στο xampp.conf και από :
Alias /phpmyadmin "C:/xampp/phpMyAdmin/"
<Directory "C:/xampp/phpMyAdmin">
AllowOverride AuthConfig
Require all granted
</Directory>
Το αλλαξα σε :
Alias /phpmyadmin "C:/xampp/phpMyAdmin/"
<Directory "C:/xampp/phpMyAdmin">
AllowOverride AuthConfig Limit
Require all granted
Order allow,deny
Allow from all
</Directory>
Restart xampp αλλά και πάλι δεν με αφήνει να μπώ. Κάποια ιδεά?

gvre
Δημοσιεύσεις: 990
Εγγραφή: 14 Οκτ 2010 11:34
Τοποθεσία: Ηράκλειο Κρήτης
Επικοινωνία:

Πρόβλημα με τον apache

Δημοσίευση από gvre » 04 Φεβ 2013 09:19

Δε χρειάζεσαι το server status αλλά το SSLSessionCache. Λογικά είναι μέσα σε κάποιο .conf (σε σχόλιο). Αν δεν είναι, πρόσθεσέ το με τον τρόπο που αναφέρεται στη σελίδα που σου έστειλα. Αν έχεις 64bit windows δες και το "Problems on 64-bit Microsoft Windows".

Άβαταρ μέλους
jpal
Δημοσιεύσεις: 27
Εγγραφή: 23 Μαρ 2011 22:57

Πρόβλημα με τον apache

Δημοσίευση από jpal » 04 Φεβ 2013 12:36

Πιστεύω να καταλαβα.. Μπήκα στο : httpd - ssl.conf

Κώδικας: Επιλογή όλων

#   Inter-Process Session Cache&#58;
#   Configure the SSL Session Cache&#58; First the mechanism 
#   to use and second the expiring timeout &#40;in seconds&#41;.
#SSLSessionCache         "dbm&#58;logs/ssl.scache"
##SSLSessionCache        "shmcb&#58;logs/ssl.scache&#40;512000&#41;"
##SSLSessionCacheTimeout  300
Εκανα ότι αναφέρει http://www.xinotes.org/notes/note/1776/

I corrected the previous error by using the alternative line for SSLSessionCache:

Κώδικας: Επιλογή όλων

#   Inter-Process Session Cache&#58;
#   Configure the SSL Session Cache&#58; First the mechanism 
#   to use and second the expiring timeout &#40;in seconds&#41;.
SSLSessionCache         "dbm&#58;C&#58;/Program Files &#40;x86&#41;/Apache Software Foundation/Apache2.2/logs/ssl_scache"
# SSLSessionCache        "shmcb&#58;C&#58;/Program Files &#40;x86&#41;/Apache Software Foundation/Apache2.2/logs/ssl_scache&#40;512000&#41;"
SSLSessionCacheTimeout  300
Αλλα ο apache δεν τρεχει.

gvre
Δημοσιεύσεις: 990
Εγγραφή: 14 Οκτ 2010 11:34
Τοποθεσία: Ηράκλειο Κρήτης
Επικοινωνία:

Πρόβλημα με τον apache

Δημοσίευση από gvre » 05 Φεβ 2013 14:37

Βεβαιώσου ότι το path C:/Program Files (x86)/Apache Software Foundation/Apache2.2/logs υπάρχει. Δες και τα logs μήπως σου έχει βγάλει κάποιο μήνυμα.

Αν δε χρειάζεσαι ssl μπορείς να το απενεργοποιήσεις εντελώς.

Άβαταρ μέλους
jpal
Δημοσιεύσεις: 27
Εγγραφή: 23 Μαρ 2011 22:57

Πρόβλημα με τον apache

Δημοσίευση από jpal » 05 Φεβ 2013 15:25

Αν το λεω σωστα. Τα logs που βρηκα είναι στην διαδρομη : C:\xampp\apache\logs.

Κώδικας: Επιλογή όλων

access
error
httpd.pid
ssl_request
SSl δεν χρειάζομαι, αλλά πως το απενεργοποιώ: Μπήκα από wp-config αλλά δεν βρήκα κάτι σαν "FORCE_SSL"

Απάντηση

Επιστροφή στο “WordPress γενικά”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης