Requires JavaScript

Κώδικας, πληροφορίες, ερωτήσεις και απαντήσεις σχετικές με την JavaScript.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
pitmar
Δημοσιεύσεις: 84
Εγγραφή: 29 Σεπ 2012 09:57
Τοποθεσία: 84

Requires JavaScript

Δημοσίευση από pitmar » 01 Απρ 2013 12:03

Καλημέρα σας. Έχω ξαφνικά πρόβλημα με το JavaScript. Ενώ αρχικά μπορούσα να προσθέτω φωτογραφίες ως slideshow στο blog μου, ξαφνικά προσπάθησα να προσθέσω νέο slideshow κι αντί γι' αυτό εμφανίζεται στο post η εξής πρόταση : the slideshow requires JavaScript. Που πήγε ξαφνικά το JavaScript; Υπάρχει τρόπος διόρθωσης;

alou
Script Master
Δημοσιεύσεις: 1374
Εγγραφή: 24 Αύγ 2007 19:52
Επικοινωνία:

Requires JavaScript

Δημοσίευση από alou » 01 Απρ 2013 14:28

Μήπως την έχεις απενεργοποιήσει στον browser σου? Η Javascrpt δεν είναι κάτι που μπορεί να φύγει γενικώς....

pitmar
Δημοσιεύσεις: 84
Εγγραφή: 29 Σεπ 2012 09:57
Τοποθεσία: 84

Requires JavaScript

Δημοσίευση από pitmar » 01 Απρ 2013 15:39

Τι να σου πω... Εγώ δεν έκανα τίποτα. Πώς μπορώ να το ενεργοποιήσω σε περίπτωση που ισχύει κάτι τέτοιο;

alou
Script Master
Δημοσιεύσεις: 1374
Εγγραφή: 24 Αύγ 2007 19:52
Επικοινωνία:

Requires JavaScript

Δημοσίευση από alou » 01 Απρ 2013 15:52

Ανάλογα τον browser που χρησιμοποιείς, ρίξε μια ματιά στις ρυθμίσεις / επιλογές του και θα βρεις κάποιο σημείο που ενεργοποιεί / απενεργοποιεί την javascript. Λογικά σε κάποια καρτέλλα που σχετίζεται με το περιεχόμενο.

pitmar
Δημοσιεύσεις: 84
Εγγραφή: 29 Σεπ 2012 09:57
Τοποθεσία: 84

Requires JavaScript

Δημοσίευση από pitmar » 10 Απρ 2013 12:08

Καλημέρα. Συγχωρήστε με που δεν απάντησα νωρίτερα αλλά είχα πρόβλημα με την σύνδεση στο Ίντερνετ. Όπως ανέφερα και παραπάνω δεν έχω πειράξει τις ρυθμίσεις και πήγα να το ελέγξω και είναι όντως ενεργοποιειμένο το javascript.

Άβαταρ μέλους
_tasos
Δημοσιεύσεις: 116
Εγγραφή: 03 Μάιος 2007 15:06
Επικοινωνία:

Requires JavaScript

Δημοσίευση από _tasos » 10 Απρ 2013 23:38

Αυτό που κάνουν μερικά plugins είναι να έχουν αρχικά στο html το μήνυμα "the slideshow requires JavaScript" και όταν φορτωθεί το slideshow αυτό το μήνυμα αντικαθιστάται από το html που παράγει δυναμικά το slideshow.
Είναι πιθανό να χτυπάει κάπου το slideshow και να μένει έτσι το μήνυμα, το οποίο φυσικά δεν είναι σωστό.

Θα πρότεινα να δεις αν έχεις κάποιο javascript error. Μπορείς να δώσεις κάποιο link με το blog σου να δούμε τι γίνεται;

pitmar
Δημοσιεύσεις: 84
Εγγραφή: 29 Σεπ 2012 09:57
Τοποθεσία: 84

Requires JavaScript

Δημοσίευση από pitmar » 11 Απρ 2013 11:54

Βεβαίως. Το link για το blog μου είναι η υπογραφή μου. Διάβασα αλλού πως μπορεί να μου δημιούργησε το πρόβλημα κάποιο plugin ή widget και μου είπαν να κάνω δεξί κλικ/επιθεώρηση στοιχείου/και στο console θα μου έδειχνε ποιο είναι το πρόβλημα. Αλλά να σου πω την αλήθεια, έκανα όπως μου είπαν δεν ήξερα όμως τι έπρεπε να κάνω στη συνέχεια κι έτσι το μόνο που σκέφτηκα ήταν να διαγράψω όλα τα τελευταία widgets, plugins που θυμόμουνα μήπως και λυθεί αλλά τίποτα. Ακόμα δεν έχω javascript. Τέλος πάντων, όπως σου είπα το blog μου είναι αυτό που γράφει η υπογραφή. Εύχομαι να βρούμε μια λύση. Σ' ευχαριστώ πολύ για την βοήθεια.

Άβαταρ μέλους
_tasos
Δημοσιεύσεις: 116
Εγγραφή: 03 Μάιος 2007 15:06
Επικοινωνία:

Requires JavaScript

Δημοσίευση από _tasos » 13 Απρ 2013 12:25

Χτυπάει ένα error στο παρακάτω snippet κώδικα.

Κώδικας: Επιλογή όλων

<script type="text/javascript">
//<!&#91;CDATA&#91;
jQuery&#40;document&#41;.ready&#40;function&#40;&#41; &#123;
var dialog = jQuery&#40;'<div></div>'&#41;
.html&#40;'<form method="post" action=""><input type="hidden" name="ip" value="2.85.10.220" /><p><label for="s2email">Your email&#58;</label><br /><input type="text" name="email" id="s2email" value="" size="20" /></p><p><input type="submit" name="subscribe" value="Subscribe" />&nbsp;<input type="submit" name="unsubscribe" value="Unsubscribe" /></p></form>'&#41;
.dialog&#40;&#123;autoOpen&#58; false, modal&#58; true, zIndex&#58; 10000, title&#58; 'Subscribe to this blog'&#125;&#41;;
jQuery&#40;'a.s2popup'&#41;.click&#40;function&#40;&#41;&#123;
dialog.dialog&#40;'open'&#41;;
return false;
&#125;&#41;;
&#125;&#41;;
//&#93;&#93;>
</script> 
Η γραμμή "var dialog = jQuery('<div></div>') " θέλει να βάλεις ; στο τέλος. Ίσως αυτό το error εμποδίζει να τρέξει σωστά το script για το photo gallery.

Επίσης, αν μπορείς δώσε ένα link όπου εμφανίζεται το πρόβλημα με το photo gallery.

pitmar
Δημοσιεύσεις: 84
Εγγραφή: 29 Σεπ 2012 09:57
Τοποθεσία: 84

Requires JavaScript

Δημοσίευση από pitmar » 22 Απρ 2013 09:42

Καλημέρα Tasos, με συγχωρείς που δεν σου απάντησα νωρίτερα αλλά έχω θέμα με την σύνδεση στο Ίντερνετ. Είχα ασύρματο, καταργήσανε την κεραία στην περιοχή μου και περιμένω τώρα να μου κάνουν σύνδεση adsl και θα πάρει κάνα μήνα. Λοιπόν, όπως καταλαβαίνεις έχω "μεταναστεύσει" προσωρινά σε φιλικό μου πρόσωπο μέχρι να ενεργοποιηθεί η δική μου σύνδεση.
Αρκετά μ' αυτά, απλά ήθελα να σου πω πως "με καίει" το θέμα του javascript απλά δεν είχα πρόσβαση μέχρι τώρα στο Ίντερνετ γι' αυτό και άργησα να απαντήσω.
Το βρήκα το σημείο που μου λες (που λείπει το ερωτηματικό), προσπάθησα να το προσθέσω αλλά δεν μπορώ. Μπορείς να μου πεις τι πρέπει να κάνω για να το γράψω;

Άβαταρ μέλους
_tasos
Δημοσιεύσεις: 116
Εγγραφή: 03 Μάιος 2007 15:06
Επικοινωνία:

Requires JavaScript

Δημοσίευση από _tasos » 22 Απρ 2013 23:50

Θα πρέπει να πειράξεις το template.

Πριν μπλέξεις με κάτι τέτοιο, έχεις κάποιο link με το gallery που έχει πρόβλημα;

pitmar
Δημοσιεύσεις: 84
Εγγραφή: 29 Σεπ 2012 09:57
Τοποθεσία: 84

Requires JavaScript

Δημοσίευση από pitmar » 01 Μάιος 2013 19:04

Ένα από τα gallery που έχω πρόβλημα είναι αυτό:
http://taskylonea.com/?p=633
Γράφει κάτω κάτω στο τέλους του άρθρου το μήνυμα.
Πιστεύω να βρεθεί μια λύση, τι λες;
Πάντως σ'ευχαριστώ για την βοήθειά σου και που συνεχίζεις μήπως το λύσουμε. Απλά, όπως καταλαβαίνεις είμαι αρχάρια και μου έτυχε κι αυτό...

Άβαταρ μέλους
_tasos
Δημοσιεύσεις: 116
Εγγραφή: 03 Μάιος 2007 15:06
Επικοινωνία:

Requires JavaScript

Δημοσίευση από _tasos » 05 Μάιος 2013 20:51

Από ότι καταλαβαίνω, χρησιμοποιείς το slideshow από το jetpack.

Κοίταξα το html της σελίδας και λείπουν τα javascript αρχεία που το αρχικοποιούν.
Το error που σου είπα στο προηγούμενο post δεν έχει σχέση με το πρόβλημα.

Βρήκα αυτό το post όπου συζητούν το ίδιο πρόβλημα http://wordpress.org/support/topic/this ... ript-error.
Αν θέλεις δες στο footer.php αρχείο και δες αν καλείται η συνάρτηση <?php wp_footer(); ?>.

pitmar
Δημοσιεύσεις: 84
Εγγραφή: 29 Σεπ 2012 09:57
Τοποθεσία: 84

Requires JavaScript

Δημοσίευση από pitmar » 07 Μάιος 2013 12:54

Καλησπέρα και Χρόνια Πολλά. Είδα την εντολή που μου είπες, υπάρχει. Θα κοιτάξω να βρω μια άκρη στο link που μου έδωσες.
Σ' ευχαριστώ πολύ.

Απάντηση

Επιστροφή στο “JavaScript και Frameworks”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες