Πως κανω την υπηρεσια http να ''ακουει'' σε διαφορετικο port?

Προβλήματα που αντιμετωπίζουμε χρησιμοποιώντας τα Windows και τα προγράμματά τους. Νέα & ειδήσεις.

Συντονιστές: Super-Moderators, Software & Hardware Moderators

Απάντηση
pol2005
Δημοσιεύσεις: 58
Εγγραφή: 26 Δεκ 2008 20:50

Πως κανω την υπηρεσια http να ''ακουει'' σε διαφορετικο port?

Δημοσίευση από pol2005 » 31 Αύγ 2013 21:29

Καλησπερα εχω ενα pc με windows 7 και εχω το εξης προβλημα.Βαζω τον xaamp και apache δεν ξεκινα διοτι το port 80 ειναι πιασμενο απο την υπηρεσια http των windows.Εαν απενεργοποιησω αυτη την υπηρεσια ο apache ξεκινα αλλα δεν δουλευει μια σειρα απο υπηρεσιες οι οποιες εξαρτωνται απο την http(οπως πχ δεν δουλευουν οι εκτυπωτες).Η μονη λυση που μπορω να σκεφτω ειναι να αλλαξω το port που τρεχει η http αλλα δεν ξερω πως.
Το εψαξα και στο google αλλα δε βρηκα ακρη.
Εχει κανεις καμια ιδεα?

ΥΓ:Το port 80 θελω για τον apache διοτι εχω στησει μια βαση που την βλεπουν και αλλοι μεσω της ip μου,αρα υποχρεωτικα πρεπει να χρησιμοποιησω το port 80 εφοσον δεν ειναι τοπικο.

Άβαταρ μέλους
korgr
Honorary Member
Δημοσιεύσεις: 5067
Εγγραφή: 07 Οκτ 2008 18:30
Τοποθεσία: Corinth
Επικοινωνία:

Πως κανω την υπηρεσια http να ''ακουει'' σε διαφορετικο port?

Δημοσίευση από korgr » 31 Αύγ 2013 21:48

XAMPP Control Panel -> Config -> Service and Port Settings

Άβαταρ μέλους
giannis17
Honorary Member
Δημοσιεύσεις: 1215
Εγγραφή: 06 Ιαν 2005 19:50
Τοποθεσία: Παγκράτι - Αθήνα
Επικοινωνία:

Πως κανω την υπηρεσια http να ''ακουει'' σε διαφορετικο port?

Δημοσίευση από giannis17 » 01 Σεπ 2013 13:48

Απλά παρατήρηση: Η port 80 δεν δεσμεύεται από τα windows για κάποιο λόγο (εκτός αν τρέχεις και IIS). Ο φταίχτης της υπόθεσης είναι το skype! Για κάποιο λόγο το skype δεσμεύει την 80 όταν ανοίγει αλλά μόνον αν είναι διαθέσιμη, αν δεν είναι πιάνει κάποια άλλη.

Οπότε η λύση είναι να ανοίγεις το skype χειροκίνητα και όχι αυτόματα με την έναρξη των windows καθώς συνήθως ανοίγει πριν το service του apache και μετά δεν παίζει το http.
"There is only one problem with common sense; it’s not very common."
– Milt Bryce

pol2005
Δημοσιεύσεις: 58
Εγγραφή: 26 Δεκ 2008 20:50

Πως κανω την υπηρεσια http να ''ακουει'' σε διαφορετικο port?

Δημοσίευση από pol2005 » 01 Σεπ 2013 18:38

korgr έγραψε:XAMPP Control Panel -> Config -> Service and Port Settings
δεν θελω να αλλαξω το port του xaamp,το port 80 των windows θελω να ελευθερωσω

pol2005
Δημοσιεύσεις: 58
Εγγραφή: 26 Δεκ 2008 20:50

Πως κανω την υπηρεσια http να ''ακουει'' σε διαφορετικο port?

Δημοσίευση από pol2005 » 01 Σεπ 2013 18:42

giannis17 έγραψε:Απλά παρατήρηση: Η port 80 δεν δεσμεύεται από τα windows για κάποιο λόγο (εκτός αν τρέχεις και IIS). Ο φταίχτης της υπόθεσης είναι το skype! Για κάποιο λόγο το skype δεσμεύει την 80 όταν ανοίγει αλλά μόνον αν είναι διαθέσιμη, αν δεν είναι πιάνει κάποια άλλη.

Οπότε η λύση είναι να ανοίγεις το skype χειροκίνητα και όχι αυτόματα με την έναρξη των windows καθώς συνήθως ανοίγει πριν το service του apache και μετά δεν παίζει το http.
Και ομως δεσμευεται.Και δεν εχω εγκατεστημενο ουτε το skype ουτε τον IIS.Οταν απενεργοποιω την υπηρεσια http ο xaamp παιζει κανονικα αλλα η ''ουρα εκτυπωσης'' ας πουμε δεν δουλευει διοτι εξαρταται απο την http,η οποια ειναι απενεργοποιημενη.

Άβαταρ μέλους
giannis17
Honorary Member
Δημοσιεύσεις: 1215
Εγγραφή: 06 Ιαν 2005 19:50
Τοποθεσία: Παγκράτι - Αθήνα
Επικοινωνία:

Πως κανω την υπηρεσια http να ''ακουει'' σε διαφορετικο port?

Δημοσίευση από giannis17 » 01 Σεπ 2013 22:25

Οκ...χρησιμοποιώ τα windows 7 από το Beta και πρώτη φορά το ακούω. Εσύ βρίσκεις HTTP μέσα στα services? Στα δικά μου (Home Premium x64) δεν υπάρχει πάντως. Και το μόνο πρόβλημα που είχα με τον apache ήταν το skype!

Δες μήπως σε βοηθήσει αυτό: www.mikeplate.com/2011/11/06/stop-http- ... n-windows/
"There is only one problem with common sense; it’s not very common."
– Milt Bryce

pol2005
Δημοσιεύσεις: 58
Εγγραφή: 26 Δεκ 2008 20:50

Πως κανω την υπηρεσια http να ''ακουει'' σε διαφορετικο port?

Δημοσίευση από pol2005 » 02 Σεπ 2013 00:53

Ανεβαζω και μια εικονα με την υπηρεσια που χρησιμοποιει το port.
Προσωρινα βρηκα λυση.Στη γραμμη εντολων αμα τρεξεις netsh interface portproxy add v4tov4 listenport=80 listenaddress=192.168.1.1 connectport=8080 connectaddress=192.168.1.1 σου κανει forward την εισερχομενη κινηση στο port 8080.
Συνημμένα
hgh.jpg

Απάντηση

Επιστροφή στο “Windows Software Guide”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες