I NEED HELP!!! Bernoulli combination

Γενικά θέματα για τις γλώσσες προγραμματισμού που δεν καλύπτονται από τις άλλες περιοχές της κατηγορίας.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Άβαταρ μέλους
Bi2L
Δημοσιεύσεις: 51
Εγγραφή: 10 Αύγ 2003 21:59

I NEED HELP!!! Bernoulli combination

Δημοσίευση από Bi2L » 05 Νοέμ 2003 19:01

Hello everybodody!
I Need HELP!!!!!!!
Pws 8a balw paragogo mesa se glwssa programmatismou?
Syggekrimena 8elw na balw ton typo tou Bernoulli combinations:
(Basika to 8elw se glwssa eiffel, alla oles oi glwsses einai paromies)

N!
____________
m! (N - m)!


N!/m!(N-m)!

PLEASE!!!!HELP ME!!!!

Άβαταρ μέλους
Bugman
Δημοσιεύσεις: 362
Εγγραφή: 01 Ιούλ 2003 20:39
Τοποθεσία: Πρέβεζα
Επικοινωνία:

I NEED HELP!!! Bernoulli combination

Δημοσίευση από Bugman » 07 Νοέμ 2003 23:08

Αν σε ενδιαφέρει να κάνεις την δουλεία σου με μια απλή γλώσσα να πάρε την Γλωσσομάθεια του Νικολαϊδη:

http://glossomatheia.studies.gr/forum/

Να ένα πρόγραμμά μου:

Κώδικας: Επιλογή όλων

! Συνολικές στήλες στο lotto 
! Θεωρία: Παραγοντικό P!(x) 
! P!(X)= X*(X-1)*(X-2)*..*1 
! P!(0)=1 
! Για το λότο οι συνολικές εξάδες είναι 
! Κανονικός τύπος P!(49)/P!(49-6)/P!(6)=13983816 
! Αν το δούμε πιο καλά θα βρούμε την απλή μορφή: 
! Απλή μορφή 49*48*47*46*45*44/6/5/4/3/2=13983816 
! ΣΤΟΧΟΣ ΤΑ ΕΝΔΙΑΜΕΣΑ ΑΠΟΤΕΛΕΣΜΑΤΑ ΝΑ ΕΙΝΑΙ *ΜΙΚΡΑ* 
! Δηλαδή μικρότερα από το τελικό νούμερο 13983816 
! Αυτό είναι ένα πραγματικό πρόβλημα που μπορεί να αντιμετωπίσουν προγραμματιστές 
! λόγω των περιορισμών στο υποσύστημα πράξεων 
ΠΡΟΓΡΑΜΜΑ Α 
ΜΕΤΑΒΛΗΤΕΣ 
   ΑΚΕΡΑΙΕΣ: Χ,Κ 
   ΠΡΑΓΜΑΤΙΚΕΣ: Π, Π1, ΠΕ 
ΑΡΧΗ 
   ΓΡΑΨΕ 'Συνολικές 6-αδες από 49 νούμερα' 
   Χ <-- 6 
   Π <-- 49 
   ΓΡΑΨΕ 'Π=', 49 
   ΓΙΑ Κ ΑΠΟ Χ ΜΕΧΡΙ 2 ΜΕ ΒΗΜΑ -1 
      Π1 <-- Π 
      ΠΕ <-- &#40;50-Κ&#41;/Κ 
      Π <-- Π*ΠΕ 
      ΓΡΑΨΕ  '*',Α_Μ&#40;50-Κ&#41;,'/ ', Α_Μ&#40;Κ&#41;,' = ', Π1&#58;10&#58;0,'*',ΠΕ&#58;10&#58;3,' => Π=', Π&#58;10&#58;0 
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
   ΓΡΑΨΕ 'ΕΠΑΛΗΘΕΥΣΗ=', &#40;49.*48*47*46*45*44&#41;/&#40;6.*5*4*3*2&#41;&#58;10&#58;0 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

Απάντηση

Επιστροφή στο “γλώσσες προγραμματισμού - γενικά”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες