Πρόβλημα με Visual Editor

WordPress Plugins

Συντονιστές: WebDev Moderators, Super-Moderators, PHP Moderators

Απάντηση
Άβαταρ μέλους
neundex
Δημοσιεύσεις: 40
Εγγραφή: 19 Σεπ 2013 09:49
Επικοινωνία:

Πρόβλημα με Visual Editor

Δημοσίευση από neundex » 09 Ιαν 2014 15:50

Καλησπέρα

Έχω ένα πρόβλημα με το TinyMCE σε WordPress 3.7.1. Ξαφνικά (ενω δούλευε κανονικά) δεν μπορώ να πατήσω το Visual από το Text. Δεν είναι ενεργό.

Δοκίμασα να ανεβάσω ξανά μόνο το φάκελο του tinymce, διορθώθηκε προσωρινά αλλά δυστυχώς ξαναγινε.

Μήπως ξέρει κανείς τί μπορεί να συμβαίνει;


Άβαταρ μέλους
neundex
Δημοσιεύσεις: 40
Εγγραφή: 19 Σεπ 2013 09:49
Επικοινωνία:

Πρόβλημα με Visual Editor

Δημοσίευση από neundex » 09 Ιαν 2014 18:39

ευχαριστώ για την απάντηση - αλλά δυστυχώς το έχω δοκιμάσει και δεν έφτιαξε. όπως και την λύση που αναφέρουν σε αυτό ή άλλο post με το google libraries..

geomagas
Δημοσιεύσεις: 667
Εγγραφή: 06 Απρ 2013 13:36
Τοποθεσία: Ηράκλειο Κρήτης
Επικοινωνία:

Πρόβλημα με Visual Editor

Δημοσίευση από geomagas » 09 Ιαν 2014 21:02

Άνοιξε το firebug (or similar), κάνε refresh, και δες αν σου βγάζει κανένα javasctipt error.

Άβαταρ μέλους
neundex
Δημοσιεύσεις: 40
Εγγραφή: 19 Σεπ 2013 09:49
Επικοινωνία:

Πρόβλημα με Visual Editor

Δημοσίευση από neundex » 09 Ιαν 2014 22:05

Έχεις δίκιο! Έχει 6 errors:

Κώδικας: Επιλογή όλων

Uncaught SyntaxError&#58; Unexpected token < 								/wp-includes/js/tinymce/tiny_mce.js/?ver=359-20131026&#58;1
Uncaught ReferenceError&#58; tinymce is not defined 						wp-tinymce-schema.js&#58;940
Uncaught ReferenceError&#58; tinyMCE is not defined 						wp-langs-en.js&#58;1
Uncaught ReferenceError&#58; tinymce is not defined 						post.php?post=287&action=edit&#58;1626
Uncaught TypeError&#58; Cannot call method 'create' of undefined 		measureIt.js&#58;120
Uncaught ReferenceError&#58; tinyMCE is not defined 						editor.min.js?ver=3.7.1&#58;1

geomagas
Δημοσιεύσεις: 667
Εγγραφή: 06 Απρ 2013 13:36
Τοποθεσία: Ηράκλειο Κρήτης
Επικοινωνία:

Πρόβλημα με Visual Editor

Δημοσίευση από geomagas » 09 Ιαν 2014 22:13

Βασικά, το πρώτο είναι το σημαντικό. Όλα τα άλλα είναι συνέπειες αυτού.

Βλέπεις ότι είναι αρχείο στο wp-includes. Αφού λες ότι το ξαναέγραψες και δούλεψε για λίγο, αυτό πάει να πει ότι ενώ κάνεις overwrite το "χαλασμένο" με το "καλό", μετά από λίγο κάτι(ποιος) το "πειράζει".

Προσπάθησε να απενεργοποιήσεις όσα plugins μπορείς (όλα???) και να τα ενεργοποιείς ένα ένα, ώστε να δεις με ποιο "τσακώνεται"...

EDIT: Τώρα που το ξαναβλέπω, το unexpected token στη γραμμή 1 είναι <. :think:
Για προσπάθησε να γράψεις στη γραμμή διεύθυνσης

Κώδικας: Επιλογή όλων

http&#58;//www.yoursite.tld//wp-includes/js/tinymce/tiny_mce.js/?ver=359-20131026
και πες τι βλέπεις.

Άβαταρ μέλους
neundex
Δημοσιεύσεις: 40
Εγγραφή: 19 Σεπ 2013 09:49
Επικοινωνία:

Πρόβλημα με Visual Editor

Δημοσίευση από neundex » 09 Ιαν 2014 22:22

ρε γμτ καταλαβαίνω τι λές αλλά νομίζω δεν ισχύει γιατί το μόνο plugin που έχω είναι το seo by yoast, το οποίο το έχω δοκιμάσει και σε άλλες εγκαταστάσεις χωρίς πρόβλημα. anyway θα το κάνω και βλέπουμε...

Άβαταρ μέλους
neundex
Δημοσιεύσεις: 40
Εγγραφή: 19 Σεπ 2013 09:49
Επικοινωνία:

Πρόβλημα με Visual Editor

Δημοσίευση από neundex » 09 Ιαν 2014 22:24

geomagas έγραψε:και πες τι βλέπεις.
τίποτα. με πάει στην αρχική του site

geomagas
Δημοσιεύσεις: 667
Εγγραφή: 06 Απρ 2013 13:36
Τοποθεσία: Ηράκλειο Κρήτης
Επικοινωνία:

Πρόβλημα με Visual Editor

Δημοσίευση από geomagas » 09 Ιαν 2014 22:29

Αχά! Εξ ου και το < (είναι ο πρώτος χαρακτήρας του πρώτου tag, πιθανότατα του <!DOCTYPE ...>).

Δοκίμασε το χωρίς το query string, δηλαδή μέχρι το .js.

Άβαταρ μέλους
neundex
Δημοσιεύσεις: 40
Εγγραφή: 19 Σεπ 2013 09:49
Επικοινωνία:

Πρόβλημα με Visual Editor

Δημοσίευση από neundex » 09 Ιαν 2014 22:43

το ίδιο! πως χάνεται το αρχείο;

μήπως έχει να κάνει με τον server και το .gz compression? κατι βρήκα για το wp-tinymce.js.gz οτι μάλλον θα πρέπει να το ανεβασω κανονικά και οχι zipped.

geomagas
Δημοσιεύσεις: 667
Εγγραφή: 06 Απρ 2013 13:36
Τοποθεσία: Ηράκλειο Κρήτης
Επικοινωνία:

Πρόβλημα με Visual Editor

Δημοσίευση από geomagas » 10 Ιαν 2014 14:36

Ναι κάντο έτσι.

Με απασχολεί το γεγονός ότι δουλεύει για λίγο κι ύστερα χαλάει όπως λες...
Το λογικό θα ήταν να μην παίζει εξ αρχής.

nbc
Honorary Member
Δημοσιεύσεις: 526
Εγγραφή: 05 Σεπ 2009 20:12
Επικοινωνία:

Πρόβλημα με Visual Editor

Δημοσίευση από nbc » 11 Ιαν 2014 12:09

Δεν έχω εμπειρία από WP, αλλά αυτό το URL

Κώδικας: Επιλογή όλων

/wp-includes/js/tinymce/tiny_mce.js/?ver=359-20131026&#58;1
δεν μου φαίνεται σωστό...

Αναφέρομαι στο / πριν το ?. Ποιος το σερβίρει αυτό και με τι mime type?

geomagas
Δημοσιεύσεις: 667
Εγγραφή: 06 Απρ 2013 13:36
Τοποθεσία: Ηράκλειο Κρήτης
Επικοινωνία:

Πρόβλημα με Visual Editor

Δημοσίευση από geomagas » 11 Ιαν 2014 12:57

nbc έγραψε:Δεν έχω εμπειρία από WP, αλλά αυτό το URL

Κώδικας: Επιλογή όλων

/wp-includes/js/tinymce/tiny_mce.js/?ver=359-20131026&#58;1
δεν μου φαίνεται σωστό...

Αναφέρομαι στο / πριν το ?. Ποιος το σερβίρει αυτό και με τι mime type?
:o Ώπα! Έχεις δίκιο!!!
Άμα σου πω ότι δεν το πρόσεξα καθόλου...
:oops:

Άβαταρ μέλους
neundex
Δημοσιεύσεις: 40
Εγγραφή: 19 Σεπ 2013 09:49
Επικοινωνία:

Πρόβλημα με Visual Editor

Δημοσίευση από neundex » 13 Ιαν 2014 18:35

nbc έγραψε:Αναφέρομαι στο / πριν το ?. Ποιος το σερβίρει αυτό και με τι mime type?
η αλήθεια είναι πως κι εμένα μου έκανε εντύπωση οτι το ?ver= είναι μετά το /, αλλά η αληθεια είναι επίσης πως δεν ξέρω ούτε ποιος το σερβίρει ούτε με τί mime type :-? - ούτε που μπορώ να το δώ αυτό.

προς το παρόν πάντως ανέβασα το tiny_mce.js και το wp-tinymce.js αζιπάριστο και παζει. το θέμα είναι βέβαια για πόσο..θα το παροκολουθήσω και βλέπουμε.

ευχαριστώ για τις απαντήσεις!

Απάντηση

Επιστροφή στο “WordPress Plugins”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης