Αναβάθμιση σε PHP 5.5

Τεχνικές και μόνο Συζητήσεις για WEB hosting servers, Mail servers, DNS servers. Όχι αναζήτηση υπηρεσιών εδώ!

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Άβαταρ μέλους
giannis17
Honorary Member
Δημοσιεύσεις: 1215
Εγγραφή: 06 Ιαν 2005 19:50
Τοποθεσία: Παγκράτι - Αθήνα
Επικοινωνία:

Αναβάθμιση σε PHP 5.5

Δημοσίευση από giannis17 » 03 Μαρ 2014 13:02

Παιδιά έχω ενδοιασμούς μη κάνω καμιά πατάτα οπότε ρωτάω και τους πιο σκληροπυρηνικούς (condor ακούει? :kaloe: )

Έχω ένα vps με Centos 6.5 x64 που τρέχει PHP 5.3.3 και θέλω να κάνω την τελευταία αναβάθμιση σε 5.5.9. Το virtualmin που χρησιμοποιώ δεν θα έχει κάποιο θέμα, τρέχει σε δικό του process και όχι μέσω apache(το πολύ πολύ να μην μπορώ να αλλάξω τις επιλογές της PHP πλέον από το panel), τα wordpress επίσηε μετά την έκδοση 3.7 δεν έχουν πρόβλημα. Μερικά joomla 2.5 που έχω τους έχω περάσει ένα patch για να είναι συμβατά.

Θα προτιμούσα αν υπήρχε τρόπος να έχω και τις 2 εκδόσεις PHP και να μπορώ να διαλέξω σε κάθε virtual server ποια να χρησιμοποιήσω. Προσπάθησα να κάνω εγκατάσταση την 5.5 χωρίς να αφαιρέσω την 5.3 και παίρνω το παρακάτω error

Κώδικας: Επιλογή όλων

Error: php55w-common conflicts with php-common-5.3.3-27.el6_5.x86_64
Ακολούθησα το guide που υπάρχει εδώ: http://webtatic.com/packages/php55/

Καμιά συμβουλή;

Υ.Γ. Ναι μου χρειάζεται η 5.5, προσθέτει πολλά νέα πράγματα που θέλω να χρησιμοποιήσω σαν developer.
"There is only one problem with common sense; it’s not very common."
– Milt Bryce

Άβαταρ μέλους
hostdog
Δημοσιεύσεις: 9
Εγγραφή: 30 Νοέμ 2011 20:21
Τοποθεσία: Θεσσαλονίκη
Επικοινωνία:

Αναβάθμιση σε PHP 5.5

Δημοσίευση από hostdog » 04 Μαρ 2014 14:29

Το documentation του ίδιου του Virtualmin: http://www.virtualmin.com/documentation/web/multiplephp δεν σε βόλεψε; (απλά χρειάζεται να αλλάξεις μόνο το repo στο αντίστοιχο που θες http://people.redhat.com/rcollet/php55/rhel-php55.repo )


Φιλικά,
Παναγιώτης

Άβαταρ μέλους
giannis17
Honorary Member
Δημοσιεύσεις: 1215
Εγγραφή: 06 Ιαν 2005 19:50
Τοποθεσία: Παγκράτι - Αθήνα
Επικοινωνία:

Αναβάθμιση σε PHP 5.5

Δημοσίευση από giannis17 » 04 Μαρ 2014 18:48

Φίλε μου το έχω δοκιμάσει και παίρνω ακριβώς το ίδιο error. Δεν μπορεί να περάσει το php55w-common

Δεν έχω δοκιμάσει την παράμετρο skip broken
"There is only one problem with common sense; it’s not very common."
– Milt Bryce

Απάντηση

Επιστροφή στο “Apache, IIS, DNS Servers”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες