Πρόβλημα με hosting

Τεχνικές και μόνο Συζητήσεις για WEB hosting servers, Mail servers, DNS servers. Όχι αναζήτηση υπηρεσιών εδώ!

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Alehandro
Δημοσιεύσεις: 26
Εγγραφή: 19 Δεκ 2009 13:50
Τοποθεσία: Ηλιούπολη
Επικοινωνία:

Πρόβλημα με hosting

Δημοσίευση από Alehandro » 03 Σεπ 2015 12:38

Καλημέρα σε όλους!
Θα προσπαθήσω να είμαι λιτός και περιεκτικός, για να μην σας κουράζω.

Καταρχάς, να πω ότι διατηρώ έναν dedicated server στην Ολλανδία (δεν σχετίζεται με το πρόβλημα, αλλά κολλάει στην υπόθεση), τον οποίον και χρησιμοποιώ χωρίς πρόβλημα πολλά χρόνια τώρα.
Τώρα, στο κυρίως θέμα, πρόκειται για μία ελληνική σελίδα η οποία (η ομάδα μου κι εγώ) θέλουμε να φιλοξενείται στην Ελλάδα, οπότε και επιλέξαμε την tophost στην οποία φιλοξενούμαστε εδώ και ένα μήνα (πριν βγάλουμε την σελίδα μας live στα social media κλπ).

Το πρόβλημα είναι ότι κάθε χρήστης αντιμετωπίζει σημαντικό HTTP Delay (αν το λέω λάθος συγχωρέστε με, εννοώ ότι σε κάθε request από τον browser μέχρι να ξεκινήσει να φορτώνει η σελίδα —και όσο δηλαδή γράφει connecting to...), της τάξης των 2 έως 20+ δευτερολέπτων.
Φυσικά, η σελίδα είναι "βαριά" (joomla 2.5, music portal με πολλές φωτογραφίες, λειτουργώντας με k2, συνολικού μεγέθους χωρίς τα backup του akeeba γύρω στα 2+ GB), αλλά αυτό δεν σημαίνει ότι επιτρέπεται τέτοια (μεταβλητή) καθυστέρηση.

Η TopHost αρνείται (με ευγενικό τρόπο) να ασχοληθεί σοβαρά με το θέμα, απαντώντας ότι "το gzip compression μπορεί να γίνει καλύτερο" (...). Τους έχω στείλει φωτογραφίες από διάφορα diagnostics (mxtoolbox, google pagespeed insights, mozilla console / firebug) δείχνοντάς τους το τρομερό delay. Έκανα ακόμη και reverse lookup και βρήκα τις άλλες δύο σελίδες που φιλοξενούνται στον εν λόγω σέρβερ και έκανα τα ίδια tests (αλλά και ως user, εμπειρικά), παρατηρώντας το ίδιο αναθεματισμένο delay.

Ωραία ως εδώ. Πήρα την σελίδα όλη και την φόρτωσα στον ολλανδικό σέρβερ για να δοκιμάσω delays:
- Όταν τρέχει στην tophost, με databases της tophost, κάνει από 1.5 έως 20+ δευτερόλεπτα (μέχρι και timeouts).
- Όταν τρέχει στον σέρβερ μου, με databases του σέρβερ μου, κάνει σταθερά 2.8 δευτερόλεπτα.
- Όταν τρέχει στον σέρβερ μου, με databases της tophost, κάνει σταθερά 8.5 δευτερόλεπτα (ίσως έχει να κάνει με την έξτρα προσπάθεια να συνδεθεί σε δύο σέρβερς, οπότε είναι λογική η επιπλέον καθυστέρηση).

Παρεμπιπτόντως, έτρεξα τα παραπάνω τεστ και για την σελίδα /administrator (που έχει εμφανώς μικρότερο delay λόγω περιεχομένου). Τα αποτελέσματα είναι περίπου τα ίδια:
- Όταν τρέχει στην tophost, με databases της tophost, κάνει από 0.5 έως 20+ δευτερόλεπτα (μέχρι και timeouts).
- Όταν τρέχει στον σέρβερ μου, με databases του σέρβερ μου, κάνει σταθερά 0.4 δευτερόλεπτα.
- Όταν τρέχει στον σέρβερ μου, με databases της tophost, κάνει σταθερά 2.2 δευτερόλεπτα.

Τι μπορεί να συμβαίνει;

Σας ευχαριστώ εκ των προτέρων! ^_^

Άβαταρ μέλους
Giannis78
Δημοσιεύσεις: 1334
Εγγραφή: 11 Οκτ 2005 12:45
Τοποθεσία: Assigned by DHCP
Επικοινωνία:

Πρόβλημα με hosting

Δημοσίευση από Giannis78 » 03 Σεπ 2015 16:27

Καλησπέρα,

Λαμβάνεις κάποιο μήνυμα 508 - Resource limit is reached?
Αν ναι μπορεί να οφείλετε σε υπερβολική χρήση resources και προφανώς θα έχουν CL και κόβει τα connection.
Στον δικό σου server είναι πιο γρήγορο γιατί μπορεί να πάρει όλη την επεξεργαστική ισχύ η την μνήμη η και μπορεί να κάνει χρήση IOPS σε μεγαλύτερο βαθμό.
Όλα αυτά σε ένα shared hosting με CL περιορίζονται για να διαφυλάσσετε η κατάσταση του server.
WebHosting Services
http://www.intechs.gr

Άβαταρ μέλους
CyberCr33p
Honorary Member
Δημοσιεύσεις: 3195
Εγγραφή: 06 Νοέμ 1999 01:00
Τοποθεσία: Αθήνα
Επικοινωνία:

Πρόβλημα με hosting

Δημοσίευση από CyberCr33p » 03 Σεπ 2015 16:37

Προφανώς εάν κάνει 20 δευτερόλεπτα να φορτώσει ή γίνεται timeout δεν μπορείς να την φιλοξενήσεις στον συγκεκριμένο server. Χωρίς πρόσβαση διαχειριστή στον server ότι απαντήσεις και να δώσει κάποιος εδώ, μπορεί να έχουν ή μπορεί να μην έχουν σχέση με την πραγματικότητα.

Alehandro
Δημοσιεύσεις: 26
Εγγραφή: 19 Δεκ 2009 13:50
Τοποθεσία: Ηλιούπολη
Επικοινωνία:

Πρόβλημα με hosting

Δημοσίευση από Alehandro » 03 Σεπ 2015 17:21

Καταρχάς, ευχαριστώ πολύ για τις έως τώρα απαντήσεις!

@Giannis78
Δε λαμβάνω μηνύματα 508, απλά αργεί υπερβολικά να κάνει connect (για να ξεκινήσει να φορτώνει την σελίδα, την οποία ουσιαστικά φορτώνει εντός 2 δευτερολέπτων).
Στις περιπτώσεις που έκανε timeout, απλά μου έβγαζε το κλασικό μήνυμα timeout.

@CyberCr33p
Να τονίσω ότι το HTTP delay είναι μεταβλητό, από ~2 έως 20+ δευτερόλεπτα, δεν κάνει πάντα 20 δευτερόλεπτα (αλίμονο). Συνήθως, όμως, βρίσκεται στα 7-9 δευτερόλεπτα, το οποίο βρίσκω τραγικά υψηλό.
Κι εγώ αυτής της άποψης είμαι, ότι δηλαδή δε γίνεται να φιλοξενηθεί σε τέτοιον σέρβερ. Απλά μου κάνει εντύπωση το γεγονός ότι αυτό συμβαίνει στην tophost (δεδομένου ότι δε διάβασα τέτοια ή ανάλογα παράπονα πχ εδώ μέσα), όσο και το γεγονός ότι το support της εταιρείας μετά βίας ασχολήθηκε εδώ και 15 μέρες, παρότι τους παίρναμε και τους ξαναπαίρναμε τηλέφωνο και παρότι μας διαβεβαίωναν ότι "όλα θα είναι έτοιμα μέχρι το site launch". Το site launch ήταν προγραμματισμένο για την περασμένη Δευτέρα και, εν τέλει, μέχρι τότε δεν είχαν καν αφομοιώσει ότι φταίει ο server τους, ενώ το ίδιο πιστεύουν ακόμη και την ώρα αυτή.

Όταν μιλάμε για πρόσβαση διαχειριστή στον server, να υποθέσω ότι το (limited, ως πελάτης shared hosting) plesk login που έχω δε θα σας βοηθήσει περαιτέρω;

Άβαταρ μέλους
Giannis78
Δημοσιεύσεις: 1334
Εγγραφή: 11 Οκτ 2005 12:45
Τοποθεσία: Assigned by DHCP
Επικοινωνία:

Πρόβλημα με hosting

Δημοσίευση από Giannis78 » 03 Σεπ 2015 17:25

Όπως σωστά ειπε και ο Χρήστος αν κάποιος δεν έχει άποψη απο τι γίνετε πισω στον server ειναι λιγο δύσκολο να πει με σιγουριά ποιο είναι το θέμα.
WebHosting Services
http://www.intechs.gr

Alehandro
Δημοσιεύσεις: 26
Εγγραφή: 19 Δεκ 2009 13:50
Τοποθεσία: Ηλιούπολη
Επικοινωνία:

Πρόβλημα με hosting

Δημοσίευση από Alehandro » 03 Σεπ 2015 17:38

Πάντως, από την στιγμή που είναι αυτή η κατάσταση με τα diagnostics tests που έκανα στον NL dedicated και στην tophost, δεν συμπεραίνετε κι εσείς ότι φταίει ο server τους;
Υπάρχει περίπτωση αυτή η μεταβλητή καθυστέρηση να οφείλεται στους DNS (μου φαίνεται αρκετά απίθανο);

Άβαταρ μέλους
CyberCr33p
Honorary Member
Δημοσιεύσεις: 3195
Εγγραφή: 06 Νοέμ 1999 01:00
Τοποθεσία: Αθήνα
Επικοινωνία:

Πρόβλημα με hosting

Δημοσίευση από CyberCr33p » 03 Σεπ 2015 17:41

Δεν νομίζω να πάρεις δημόσια απάντηση σε αυτό για ευνόητους λόγους από τη στιγμή που αναφέρεις το όνομα του webhost.

Alehandro
Δημοσιεύσεις: 26
Εγγραφή: 19 Δεκ 2009 13:50
Τοποθεσία: Ηλιούπολη
Επικοινωνία:

Πρόβλημα με hosting

Δημοσίευση από Alehandro » 03 Σεπ 2015 17:59

Κατάλαβα! Συγγνώμη κιόλας εάν παραβαίνω κάποιον κανόνα, δεν είχα τέτοιο σκοπό, ούτε να δυσφημήσω την εταιρεία, παρά να καταλάβω λίγο καλύτερα τι μπορώ να κάνω εγώ για να λυθεί το ζήτημα.
Όπως είπα και στους ίδιους, "εάν είναι σφάλμα του website μας και εμείς πρέπει κάτι να αλλάξουμε στη διαχείριση, να μας το πείτε".

Άβαταρ μέλους
gvard
Honorary Member
Δημοσιεύσεις: 2149
Εγγραφή: 16 Μάιος 2002 22:38
Τοποθεσία: Τραχανοπλαγιά
Επικοινωνία:

Πρόβλημα με hosting

Δημοσίευση από gvard » 04 Σεπ 2015 00:19

Καλησπέρα,
Alehandro έγραψε: Υπάρχει περίπτωση αυτή η μεταβλητή καθυστέρηση να οφείλεται στους DNS (μου φαίνεται αρκετά απίθανο);
Οχι, οι DNS δεν έχουν σχέση με αυτό που αναφέρεις. Αν τρέξεις καπάκι 2η φορά τα ίδια test βλέπεις τα ίδια αποτελέσματα;
Με εκτίμηση,
Γιώργος Βαρδίκος
Φιλοξενία ιστοσελίδων - Cloud Servers στην Ελλάδα

Alehandro
Δημοσιεύσεις: 26
Εγγραφή: 19 Δεκ 2009 13:50
Τοποθεσία: Ηλιούπολη
Επικοινωνία:

Πρόβλημα με hosting

Δημοσίευση από Alehandro » 04 Σεπ 2015 00:33

Καλησπέρα!

Όχι, και αυτό ήταν κάτι που με απασχόλησε σημαντικά. Δηλαδή, κατά βάση, όταν ρίξω ένα τεστ (ή ένα request ως χρήστης), τα επόμενα tests/requests είναι γρήγορα, μέχρι το επόμενο spike. Μπορεί να είναι μπαρούφα αυτό που λέω, αλλά εμπειρικά αυτή την εντύπωση έχω...

Έχουν υπάρξει φορές που το delay έχει επαναληφθεί ή επαναλαμβάνεται στα αμέσως επόμενα tests/requests, αλλά ποτέ δεν έχω πετύχει καλό response time όταν είναι idle.

Άβαταρ μέλους
gvard
Honorary Member
Δημοσιεύσεις: 2149
Εγγραφή: 16 Μάιος 2002 22:38
Τοποθεσία: Τραχανοπλαγιά
Επικοινωνία:

Πρόβλημα με hosting

Δημοσίευση από gvard » 04 Σεπ 2015 07:55

Καλημέρα,

Μπορείς να κάνεις ένα test με το http://tools.pingdom.com/fpt/ και να μας κάνεις share το αποτέλεσμα;
Με εκτίμηση,
Γιώργος Βαρδίκος
Φιλοξενία ιστοσελίδων - Cloud Servers στην Ελλάδα

Alehandro
Δημοσιεύσεις: 26
Εγγραφή: 19 Δεκ 2009 13:50
Τοποθεσία: Ηλιούπολη
Επικοινωνία:

Πρόβλημα με hosting

Δημοσίευση από Alehandro » 04 Σεπ 2015 16:14

Καλημέρα!

Δεν ξέρω πώς να κάνω share ακριβώς το αποτέλεσμα, αλλά μπορώ να πω ότι το έτρεξα αρκετές φορές:

α) Του πήρε 12.09 seconds συνολικά, ενώ το load time μέχρι να κάνει connect (πρώτο request) ήταν στα 6.5 seconds.

β) Του πήρε 17 seconds συνολικά, νώ το load time μέχρι να κάνει connect (πρώτο request) ήταν στα 6.1 seconds.

γ) Του πήρε 6.7 seconds συνολικά, ενώ το load time μέχρι να κάνει connect (πρώτο request) ήταν στα 3.1 seconds.

δ) Του πήρε 11.01 seconds συνολικά, ενώ το load time μέχρι να κάνει connect (πρώτο request) ήταν στα 5.9 seconds.

ε) Του πήρε 3.89 seconds συνολικά, ενώ το load time μέχρι να κάνει connect (πρώτο request) ήταν στα 0.75 seconds.

στ) Του πήρε 11.64 seconds συνολικά, ενώ το load time μέχρι να κάνει connect (πρώτο request) ήταν στα 6.2 seconds.

.... etc

(attachment)


Τρέχοντάς το στον Ολλανδικό σέρβερ:

α) Του πήρε 4.08 seconds συνολικά, ενώ το load time μέχρι να κάνει connect (πρώτο request) ήταν στα 0.9 seconds.

β) Του πήρε 4.76 seconds συνολικά, ενώ το load time μέχρι να κάνει connect (πρώτο request) ήταν στα 1.87 seconds.

γ) Του πήρε 3.83 seconds συνολικά, ενώ το load time μέχρι να κάνει connect (πρώτο request) ήταν στα 1.9 seconds.

Όπως φαίνεται και στο attachment, είχε και αυτός τα spikes του, μόνο που η διακύμανση ήταν σαφώς μικρότερη.

(attachment)

Αυτά, πάντα σύμφωνα με το pingdom.
Συνημμένα
tophost-pageloadtime.png
Tophost
(18.07 KiB) Μεταφορτώθηκε 96 φορές
leaseweb-pageloadtime.png
Ολλανδικός
(16.72 KiB) Μεταφορτώθηκε 82 φορές

Alehandro
Δημοσιεύσεις: 26
Εγγραφή: 19 Δεκ 2009 13:50
Τοποθεσία: Ηλιούπολη
Επικοινωνία:

Πρόβλημα με hosting

Δημοσίευση από Alehandro » 17 Σεπ 2015 15:57

Σας ευχαριστώ όλους για τις απαντήσεις και το ενδιαφέρον που δείξατε (εδώ και σε πμς).
Πήρα την πρωτοβουλία να μελετήσω τα πακέτα που προσφέρετε, χωρίς να μου υποδειχθεί από κανέναν σας, και αποφασίσαμε ότι η hyperhosting ανταποκρινόταν περισσότερο στις ανάγκες μας, οπότε και προχώρησα συνεργασία με την εν λόγω εταιρεία.

Παρότι είμαι σίγουρος ότι δεν θα είχα πρόβλημα με την φιλοξενία του site σε οποιονδήποτε εκ των εταιρειών των οποίων τα πακέτα μελέτησα, θα ήθελα να σας πω ότι (όπως αναμενόταν) το πρόβλημα το είχε η tophost και όχι το website, αφού στην hyperhosting τώρα κυριολεκτικά πετάμε!

Απάντηση

Επιστροφή στο “Apache, IIS, DNS Servers”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης