forma problem!!!

Ερωτήσεις και απαντήσεις σχετικές με την HTML, XHTML και την κατασκευή σελίδων για το Web.

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
Άβαταρ μέλους
donegr
Δημοσιεύσεις: 43
Εγγραφή: 25 Φεβ 2004 12:26
Τοποθεσία: Σαντορίνη
Επικοινωνία:

forma problem!!!

Δημοσίευση από donegr » 26 Απρ 2004 14:59

Pws mpwrw na kanw na leitourghsei mia forma?
Pi8anon na 8elei kapoio script, 3erei kaneis ti prepei na kanw?
kai pws ginetai na kanw mail box sto site mou?

www.mysantorini.com

Άβαταρ μέλους
Youli
Honorary Member
Δημοσιεύσεις: 1586
Εγγραφή: 29 Δεκ 2000 01:00
Τοποθεσία: Στο ηρωικό Τριπιτσούνι

forma problem!!!

Δημοσίευση από Youli » 26 Απρ 2004 16:28

Θέλεις να γίνεις λίγο πιο σαφής για να καταλάβουμε ακριβώς τι πρόβλημα έχεις? Έχεις φτιάξει μια φόρμα και δεν λειτουργεί ή δεν ξέρεις πως να φτιάχνεις φόρμα?? Δες λίγο το παρακάτω link να δεις αν θα σε βοηθήσει...

http://www.w3.org/TR/REC-html40/interact/forms.html

Και τί ακριβώς εννοείς όταν λες να φτιάξεις mail box στο site σου? :roll:

Άβαταρ μέλους
donegr
Δημοσιεύσεις: 43
Εγγραφή: 25 Φεβ 2004 12:26
Τοποθεσία: Σαντορίνη
Επικοινωνία:

forma problem!!!

Δημοσίευση από donegr » 27 Απρ 2004 12:12

Exw ftia3ei forma alla den leitourgei, ekei pou filojenw tis selides.
Den mporw na katanohsw pws leitourgoun oi formes gia na psa3w gia th lush.
an deis ligo to site kai ton kwdika 8a katalabeis.
Ekei pou htan arxika to site, mou eixan dwsei ena cgi script kai leitourgouse.
to site einai www.mysantorini.com
To allo pou rwtaw einai an mporw na kanw mail box me diko mou mail se ena server pou me filo3enei kai den 3erw an prepei na mou dwsoun kati autoi!!!
Euxaristw ek tvn proteron...

Άβαταρ μέλους
Youli
Honorary Member
Δημοσιεύσεις: 1586
Εγγραφή: 29 Δεκ 2000 01:00
Τοποθεσία: Στο ηρωικό Τριπιτσούνι

forma problem!!!

Δημοσίευση από Youli » 27 Απρ 2004 13:19

Καταρχήν, δεν ξέρω αν το πρόσεξες, αλλά στον κώδικα της φόρμας σου λείπει κάτι...
<P><SUB><IMG SRC="Form_info_name.jpg"border=0></SUB><INPUT NAME="Name"> <SUB><IMG SRC="Form_info_last-name.jpg"border=0></SUB><INPUT NAME="lastName">
<P><SUB><IMG SRC="Form_info_e-mail.jpg"border=0></SUB><INPUT NAME="e-mail adress">
<P><SUB><IMG SRC="Form_info_Country.jpg"border=0></SUB><INPUT NAME="country"><SUB><IMG SRC="Form_info_adress.jpg"border=0></SUB><INPUT NAME="adress">
Πρέπει να βάλεις και TYPE στο INPUT. <INPUT TYPE="text" NAME="name"> κ.λ.π. ...

Και κάτι ακόμα... Δεν είναι λάθος απο λειτουργικής πλευράς, δηλαδή η φόρμα θα δουλέψει ούτως ή άλλως, αλλά είναι καθαρά θέμα εμφάνισης. Έχεις βάλει

<INPUT TYPE="submit" VALUE="SENT">
Ή βάλε value="send" (που είναι ο ενεστώτας του ρήματος, send-sent-sent) ή βάλε type="submitted" :kaloe: :kaloe:

Για το άλλο θέμα δεν μπορώ να σε βοηθήσω... Τί συμφωνία έκανες με αυτούς? Πληρώνεις μόνο για χώρo ή και για mails?

Άβαταρ μέλους
donegr
Δημοσιεύσεις: 43
Εγγραφή: 25 Φεβ 2004 12:26
Τοποθεσία: Σαντορίνη
Επικοινωνία:

forma problem!!!

Δημοσίευση από donegr » 27 Απρ 2004 18:07

nomizeis oti auto einai to la8os?
giati pisteuw oti leipei kai kati allo pio panw ekei pou einai ayto kati den paei kala....

<input type=hidden name="redirect" value="http://www.mysite.com/thanks.htm">
Εικόνα

Απάντηση

Επιστροφή στο “HTML και XHTML”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης